RM not cancelling delay per mode!

Very simple rule here, turn off kitchen lights when motion is inactive after a delay. Ever since updating this rule has a mind of its own. I even deleted it and recreated to the same effect.

You haven't really showed enough of the logs to tell what is going on. I would suggest unpausing the rule within its UI, and then hitting Done. Start with clear logs, and show two full cycles of the logs.

Thx Bruce for looking into this. Here's a fresh cycle, if i stand still and don't let the motion sensor become active then it works perfect. The problems appears when I'm moving around the kitchen and the lights are randomly shutting off without using the delay per mode. If you look at the time stamp from 9:10:02 you can see the rule triggered and the delay started then at 9:10:39 the 3 min delay is somehow over and the lights are shutting off. Hopefully these 4 split up screen shots make sense.

Have you tried finishing the rule with the proper "END-IF" to see if that has any effect? Shot in the dark but hey, worth a try.

Nice catch Ryan, forgot to add that when I recreated the rule. The original rule had the proper END-IF and still did this weird behavior. I just added the END-IF to the new rule and the results are the same unfortunately.

@bravenel while walking around the kitchen and then going back to my logs, this error popped up.
[error] java.util.NoSuchElementException: Cannot pop() an empty List on line 5694 (delayedActs)

There are multiple simultaneous instances of this rule running. Why that is happening is a good question that I don't know the answer to at the moment.

Please take a screenshot of the App Status page, where the Scheduled Jobs are listed, at some point while the rule is active.

Have you rebooted your hub since this started misbehaving?

One other suggestion: Use Motion Lighting for this instead of a rule in Rule Machine. You can get the same result.

Yes I rebooted shortly after I did the update. I was actually using Motion Lighting for this originally but it also gave these mixed results. Sometimes it works but most times the delay was not completing fully. This lead me to set this up in RM instead, ML was more consistent than the RM rule if that means anything.

There shouldn't be 3 pending delayedActs from this rule. Something isn't working right, but at the moment I don't know what or why. I'll have to study this later... It's as if the cancel isn't canceling the delays.

Exactly my thoughts when I went through the app state. Thanks for your time and I look forward to the resolution.

@AutoM8 While I am not knowledgeable enough to help you with this tough issue, I did want to give you a tip that might help you with multi-page screenshots in the future.

I've been using a Chrome extension called Full Page Screen Capture to take screenshots of webpages which extend past multiple page breaks. It's free and works quickly and reliably. Here's an example of what a screenshot of my logs look like:

I'm sorry that I cannot provide advice on this issue, but at least this Chrome extension might save you the trouble of having to upload multiple images when you want to show a long web page.


Thx for the info, I was hoping there was a better way to get these screen shots. Much appreciated.


Good one! The screenshot extension I always used before, Nimbus, never worked for "scroll and capture" on my Hubitat UI. Glad someone found one that works!

1 Like

Hey Bruce just wondering if you've found what's causing this. I see theres a platform update available but I didnt notice anything in the notes. Thx

No, I have not found out what is going on with this. I will put some more energy into it -- got distracted before.

Thx, much appreciated.

I found the cause of this problem. There was a bug introduced at some point for cancel on Delay Actions Per Mode. That's been fixed, and will be in the next hot fix release due out soon.

1 Like

Awesome, thx again.

This has been fixed in Release