RM HTTP GET Bug?

I'm attempting to issue a basic HTTP GET but it doesn't work. The same command works when executed by a browser:

image

Also, although I have Actions selected in the Logging box, no entries appear in the Logs when I click Run Actions.

C-7 v2.2.7.126

An equivalent rule works fine for me (also using sonos-http-api). Make sure you click on "Update Rule" after turning logging on. And then test Run Actions again.

If that still doesn't work, I'd suggest recreating your rule.

1 Like

Creating a new rule worked, thanks.

Would be great if we could 'Generate Error Report' to send the current state of our hub to the dev team to debug these types of issues. Otherwise, who knows how long it will be until the underlying bug is identified and resolved.

1 Like

Any idea why this isn't working?


Issuing the same URL via a browser works as expected and single word Favorites like the one below also work so Favorites that contain spaces are not working.
image

Save the encoded URL to a local string variable and use the variable instead.

Thanks for the suggested workaround but I'd rather the bug be fixed.

Have you tried using the URL encode option in RM? I don't use RM (outside of occasionally testing a rule for someone else), but I know that option was added recently.

1 Like

It was fixed.

1 Like

Have you tried Play Track on the Sonos from RM, as an alternative to sending HTTP?

I've never been able to get Play Track to work, regardless of which Sonos Favorite I choose:

image

image

image

or which Sonos unit:

image

The Commands buttons on the Device page of Sonos devices work fine.

Download the Hubitat app