Rm 5 (2.2.8.152)

@bravenel
I have noticed that the issue with connectors and variables getting out of sync has returned.
This is just one rule with the issue. As you can see the rule thinks the controlSwitch variable is TRUE where it says its connector is off.

Please run the rule with Action logging on.

This is what is in the logs for the rule. and the rule that turns off the control switch.


You will need to turn on every30Mins for the rest of the rule to run. We need to see the part where there is the apparent discrepancy, i.e., IF (controlSwitch = true) THEN...

Also, be sure that the rule page you posted is from immediately after a page refresh, as that is not a dynamic page.

Okay, this is the output, the connector switch was turned off after the first announcement. The last run through the loop I had reset the variable manually to stop the rule.

Not sure if this is related, but the UI thinks the rule has an incomplete if.

What other rules are touching the connector for 'controlSwitch'? Open the device page for the connector ("Mail Reminder Canceled"), and show the In Use By section at the bottom of that page.



The Echo Speaks just uses it as a trigger.

Well, evidently something turned it off while the posted rule ran. What did that?

From its device page, click on Events at the top of the page, and post a screenshot of that. It will show the events for the connector, and hence for the variable.

Okay, I have created an identical rule and it works as expected. All the other rules I have issues with the connectors would have been created at the same time under the same version.
I'll recreate them, no problem. Let me know if you think there is anything to be gained in diagnosing what went wrong.

Did you see the release notes:

You don't need to recreate the rules, just remove and recreate the connectors if they are local connectors.

2 Likes

Ahh, no. sorry for wasting your time. Thanks for the solution.

Actually how do you remove connectors safely?
In the past i experimented with deleting the device, the first time worked fine the second broke the rule.
I see no option on the variable like in RM4

From its device page. Best to remove it from apps first, perhaps by substituting some other device temporarily.

BTW, I found the other bug, with the buttons displayed when they shouldn't be. Thanks.

2 Likes

Download the Hubitat app