RL Only activating level if it changes when turning on

@bravenel
I am trying to set per modes for a group of lights (previous I have only done for a single bathroom light).

I want it so if the light is turned on at say full brightness but the per mode setting is 10, it should adjust it to 10. It seems to work if I turn the light on from the hub by changing the level. If I just turn it ON at whatever the existing level is, the RL is not adjusting the level to the current setting.

I want to turn on the Activate only Activating Switch option also but I have it off right now trying to troubleshoot this possible issue. EDIT: Just tested this setting again and with Activate only Activating Switch turned on I cannot reproduce screenshot #2 below at all, no matter what I do it looks like #1, it says it is activating but then does nothing.

Am I doing something wrong?

#1 Turn on to existing level

#2 Turn on with setLevel (level changing from prior)

Also just noticing this error when commanding the devices from the red/green circle in the RL app.

Please post the portion of Application State that shows "capDev..." There should be a few of those. What mode is the hub in?

Also, what is value of state variable "mode"?

Mode is 4-Night as shown.
I tested the first issue (not the error) probably 10 times earlier, now it works fine...

Here are the capdevs

Still does not work no matter what I do though if I turn on "Activate only Activating Switch"

I need to know value of state variable "mode". From Application State.

Yeah I realized that after posting was just getting screenshot
image

Which switch were you clicking on the circle for that threw the error?

Seems like they all do it, I tried Center, Counter and Sink, all get the error turning on or off but only from the circle button in the app. It is looking in the capDevs0{} somehow only when I use the in app button?

No, that's not what it's doing.

I'm not able to look into this tonight. What you first posted is too complex, with too many moving parts. Please settle on a specific setup, and try again with a new description of what is not happening that you expect should happen. Be very specific, and limit the scope of what you do.

I suspect that the problem is that the light is already on (from turning it on), so it doesn't "Activate" it, i.e., set it to the table value. You could force it to work by turning on the Activation Option to 'Command devices irrespective of ...', and then checking the column that brings up. Tomorrow I will investigate the specific case of 'Activate only Activating Switch'.

No problem I did not expect to even get a reply tonight. Just trying to figure out if I am doing this right or expecting the wrong results. Mainly I was hoping I could have this group of lights with the per-mode settings, but also if someone turns on a single light with the switch the brightness would be adjusted to the correct level for the mode on just that switch without turning on all the lights. I thought that's what the Activate only Activating Switch setting was for but maybe not? Kids often come out in the middle of the night after everything is off and just turn on a single light.

Think about it and let me know tomorrow. If I get this working one way or another I will have another example to post.

Correct. I know what the problem is, and the workaround is what I described above with the Force column.

1 Like

Ok so did you need any more info from me for the activation or the unrelated error message? I wasn't sure what you wanted me to make a new thread for. I will try out the force option tonight and see how it works.

That should work as a work-around. There was a bug with this, now fixed, in the next release.

2 Likes

The activation for one device seems to be working correctly now.

Sadly the button activation (when using one of the devices in the scene) is also locked on to the activating device as well and does not activate the entire scene, I assume this is by design? Which I can understand why, just let me know. I can always add an external rule for the buttons to turn on the activator device if I want, that should turn on the whole thing.

This is a bug. Fixed for next release. It should only do this for switches being turned on.

3 Likes

Download the Hubitat app