RL 2.3.2.139 level not being set upon activation if lights are already on

@bravenel First I noticed tonight the mode had changed and the lights were not adjusted automatically. Possibly due to me installing the update and rebooting. This worked yesterday with v138. Then I tried pressing activate on the rule and nothing, it said activating in the logs but does not do anything. If I turn on the force option and check all the lights then it will adjust the level when I press activate.

Current mode, Center Light I set to 100, the RL app picked up the event somewhere I saw it.
image

This is ALL it logs.
image

Now I am going to turn one light off and activate again, just to see that it does in fact turn it back on.

But the Center light is still at 100%, should be at 15%

Turning the force option on for all lights seems to make it work for now

Oh I found in my logs where the mode changed, it was about 5 minutes after I updated and rebooted
image

Nothing logged from RL about adjusting the lights per the mode

It is subscribed to the mode

Will look into it.

Mode changed to 4-Night and it changed the level now that I have the force option enabled
Not sure why it went to not Active at the very end there, but everything is set how it should be.

image

Turn off the indicator option, and the Force option, and see if it changes on Mode change.

Looks like that did the trick for setting the level. It adjusted the level on mode change and also if I manually activated. I will leave the indicator option off for now.

Uncovered another issue in the process of testing, sorry

Download the Hubitat app