RL All lights turned on during mode change

This is the same Kitchen RL I have been working on. With the force option on at the 6AM mode change to Morning all the lights got turned on from the off state.

Hmm I thought I had the force box checked last night. Could it have unchecked itself somehow?
The only thing I have with mode is to adjust at mode change, I did not think that was supposed to turn them on?? Or is it?

@bravenel Ok I guess it was not the force option, in testing the other issue I also re-tested this. Looks like any mode change is turning everything on. I turned one light off manually then did a mode change

I need an explanation of what the problem is.

When the mode changed all the lights turned on. I am not using mode change as a means to activate. The only place the mode is tied to this is "Adjust lights on mode change" option which I thought would just adjust the level of lights already on, but it appears to be forcing them all to turn on even if they are off.

It "adjusts" them (which could mean turning on) if the app is Active. Was it "Active"? This is a situation where the Indicator could come into play, as if there is one, it controls the Active state of the app. So, for example, if it is set to show any on, and any light is on, then the app is Active and mode change will set all of the lights.

That makes sense since the light could have been off in a previous mode and now you want it on. It probably was active because I turned off the indicator setting due to the other issue. I will play around with it some more and post again if it is not working as I now understand it to work.

1 Like

Looks like it is activating even when the app is "not active"
Here was mode change at 6AM. I can tell the app was not active prior to this because at the end it logged it was active. Otherwise it is very hard to tell which state it was in, nothing else really gets logged. I did have the scene option turned back on despite the other bug we found with it, so since all the lights were off it should have been inactive.

It was Active as far as I can tell from what you've shown. Your logs are inscrutable, but don't show anything to illuminate its state prior to 6:00 AM. The one highlighted log entry reveals nothing. How about the Activator Device state? Look at its Events logs. The Active state of the app is tied to the Activator when you have Indicator in use. And, only if the app is Active does mode adjust do anything.

However, that bug you pointed out before about line 2203 throwing an error is messing up the Active state being set correctly by the indicator. So, until that fix is released, my guess is that indicator is not setting the app state, so it's remaining Active. Try a test: Open the app, if it shows Active at the top, hit Turn Off in the ui. Then change the mode and see if it does anything.

Activator was off at 6AM and then turned on.

But I think as you said that other bug might be affecting it. I did your test with everything off and changing the mode it did not do anything.

And yes something is going on with the scene indicator thing as well. If I just turn one ONE light which is a means to activate it activates the entire app, but it is only supposed to activate that one light and with the scene option set it should not activate the app itself. So if I do that the app is active and then when mode changes it turns everything on.

So yeah... I think this particular thread is solved, its a result of other issues and not a bug in itself.

Going to test it out like this see if this works better. Got rid of the scene/group mode and using the switches to determine all are off. This should make the app not active overnight so it does not all come on at 6AM.

Download the Hubitat app