RGBGeinie ZB-5122

Am not having success installing this switch.

I have paired it and it automatically installs with the ZB-5122 driver.
I have used mirroring to connect it to a light which has already been set up in HE and works otherwise.

I am not sure what I am looking for to diagnose.
When I initially install (before mirroring) there is no response as far as reacting to button pushes. Should there be?

Mirroring setup seems to work fine but still no response from button pushes.

Have removed reset re-paired several times to no avail.

Tried using the ZB-512x driver and couldn't mirror that.

Am I missing something in setting this up?
Has anybody else had success with this?

Thanks for any help.

I think mirroring is mainly for when you have something like a RGB controller, and a RGB panel, where you want to tie the two together. From the release notes:

  • Mirror and Mirror Me child
  • A simple app which sends all available switch, level and color commands from one master device to any number of slave devices.
  • This app was specifically designed for use with controllers that have color wheels and or slider type control surfaces.

Your ZB-5122 device isn't a switch, it is a button. So you should be using some type of button controller, or rule to tie this button to an action.

Can you describe what you are trying to do with this button? Does it turn on some light (dimmable? RGB? Other?), or some other action like running a rule or activating something?

I am wanting to control a single smart rgb light. This is ,as you probably know, a 5 button "wall switch" with one of the buttons intended for 1 scene recall, one for cycling white temperature, one for cycling r g & b and of course 2 for on and off/ bright and dim. I assumed it would be the same setup as my other rgbgenie 3 zone touch panel which works great through the mirroring app.

So, per correspondence with Sean at RGBGenie, the Mirror app is what is required to use these controllers. The functionality is hard-coded in the device.

Also, it seems like I needed to slow things down when setting this up in Hubitat. If I named it and saved it too quickly something broke. It showed up as a devices and everything looked normal but no response from the buttons. So once it was discovered (Which was almost instantaneous) if I waited a few seconds to name it and save it, all was good.

Download the Hubitat app