RF and Heartbeat

I'll make this short. And maybe this is the wrong forum for this.
I am a new user and doing lots of testing.
Before i commission my Tasmota Sonoff devices I need to work out some issues.

  1. Most of my Sonoff devices have RF control. I found that if a device is activated either by RF or local switch my console doesn't show the correct state of the device.
    So that brings me to something that may be there but I cant find it.
    Is there a heartbeat or looping poll of devices?
    I got plenty more issues that i'll have to figure out.

Tagging @markus. He does a lot of dev work with Tasmota.

1 Like

With my Tasmota drivers state is kept correctly inside the device, so that is not a problem. The only requirement is that you need to use my modified version of Tasmota that pushes changes to HE. The release thread is here:

And documentation can be found here:

If one of your Sonoff devices isn't in the drop-down configuration menu in the driver, give me a shout and I'll add it.

1 Like

Both of my Sonoff devices are listed.
4 Channel Pro and Sonoff RF.
Logs on the devices show change of state but I get nothing on the HE logs.
4 Channel Firmware.
Build Date & Time 2019-12-25T12:33:25
Sonoff RF
Build Date & Time 2019-12-25T12:33:25

@ekraus What do you get in the log when you type "setoption113" in the Tasmota console? These look like the unmodified version of Tasmota, you need to run my version of Tasmota for updates to work.

Sonoff RF
Build Date & Time 2019-12-25T12:33:25
02:08:06 RSL: RESULT = {"SetOption113":"ON"}

4 Channel Firmware.
Build Date & Time 2019-12-25T12:33:25
02:02:40 RSL: RESULT = {"SetOption113":"OFF"}

Ok, so that is my firmware, so far so good. Your Sonoff 4 Channel one doesn't have the HE features turned on.
Run these commands:

Emulation 2
setoption113 1
HubitatHost <your HE hub ip>
Example: "HubitatHost"
HubitatPort 39501

With that, check if it works as expected and report back if it does or doesn't and we take it form there.

Here are my results
11:01:21 CMD: Emulation 2
11:01:21 RSL: RESULT = {"Emulation":2}
00:00:00 CFG: Loaded from flash at F5, Count 151
00:00:00 Project tasmota Landscape Lights Version 8.1.0(tasmota)-2_6_1
00:00:00 WIF: Connecting to AP1 KRAUSHOUSE in mode 11N as tasmota-4306...
00:00:05 WIF: Connected
00:00:05 HTP: Web server active on tasmota-4306 with IP address
00:00:05 UPP: Multicast (re)joined
00:00:05 RSL: INFO1 = {"Module":"Sonoff 4CH Pro","Version":"8.1.0(tasmota)","FallbackTopic":"cmnd/DVES_8090D2_fb/","GroupTopic":"cmnd/tasmotas/"}
00:00:05 RSL: INFO2 = {"WebServerMode":"Admin","Hostname":"tasmota-4306","IPAddress":""}
00:00:05 RSL: INFO3 = {"RestartReason":"Software/System restart"}
00:00:05 RSL: RESULT = {"POWER1":"ON"}
00:00:05 RSL: POWER1 = ON
00:00:05 RSL: RESULT = {"POWER2":"ON"}
00:00:05 RSL: POWER2 = ON
00:00:05 RSL: RESULT = {"POWER3":"OFF"}
00:00:05 RSL: POWER3 = OFF
00:00:05 RSL: RESULT = {"POWER4":"OFF"}
00:00:05 RSL: POWER4 = OFF
00:00:09 RSL: STATE = {"Time":"1970-01-01T00:00:09","Uptime":"0T00:00:11","UptimeSec":11,"Heap":27,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":23,"MqttCount":0,"POWER1":"ON","POWER2":"ON","POWER3":"OFF","POWER4":"OFF","Wifi":{"AP":1,"SSId":"KRAUSHOUSE","BSSId":"60:38:E0:77:F0:FA","Channel":1,"RSSI":34,"Signal":-83,"LinkCount":1,"Downtime":"0T00:00:06"}}

11:04:25 CMD: HubitatHost
11:04:25 RSL: RESULT = {"Command":"Unknown"}

11:02:58 CMD: setoption13 1
11:02:58 RSL: RESULT = {"SetOption13":"ON"}

11:38:39 CMD: HubitatPort 39501
11:38:39 RSL: RESULT = {"Command":"Unknown"}

  • I saw no information in the Hubitat log exercising the local module buttons to change the state of the switches.

Setoption113 needs to be on before hubitathost and hubitatport work. You typed in setoption13 :wink:
Try pressing Configure on the driver page, that should also work.

Thought it was option 13.
And I am still getting command unknown.

Here is what I got
00:00:14 CMD: setoption113 1
00:00:14 RSL: RESULT = {"SetOption113":"ON"}
13:34:44 CMD: HubitatHost
13:34:44 RSL: RESULT = {"Command":"Unknown"}
13:35:09 CMD: HubitatPort 39501
13:35:09 RSL: RESULT = {"Command":"Unknown"}

Is there a command to dump the entire configuration of the module?

At the bottom of the Tasmota device page, does it look like this?


Its the wrong firmware.

Yes, change firmware and it will all work. Just press Configure on the device page in HE and all should be setup correctly.

Yep Thanks it works!

1 Like

Is that the correct firmware for the Basic with RF?

Yes, the 8.1.0 firmware from my github is the correct one.

Great the Basic RF working also.
Now all I need to do is fix the issue with rapid power cycling clearing the config.
Thank you for your help!

1 Like