Return lights to 100% level after fade

I have a couple of Rule Machine automations set up, one example is a kitchen sink light that comes on around midnight and then slows fades off over 120 minutes.

After the light fades down to 1% (it never hits 0 for some reason) it stays at 1% as expected since that was the last time it was on. I want the dimmer to go back to 100% without turning the light back on for 1 second and then off, does anyone else have this issue?

When I dim my lights with Alexa in my tv area, (dimmed to 20%) they stay at 20%. So when i run my routine to "turn on downstairs lights" they all come to 100% except for the living room, which only goes on to the last setting, 20%.

How do i get it to hit 100?

Most dimmers will turn back on to their last dimmed level when they are turned back on from the device itself. What specific device are you trying to control? A workaround might be possible.

The easiest way to solve this would be to change the device to one that allows for a default level setting (leveiton dimmer or GE motion dimmer) or one that always ramps to 100% (Lutron Caseta). The other possibility is that when the device is turn on physically is to turn it up to 100% but that will depend on whether the device reports a physical turn on and whether the driver reports that it has physically been turned on. The other possibility is to ramp the dimmer back up to 100% when it is equal to 1% at certain times of the day, the times it is not dimmed down low later at night. So, the possibilities are numerous. Many of which will depend on what device you are using.

I am using HomeSeer devices, i dont want to swap out all of them at this point ($50 x 15 devices will be expensive)

What routine are you using? Is that an Alexa Routine? Or are you using something on the Hubitat side?

In either case, are you turning the lights "ON"? Or are you setting their dimmer level 100 in the routine? You'll want to set their dimmer level to 100 instead of just turning them 'on', if possible.

The group is form Hubitat, but the command is run via Alexa,

I am not sure I follow completely...but it sounds like you created a Hubitat Group of lights. This group is being set to 100% via an Alexa Routine... Is this correct?

My guess is that the group device in Hubitat is still 100%, even though not all of the devices within that group are still at 100% due to other changes that have been made (i.e. setting some lights to 20%.) Changing devices within a group independently of the Hubitat 'group device' is bound to create some issues like the ones you're seeing.

Perhaps what you really want is a Hubitat "Scene" which should make sure all devices are set to their correct values? Just a guess...

I am trying scenes now but they seem inconsistent in function, for example now my Sharptools integration is slow to show what lights are on or off.

There is a really easy way to fix this problem. I thought your original question was about when you turn the device on MANUALLY with the switch. That is when the light will return to it's previous state. If you are issuing a command by another means, then you just need to modify the command that is being issued. Instead of turning the device ON you just have to set the level of the dimmer to 100%.