Restrictions set in my Apps

I am having a heck of a time with "restrictions" in my apps. I don't know if others are as well, I didn't see much when I searched. For example, I had a rule (keyword being "had", I abandoned it because the restrictions were not reliable) that sometimes the a restriction put into place on the entire rule would not be followed or it would be followed when it should have been. This rule was tied to changing the temp of an AC unit so that led to rooms being way too hot or way too cold and I couldn't deal with that and switch to using the thermostat controller app instead.

Now, I am trying to use the Hubitat Safety Monitor. It works well for the most part but I have custom rules tied to a switch (disable when off, enable when on) and the same thing is happening. The app page never updates to the accurate status unless I actually go into the rule, then it will update. For example, I have turned my switch off, so the custom rules should be restricted. They are not even after refreshing the page:

Now, I go into the first custom rule, it says "Restricted" on the top of the page, which it should:

Now, I click to go back to the App page, and that custom rule says "Restricted" as it should, but notice the 2nd one still is not restricted and won't be until I go into that rule:

I would be perfectly fine with this, chalk it up to caching perhaps and it is just a view, no big deal. But, I feel this is truly affecting the app and not sending alerts when it should when armed. Anybody else seeing this or have any ideas? Again, I was seeing this same sort of behavior with a rule in Rule Machine as well and seemed to have the same affect on that rule.

I don't use HSM but have seen similar behavior with RM and what-not. Basically, the app page isn't dynamic. So, if you load the page and then trigger the restriction, it the app label will not update until your refresh the page (in your case, that was done by going into the instance and back out).

As with pretty much any other app...if you feel like something isn't working properly, your first step is to enable logging, reproduce the issue, and see what the logs tell you.

I'm not sure what you mean by "refresh" the page. I get the App page isn't dynamic, but to "refresh" the page one would think that one would just need to hit the refresh button in the browser instead of having to go into the app and then back out to get a refresh? As you can see in my example, one of the rules/apps updated only after I went into it, then back out, the other one didn't, I would have to go into that rule/app for it to update and then back out...Further, I could click to empty the cache and hard reload the page and still have no impact on the proper setting...I'm also not seeing any logging for HSM...I may be missing it, but it isn't in the obvious areas as with other apps...not sure that would show much because the issue is the restrictions are not being lifted or put into place properly, at least, that was the case with the rule I abandoned in RM.

This is what I meant by refresh the page. You didn't explicitly say you tried refreshing the page so I didn't want to assume.

Ah, yes...sorry. I hid that pretty deep in the post with "They are not even after refreshing the page:". I should have had that at the front. But yes...refreshing, hard refresh, navigating to the page after setting the switch, all do not refresh the App page to show the accurate setting.

Anybody else have any other input? Wonder if it is just happening with me and, if so, how I could do something that wrong....LOL!

So, this seems to be affecting more and more apps as time goes on (now thermostat controllers and button controllers along with the aformentioned rule machine and security), which is just unacceptable now. Since it has been so long since the first post and it seems I am alone with this issue I am going to just start retiring apps and build out a different platform because this stuff just needs to work reliably.

Can you show a sample of an app running into the problem?

Thank you for your persistence, FriedCheese2006. All of the information plus a sample is provided in the very first post, despite conversation in later posts/replies about trying things I had already tried in the first post (Rule Machine: restrictions do not update reliably and usually not at all unless actually go into the rule, Hubitat Security: sometimes will not update unless go into the app--example above, Thermostat Controller: actual temperature does not update reliable unless go into the app) and no refresh of the page (regular refresh, hard refresh, whatever) makes no difference at all. I will also point out that I tried to monitor the memory with Hubitat Information driver but my memory always stays above 300K so not thinking that is problematic.

At this point, I'm not spending more time on diagnosing the problem. There is clearly an issue as things "used" to work well and I haven't been crazily adding devices since I am quite a few years into the game now. I just wanted to put a cap on this particular thread with an update from me because I get frustrated searching through community to find a thread applicable to what I am seeing and then it just gets abandoned by the OP. If there are others with the same issue out there seeing this, then I was not able to figure out what is causing it. I am already in the process of migrating to a different platform.

@bobbyD :arrow_up:

1 Like

If you run out of options, there is always the last resort to send @support_team a private message so we can take a look at your hub's engineering logs to see if we can figure out what's going on.

1 Like

Thank you for that. I, seriously, forget about simply reaching out to support. That was going to be my plan B but, turns out plan A worked remarkably well! Now the apps page, particular HSM, show the proper status every time I refresh. My guess is my hub was overworked and I was becoming one of those folks that would need to regularly restart the hub because free memory would dip below 320k within a couple of days and seems my hub doesn't care for that so I am avoiding regular restarts now, too!