Repeated Error 500 with no apps or devices

My C-4 Hubitat has been generating repeated error 500 and corrupted database found messages. I have performed repeated soft resets and hub shutdowns and restarts. I have reduced the apps and devices loaded to zero except for the Basic Rules and the hub still gives me error 500 and corrupted database found even though I have not restored anything and reinitialized the hub. Is my hub basically dead? The hub version is 2.3.4.134. The diagnostic tool version is 1.1.110. There are no messages in the log to indicate why this is occurring.

Since you seem to have turned off everything, try doing a soft reset again but do NOT restore a backup. That turns the hub back to the day you got it, and registered it, but before you did anything. Now let it run for a while. I'm going to bet you don't get those errors. :slight_smile:

let us know...

3 Likes

After you follow @csteele 'ss advice, go to settings>>backup and restore and click the download button at the bottom and save it to your pc. Shut down the hub, unplug for 5 mins at the wall not the hub and power back up. Now do the soft reset and on reboot use the download you made to your pc, not the onboard ones.

Thanks for the reply, I will give it a go and let you know how it turns out.

1 Like

Okay, I am still getting the error 500 after doing a soft reset without backup restoration. I have performed the soft reset three times over the past three days and I am still getting the error 500 after a several hours of running time. Is my hub broken? I have not followed rlithgow1's advice since I keep getting the errors every day.

Roll the platform version back to the last version that you didn’t have these errors (using the Diagnostic tool). Do a soft reset without a database restore. Do you still get the errors?

I have the same issue with a backup C-4 device that I recently brought up for the first time. It fails repeatedly after a few hours, just like you described.

I haven't seen this issue at all on my other C-4 which is my main production and development environment.

Maybe @gopher.ny has suggestions on possible fixes for this?

Can you PM me the hub id for the hub that's having issues? As long as it's accessible from the support tool, I can check the engineering logs.

Looks like it happens on C4s without radio stick plugged in.
If you want to run the hub without the radio, please disable both Zigbee and Z-Wave from the Settings - Zigbee details and Settings - Z-Wave details page. Otherwise, it will try to restart the radios time and again and will eventually fail.

2 Likes

That's the setup I am using. I just disabled Z-Wave and Zigbee and will report back if it fails again. Thanks for the tip!

This i will try.
Wishing for instructions on disabeling both radios.
Was quite convinced that i had, further checking, they came ?back? on.
Hope this works, have tried numerous solutions posted in several threads.
If not 2 new C7's should be here today.

I did it on these two pages:
http://hub_ip/hub/zwaveInfo
http://hub_ip/hub/zigbeeInfo

Then I rebooted for good measure.

1 Like

Thank you.
Heres hoping.

1 Like

This appears to have fixed the issue for me. My spare C-4 has been up for over a day now, and it used to fail in a few hours before. Thanks again!

3 Likes

Download the Hubitat app