Removing Z-Wave Switch

I have a zooz z-wave switch that has stopped communicating. It works locally but not through Hubitat. I have another switch that I want to replace it with but I cant remove it from Hubitat.

in z-wave details I hit refresh. After it thinks for a minute I have the option to remove, I click remove and it thinks for a minute again. The switch remains as pending in z-wave details. I've tried a reboot and that doesn't help.

Am I missing a step? What's the proper way to remove a z-wave device?

Have you looked at the compatibility list List of Compatible Devices - Hubitat Documentation and looked up your device? There should be instructions on deleting and adding you device if you select it.

Yes, I should have added that I tried a proper exclusion using the instructions from Zooz & Hubitat. The switch flashed but never did the handshake with the hub to exclude.

Have you tried cutting power to the switch (air gap or shut off a breaker) and then trying to remove it? You may have to try multiple times.

1 Like

Thats the usual way. Also you can exclude at least with the toggle style switches by clicking down 4 times (usually).

if it won't let you exclude it, go to your devices, and click remove. after about 30 seconds, it'll give you the option to force remove the device