Remotec ZRC-90US

I have copied and edited the code from "erocm123 : Remotec ZRC-90 Scene Master" and see events for Button pushes. However the controller is not available for selection as a button controller in Apps.
Any advice? See pics.

Yes, we changed the way buttons work. See this post:

https://community.hubitat.com/t/hubitats-button-implementation/283?source_topic_id=316

@bravenel I get the following:
Sorry, you don’t have access to that topic!

add “pushablebutton” as a capability, and change the send events to something like
sendevent(name: “push”, value: {button number, probably a variable})

@ajpri1998 I get the following error after adding the capability.

Metadata Error: Capability ‘pushablebutton’ not found. on line 24

I believe the capabilities are case sensitive and it would be PushableButton

Also, I believe the event is: sendEvent(name: "pushed", value: {buttonNumber})

1 Like

sorry, that was 100% by memory. @josh had it correct

We have fixed this. You should have access now, or very shortly.

1 Like

I got the controller to show up as an option and will adjust the sendEvent when the post above becomes available (probably tomorrow as it’s almost time for bed).

Thanks for all the help thus far.

Got it working guys. Muchas Gracias!!

3 Likes

I'm in the UK and have recently started setting up my new Hubitat to replace my very frustrating VeraPlus.

I have a Remotec ZRC90EU which I have managed to connect using stephack`s device driver. It was a PITA to get paired but finally It is on the system and I have a couple of button controller events programmed. However, pressing the appropriate buttons gives 4 quick flashes of the blue LED, the programmed action doesn't occur and nothing appears in the device event log. Any ideas? I presumed the US version commands would be the same as the EU but I'm now wondering if that's not the case.

Yeah, mine took about 10 attempts and I had to hold the device right next to the hub to pair.

When it paired, did it initially set itself as a generic driver or did it automatically use my custom driver?
If it went to the generic first, did you hit save and then configure after selecting the custom driver?

I think it was marked as device unknown initially then I picked your driver for it and clicked save. Maybe I should remove it and start again?

That shouldn't be necessary. That is usually how 3rd party devices get added.

Open the device page and click the configure button and test the remote again. If that doesn't work..go to Setting-> Zwave Info and make sure the remote is listed as Alive. Also check for any strange looking or blank devices. I remember when trying to pair this controller I ended up with a bunch of ghost devices. I had to remove them all, including the one I felt was valid and re-pair it again.

I've tried the configure button again with no change. Under the Zwave settings list the Remote shows as FAILED but in the device page is it showing as ACTIVE.

I had a lot of difficulty pairing this bad boy initially, so my guess is that it did not complete the pairing process properly.
I will rely on the expertise of @mike.maxwell on this one.

In the meantime, try to remove the remote and pair again. Do this VERY close to the hub and leave it there for at least 2 full minutes. It can take a long time to complete the process. Make sure to delete any ghost devices in the zwave information page before attempting to pair again.

I've removed and re-paired it with the remote lying right on top of the Hubitat Zwave dongle (it was more like full on mating than remote pairing!) and left it for 10 mins. The blue light on the Remotec stopped flashing after a short while but I left it anyway. The Hubitat never did list the device in the normal way. But a device did appear in the Zwave list which I then allocated to the Remotec device driver and it seemed to understand. This is the same as happened before but there is now a slight improvement in that it shows as ACTIVE in the Zwave table. However, still nothing happens when I press the buttons, to either the allocated button commands or in the Device Event Log.

I appreciate all of your help stephack, but I think I will put the Hubitat in a drawer for a while and wait until it's a bit more developed.

I currently use 3 of these remotes for my Vera, and if it is going to be this much of a pain to set them up on Hubitat, I would be jumping out of the frying pan into the fire to switch my system over.

I wouldn't be so hasty. This is not a standard device and took a while before it was working with ST reliably as well. The button controller app that is built in to Hubitat is not built to utilize the double taps on this device as well.

Also, I never updated the logging code (original author devised a custom method for logging) in the driver I ported from Hubitat because the effort to reward ratio was too low for me. I may revisit it in the future but right now it does not log events in the logs. You should be able to see the button presses in the device event list though. If i registers there, the device has been successfully paired and setup in HE.

Also, I adapted my Advanced Button Controller app to support this remote and shared it here.

I think it simply isn't pairing properly. I get the quick flashing blue led for every button press (which on Vera at least means the command has not been accepted by the controller) and nothing appears in the devices event list. My device details don't have the data that yours does for doubleTapped, held & pushed. My only entries there are battery, checkInterval and numberOfButtons. I will try to re-pair it again later. I've just checked out your ABC app which is perfect!! If only I can get this thing paired properly I will definitely be using that. Seeing all the button press settings in one screen is ideal.

I get 2 quick flashes with every button press on mine. I believe this is the same way it worked on SmartThings.
If I press and hold, it waits until I release and then I get the 2 flashes, so it seems to indicate when the remote sends the update that the button has been handled in some way.

Did you hit the configure button after re-paring as well?

Download the Hubitat app