Remote Admin and Cloud Dashboards not working for one hub

I've emailed Hubitat support, but I assume they're busy with the new version released yesterday, so I thought I'd try here too.

I have 2 hubs at my main house. But I also have a hub at a vacation condo, about 2 hours away from here. What I've found is that the condo hub will periodically lose its ability to be contacted through cloud connections. What I mean by that is, right at this moment, the connection is down. And here are the symptoms:

  • Right now, if I try to go to its cloud dashboards, I just get a page saying "No response from hub".
  • If I go into the "Registered Hubs" section of, the condo hub doesn't show in the list. I only see the 2 hubs at my main house.
  • They recently added a "Registered Hubs" section to the mobile app. Oddly, the condo hub DOES show up in there. But if I try to use remote admin from in there, it never connects. (Remote Admin in the mobile app DOES work for my other 2 hubs. So it's not an app problem.)

It seems to reconnect if I reboot the condo hub, but of course, I'm 2 hours away. I set up a Rule Machine to reboot the hub nightly, and that helps somewhat, but I'm still finding that I can't connect remotely a good chunk of the time.

Now, what could it be? I think the most likely culprit is the combination modem/router at the condo. The only ISP there is Suddenlink, and they don't allow you to provide your own hardware. You have to use their combo device, which is an Altice One box. It's not as configurable as I would like, and doesn't let me set the Hubitat to a static IP from the router. I did use the new networking features to set a static IP on the Hubitat itself. And it seems to be sticking with the same over time. But I suspect that the modem/router is doing something that causes the hub to lose connection to Hubitat's servers.

Does anyone know any way to debug this? Are there non-standard ports that the hub uses to connect to Hubitat's servers? (So maybe the router's firewall is blocking things?)

CC: @bobbyD @bcopeland

The hub (id ending with 6b) is not responding to the support tool either, so its internet/cloud connection has dropped.

Was the hub dropping network while using DHCP? Its last cloud check-in (which happens on reboot) was on 4/23. If it reboots nightly, that means it missed quite a few check-ins. I suspect assigning a static IP without making a change on the router isn't going to work.

It uses MQTT ports 1883/8883 to talk to the cloud to get cloud dashboard and to start remote access session.

Yes, this was happening when using DHCP.

Ah, that's interesting. I'll investigate whether the router allows me any control there.

This is the other weird thing. I was there in person one time when it lost cloud connection. It did respond to local requests - I could log into it with my browser on wifi. It just didn't respond if I, for example, turned off wifi on my phone and tried to access the cloud dashboard over LTE.

That was definitely a router thing.

How often does the hub try to reconnect to your cloud? If it loses connection, is it just waiting until the next reboot? Or does it self-correct?

Because those MQTT ports can't be completely blocked by the router, because the dashboards often do work over cloud.

It detects when a cloud connection down. 2.2.6 and earlier versions attempted to reconnect every 4-5 minutes. 2.2.7 does it about twice a minute.

Oh, that's interesting. The hub is still on 2.2.6. It's odd that rebooting it fixed things, but the 4-5 minute reconnection didn't. Smells of something strange going on in the router.

i get the exact same thing.. any cloud links are not working smarttiles etc.. and not a browser cache as i cleared cache and tried from both chrome and ie and different machines..

restoring to 2.2.6 and the cloud dashbaords work immediately so it is not some weird network thing.. there is obviously something wrong in the latest firmware regarding cloud endpoints.

also the cloud itself was not down when it was not working on 2.2.7 the hub could reach the cloud as outgoing email and the tesla integration worked fine.

I'm on 2.2.6, so we might have different problems. That said, I do think it's possible (in my case at least) that my hub can talk to the internet, but cannot reach Hubitat's cloud for some reason.