Reliability is gone

I don't think you will see scheduled event for sunset unless you use an offset. Then it will put the offset time in as a scheduled job.
As for your issue have you checked to make sure your location and time zone are correct?

You should see something in Event Subscriptions if you go into the settings cog and and scroll down.

image

Have you tried the built-in Simple Lighting app? This is a simple automation; on at a specific time and off at a specific time and is well suited for that app. It’s not a fix for a problem that shouldn’t exist, but it may get you on a faster path to stability.

There should not be a scheduled job at 12:01 AM. That happens only once for rules with before sunrise triggers. For your sunset trigger, there should be a Subscription to the sunset event. Like this:

Are you sure there's not another process changing the state of the lights?

Pick one of the items you're turning on that shouldn't have anything but this rule changing it's state. Maybe Christmas Tree? Look at that device in the Devices section and scroll to the bottom. You'll see a 'In Use By' section that shows everything that's using that device. I've had a few rules I deleted that weren't in the Rule Machine list anymore but the rules were listed under a device. I could click them in the 'In Use By' and then delete them again which did remove them completely.

THanks for all the input so far... I am working through the suggestions.

I see that the time zone and location is all correct... but is there a place to see what TIME the Hubitat actually thinks it is currently?

I am not finding that at the moment... probably overlooking the obvious.

Go to
Settings -> Hub Details
image

EDIT: You can also use a local NTP server if you wish.
I sync up to my RPi to ensure everything is OK after a power blip.

Thanks! My time is correct so the mystery is still unsolved . :slight_smile:

I have found the same problems lately. Hub has become unreliable. I hadn't changed anything and yet sometimes the rules that were running smoothly don't run for some reason. Like last night my night routine to turn the heat down and turn off the lights didn't run. At 2:30 I got up because I was so hot and noticed all the lights still on and the heat still up. This rule usually runs but for some reason it didn't. And this is happening more and more. Hub freezes. Can't get into it using port 8081 so I have to pull the plug. Then I have to rebuild the database and then it runs ok for about a week and then things start happening again.

1 Like

Hi @pcgirl, I didn't know about rebuilding the database... maybe I should try that. I will search for instructions. thanks - and I hope we can get back to good on these things....

@pcgirl have you contacted support????

If you have pulled the plug you may need to do a soft reset. Do a backup and download it then run the reset procedure.
https://docs.hubitat.com/index.php?title=Soft_Reset

This happens to me about once every week or two on three of my 5 hubs. There are two characteristics that distinguish two of those hubs; first they are the older model C-4 hubs with the external radio stick, and the second is that both hubs are more heavily loaded (> 200 devices each). The third hub is a “stickless” C-4 hub which is my HubConnect server with >540 devices, mostly virtual.

The hubs are crashing. No blue light, only solid red. If I reboot them once a week the problem almost completely goes away. I’m convinced it’s a resource leak somewhere.

Well I only have maybe 40-50 devices, if that and it is the C-4 hub with the stick on the side. Most times I have a solid blue light but I can't access the hub. Sometimes it is red. I have sent support a request to look at it.

So is there a way to periodically reboot the Hub weekly without just cutting power? I also have emailed support on my issue(s) but nothing yet.

Thanks!

every 3 weeks for the last 3 months my hub becomes unresponsive.
I am not getting red device lights, but externally and locally the hub is unresponsive so I have to do the :8081 and reboot it / soft reset.
Support have said its an issue with telnet and to slowly remove my wemo / tp link devices to see if that fixes it. It also affects my yeelights that were randomly staying on when triggered with a motion rule.
I constantly chase support / Bobby every 3rd day, all they come back with is that engineering is looking into it. No suggestions, no information, just, we're looking into it.
It is frustrating cause everything about HE I really like, and when it works for long periods and you completely forget about it its bliss. But when it goes bad and you cant isolate the problem - thats the worst lol

Thanks for that info. Yeah this HE is fantastic compared to what I used to use... but even a few reliability issues make me very nervous... we kind of count on this stuff to work at some point... I am hoping to hear from support soon.

@bobbyD Do you have a ticket for @kv1 kv1?

I believe my case number is . 15265 . -- I submitted it yesterday. I figured they are catching up from the long weekend . :slight_smile:

Have you tried updating/installing the latest version of Rootin’ Tootin’ self-rebootin’? (0.91). It’s been very good at catching these errors and self-healing from them. I’ve also been testing something else and have high hopes that it fixes those telnet/socket issues.

Yes :slight_smile: You can use a rule to send a POST (form encoded) command at a certain time to http://your_hub_ip/hub/reboot

I installed a heatsink on my C-4 and it’s been good ever since. No issues like that on my C-5... I’d recommend to see what support has to say about there thoughts there, if it’s a C-4.

How? The c4 has a thermal pad and a piece of metal to transfer the heat, did you removed those? What heatsink? For Rpi?

Thanks