[Released] Rule Machine 3.0


#184

What error?

Please use screen shots instead of copy/paste.


#185

image


#186

Ah, so whatever is happening is because of Adjust Dimmer, right? Will investigate...

Update: Yes, there is a bug with Adjust Dimmer. Found and fixed, next release.

So this had nothing to do with IF-THEN...


#187

Okay. Thanks for fixing it.


#188

It got busted when I put in the code to allow Global Variables to be used in these dimmer actions instead of just numbers. Many things that were numbers became strings, and have to be changed back into numbers to do math on them --> adjust dimmer does math...


#189

Hi Bruce @bravenel,

  1. Was playing with repeat-until infinite loop and it looks like it doesn't work the way it's described.

Repeat-Until loop

Repeat
some actions
IF (condition) Stop
End Repetition

There is no Stop action type exists in Delay and Repeat Action drop-down box, but without it the infinite repetition doesn't stop.
I've figured out that stopping this rule will stop repetitions, but it's very confusing, because this action type is selected from another drop-down box(Set private Boolean etc.)

Working example:

Repeat every 0:00:01
On: Butler
Off: Butler
IF (Backyard Door Contact open FALSE) THEN
Stop Actions: This Rule
End Repetition

So my point is that End Repetition doesn't work.

  1. Custom command names
    Now we can name Custom Commands which is extremely useful. Unfortunately these custom names are visible only in the main Rules section. When user wants to pick up the actual custom command to use in the rule from the drop-down box the name there is still built-in.

#190

Stop is an action under "Run/Stop/Pause Rules", not under Repeat. You would use Stop This Rule.

These are the command names of the "custom commands", the command of the device in question. They are what they are, not really subject to be renamed.


#191

I've already figured it out, but it will be additional point of confusion from my point of view.

I didn't get you.
I have 3 custom commands calling Alexa routines for my IR managed fireplace which are formatted as executeRoutineId('amzn1.alexa.automation.automationid), where automationid is a 36 symbols string representing Amazon internal id. How I'm supposed to distinguish between them if I can't give each a custom name?
And in this case what is the benefit to give custom names for custom commands?


#192

@bravenel

Getting an error after latest hotfix on a rule I've had in place for quite some time.


I tried re-building the rule and using both a decimal/number GV same results.

thanks


#193

I will try something similar. It appears to come from the Delay 0:10:00.


#194

Mine works with no error. Please turn on rule logging, and give screenshot of entire sequence for that rule when it fails.


#195

Ok, I tweaked the timing and conditions to make it happen quicker so here is the example and logging.



#196

Have you deleted this rule and rebuilt it from scratch? If not, please do so. After that, repeat with the logs just like above.


#197

Deleting a rebuilding seems to have done the trick!

Edit: I ended up having to delete and re-build every rule that used a "repeat" but now I'm running without errors on the current build.


#198

You had worked on that previous one for some time (I could tell). Editing actions can sometimes mess things up. I've tried hard to make it not prone to such things, but your rule is the living proof that it isn't perfect by a long shot. When you have a rule that acts strangely, first thing I'd try is to remove it and try again, especially if it's been edited a bunch. You error was for True.10, which meant that delay was the 10th action you'd put in that rule. And yet it was the first one. Hmmm.


#199

How does the "start raising/lowering dimmer" action work. As in how does it determine how fast/slow to raise the dimmer or at what level to start?


#200

I'm also have a few rules that were working in the previous hotfix release, that are not working in the most recent release. Throwing errors.


#201

This is today's mystery. See if opening the rule and hitting Done makes it work right again. If not, remove it and recreate.


#202

Yes, I did that (see below), and the rule ran and sent a pushover notification (the lack of which when I went out earlier was my first hint something was up)

When I hit: run this rule, the rule ran.
When I hit: update this rule, the rule did not run (or, at least I got no notification)
When I hit: done with rule, the rule did not run, (or, at least I got no notifcation).


#203

I also had a few lighting rules which didn't run today. Tried recreating a few to see if they stick tomorrow.