[RELEASE] Z-Wave Firmware Updater

I never got it to completely work. While I can extract what looks to be a valid firmware, and it flashes 100%, the device never reports that it is running a newer version than I started with.

I don't know if this issue has been resolved with the new hub and it's updater feature, but with my C-5 it completes but never indicates it's actually running a new version.

1 Like

I've run into another issue where Zooz support has asked me to exclude a device and I'm not sure if I have any other choice for troubleshooting . I wanted to understand the DNI swap trick to avoid the hassle of redoing a lot of automations. Is there any more info or guide on how to go about doing this?

1 Like

Excuse me for answering but there’s a good guide and explanation on changing DNI’s HERE

4 Likes

I'm experiencing an issue on my Zen27 where the switch can only be operated manually. Looking at the device settings I see the following states:
image

It is stuck in the pending changes state. I don't recall when this started but it may have been after I attempted to do a firmware update to 3.04. When I look up the firmware for the switch I don't even see it:

When I try to update via fimware updater I see the following:

The log is registering commands from the hub but the switch is not actually turning on. I have tried configure and refresh buttons several times but no luck.

I'm currently using the Zooz Zen Dimmer Advanced DTH and I've tried reverting to the original DTH and that gets rid of the pending changes state but it does not do anything to control the switch from the hub.

Finally, I've tried a z-wave repair but that didn't help either.

Appreciate any assistance as I can't think of any other troubleshooting steps.

@alexcapone If the firmware update worked, often times with Zooz the device will factory reset itself afterwards. I think they do this in case parameters have changed so it gets a clean start. You need to join the device back to the network. Check out this guide I made on how to get it back in using the same node:

I tried to replace and put it into inclusion mode but it says it failed:
image

When I backed out of the page it says "Pending"

I don't remember if that was there before I tried the replace process. I'll try restarting the hub and bringing it closer to the switch.

Can Habitat do an OTA firmware upgrade on an HSM 200? . If the topic has been discussed - appreciate a link so i can rsearch further. thank you.
Mac

Hi @bcopeland can you please help me with updating leviton DZPA1? I cant find the bin file in that zipped file.

Thank you

Hi, could you please post the ZW117 hex file again? It is no longer at above location. Thank you.

Can you please provide more detail on how to do this? To be more specific, what does the start / end of the section looks like and exactly where to trim to/from?

1 Like

I'm new to Hubitat and I'm curious, now that the C-7 has a built-in Device Firmware Update App (with instructions here), are there any reasons an owner of the C-7 hub would use this Firmware Updater vs. the built-in one? I ask partly because Inovelli's firmware update instructions point to this Firmware Updater, and don't mention the built-in one, which seems like an endorsement of this updater, but it could just be that the instructions haven't been updated for the new app yet (or they wanted generic instructions for all hubs).

PS: I did skim through this entire thread, and didn't see a direct answer to this question, but I only skimmed, and I could easily have missed one of the 1351 posts before this. If that is the case, sorry.

Bryan wrote both this and the built-in updater app. Inovelli's instructions are older and predate the newer app; they should really be updated. I initially used this to update one of my Red dimmers, but I used the built-in app to update other 7 Red dimmers.

I have a Zooz Zen32 I’m trying to update. Does the target I choose matter? Zooz didn’t give me any suggestion on that. Thanks!

Target is the existing firmware on the device

When I run the firmware updater it asks for a target number from a drop down menu with options 0-5. I just didn’t know which to pick, or if that matters. I saw someone post for an Inovelli device to choose target 1 for a binary file. I didn’t know if that’s the same for the Zooz.

It's usually Target 0, but not always. Contact zooz support before attempting.

@bcopeland

By any chance could you still temporarily re-post the "Aeotec-ZW117_RangeExtender_Gen6_S0_US_A_V1_05.hex"? One of my Aeotec v6 repeaters is out-of-date and I've not yet figured out how to fully unpack the binaries from Range Extender 6 (ZW117) firmware update. (1/15/2018) : Aeotec Help Desk

Alternatively -- if you may not have the hex package still, might you be able to share any detail on how I can unpack it? I've tried tinkering with pev ( GitHub - merces/pev: The PE file analysis toolkit or https://pev.sourceforge.io/ ) without much success yet.

Thank you in advance. :]

He doesn’t seem interested in doing this via the forum now that he’s an employee of Hubitat. I’ve messaged him privately several times without a response, My guess is for legal reasons.

As a result I’ve emailed support to see if they can help.

2 Likes

Unfortunately we cannot help as Aeotec support doesn't share their files. Your best route would be to reach out to them directly.

2 Likes

@bcopeland knows how to extract the drivers from the Aeotec executable.

Download the Hubitat app