[RELEASE] Z-Wave Firmware Updater

If you're on recent hub firmware (version 2.2.1 or later, released June of 2020), there's no reason to do this: you can use File Manager to host it locally on the hub, then get the URL from there. Add port "8080" (alternative to the default of 80 which you'll need if you're hosting and updating on the same hub), so something like http://yourHubIP:8080/local/yourFileName.gbl.

That being said, I have one of these and think I just gave up trying to update it from Hubitat and used PC Controller instead. Similar problem IIRC where it insisted it was sleeping but shouldn't have been, but I can't recall anymore...

2 Likes

I tried PC Controller as well.

No go.

:confused:

All my blinds are working perfectly.

I just have one blind on 3.01 so I will just live with it.

Thanks for the help!

:slightly_smiling_face:

@nkyspike i followed the same procedure without success........started the update, it did not even finish getting the current version, it just went straight to "wake up your sleepy device"........... any suggestions?

I received an update firmware file from Zooz for my Zen27 (v 3.03). I went through the update and got a successful confirmation. However, when I go to the device page the it shows current firmware of 3.00. When I asked Zooz they asked me to factory reset the device or exclude/re-include which I don't want to do since I've already integrated the device into various smartapps and automations within Hubitat.

Is this a device issue or a something related to HE not refreshing the correct firmware on the device page?

If you can still control the device from the hub then you should not need to exclude it and re-include it. Test by trying to turn it on and off from the hub. If that works then try running a configure and it should refresh the firmware version (this can depend on the driver you are using).

If you do need to re-include it, there are ways to keep your rules working. One is to do a zwave "replace" which is finicky and sometimes refuses to work. The other way is to NOT exclude it, do a factory reset on the device and then include it again creating a second device, then swap the DNI's so that the old device now has the new DNI listed. The new device must have the original DNI so you can delete it. Then you should be able to force remove the newly created device (which now has the old DNI attached).

1 Like

Wouldn't it be easier to do as I have seen others do and create a dummy virtual device and use it to replace the current device in the rules using it? Then exclude and reset and put the original device back in the rule(s). Still potentially lots of editing, but maybe less error prone than the DNI approach?

1 Like

If you only have one or two things tied to it maybe. But even a dashboard, a rule, and a scene or two and that would get annoying having to edit them all twice. Less risky though if you are not comfortable doing the other trick. Swapping the DNI is pretty painless once you understand how it works.

2 Likes

Great idea. I had never thought of this before. Will probably take this approach next time I have to factory reset something.

@agnes.zooz What are the latest firmware revisions for your 500-series switching devices? The support web page still shows 3.01 is the latest for the Zen27. Would be nice to see the changelog updated so we know whether or not there's something useful in a later release. For example, I have occasional (less than once per month) events where a device in my house will just stop responding to paddle presses or Z-wave commands and needs a hard power cycle to get working again. Always the same 3 devices... 2 of them are Zen27s and 1 is a Zen26. Nothing in the HE logs indicates trouble, and everything else in the house (> 60 zwave devices) continues to work normally. The problem is so infrequent that it's almost impossible to troubleshoot... I'm curious to know if there are zwave-specific improvements made in more recent firmware versions that might help solve the annoying lock-ups.

1 Like

@mbaran
This is first set of instructions I have found for Extracting Aeotec binaries from the firmware .exe. I am attempting for the first time to update firmware on a number of different devices from Aeotec that I have. I have Multisensor 6s, Door/Window sensors 7, Siren 6, Repeaters, and Smartswitch 6s.

Since these instructions are a year old, my questions for youare: Are these instructions still complete and correct? Have they ever failed and resulted in bricking the devices or other tragedy using the HE Device Firmware Upgrade feature? Have you used this technique on any of the above devices successfully using the HE Device Firmware Upgrade tool? If yes, what devices and versions?

As you can tell I am a little leary of trying this given that it is not totally straightforward and automatic. Any help or assurance would be welcomed.

LJ

I never got it to completely work. While I can extract what looks to be a valid firmware, and it flashes 100%, the device never reports that it is running a newer version than I started with.

I don't know if this issue has been resolved with the new hub and it's updater feature, but with my C-5 it completes but never indicates it's actually running a new version.

1 Like

I've run into another issue where Zooz support has asked me to exclude a device and I'm not sure if I have any other choice for troubleshooting . I wanted to understand the DNI swap trick to avoid the hassle of redoing a lot of automations. Is there any more info or guide on how to go about doing this?

Excuse me for answering but there’s a good guide and explanation on changing DNI’s HERE

3 Likes

I'm experiencing an issue on my Zen27 where the switch can only be operated manually. Looking at the device settings I see the following states:
image

It is stuck in the pending changes state. I don't recall when this started but it may have been after I attempted to do a firmware update to 3.04. When I look up the firmware for the switch I don't even see it:

When I try to update via fimware updater I see the following:

The log is registering commands from the hub but the switch is not actually turning on. I have tried configure and refresh buttons several times but no luck.

I'm currently using the Zooz Zen Dimmer Advanced DTH and I've tried reverting to the original DTH and that gets rid of the pending changes state but it does not do anything to control the switch from the hub.

Finally, I've tried a z-wave repair but that didn't help either.

Appreciate any assistance as I can't think of any other troubleshooting steps.

@alexcapone If the firmware update worked, often times with Zooz the device will factory reset itself afterwards. I think they do this in case parameters have changed so it gets a clean start. You need to join the device back to the network. Check out this guide I made on how to get it back in using the same node:

I tried to replace and put it into inclusion mode but it says it failed:
image

When I backed out of the page it says "Pending"

I don't remember if that was there before I tried the replace process. I'll try restarting the hub and bringing it closer to the switch.

Can Habitat do an OTA firmware upgrade on an HSM 200? . If the topic has been discussed - appreciate a link so i can rsearch further. thank you.
Mac

Hi @bcopeland can you please help me with updating leviton DZPA1? I cant find the bin file in that zipped file.

Thank you

Hi, could you please post the ZW117 hex file again? It is no longer at above location. Thank you.

Download the Hubitat app