[RELEASE] Xiaomi Mijia Smart Light Sensor GZCGQ01LM (Zigbee 3.0)

This sounds like an easy job with WebCore which I recommend, especially if you have any programming background.

You can set it so if Light sensor has a value of X for over X minutes, then...

Sensor arrived today just now, paired w/out issue, illuminance and battery level appeared w/out any additional actions after pairing, which worked just as instructions said it would. Excellent!

The device is much smaller than I expected (that's good). From the pics it looked like it was going to be 2-3" across, but it's nicely small and discreet.

Thanks for the post and the driver, very well done.

@markus' drivers use presence to track whether or not the device is still present in the network, since Xiaomi/Aqara devices are flakey and prone to becoming non-responsive. Threw me at first as well.

4 Likes

The driver adds a presence attribute to the device. The existence of a presence attribute causes the system to recognize the device as having presence sensing capabilities.

4 Likes

Brilliant, works much better than what I hacked together. Thanks.

Getting some errors using this sensor in the Simple Automations app to turn on a light when the reading is <15. Any suggestions on what may be causing this?

Line 474 in the driver...if the line reference is to the Simple Automations app, I can't see that code.
image

Firstly, I´d like to thank the developer directly from Brazil: the driver was working very well to me! But I had an issue and needed to factory reset my C7 hub, and updated it to the latest firmware. Now the sensor isn´t working anymore, the illuminance isn´t displayed. Some tips?

Thanks in advance,

Marcus

I'm up to date with my C7 and am using this driver with good luck

Driver

JohnRob, you probably updated your C7 with the driver installed, correct? I reset and updated mine; the driver was working well before the problem I had in a previous firmware version, but now, with a new firmware fresh install, the illuminance isn't displayed...

I tried another brand new sensor I had here with the same result: no illuminance information...

Yes Correct. Now I'm afraid to change the driver.

However you might try BoristheCat driver called "Clean Device" you select it as a driver and there are options to wipe:

  • State variables
  • Child devices
  • Schedules.

You would then change back to the normal driver.

JohnRob, I spent an evening trying to make it work, and solved using the driver written by Roberto . It is working flawllesly to me!

But I accepted you suggestion, I'm downloading the Clean Device driver to perform maintenance, thanks a lot!

1 Like

Are these's true Zigbee 3.0? and will work will all repeaters unlike the old Xiaomi devices?

I have one on the network right now (I just got another but have not added it yet) since June. It has stayed on the network. I have a Xiaomi cube and it falls off a lot. However, I haven't figured out what the light sensor is repeating through so it is a hard to say for sure.

I can confirm that these devices must be configured next to the hub, and not via some kind of repeater.

I'd been struggling for days to get it paired but finally took the plunge and moved it into the garage to pair it with the hub.

Within 10 minutes, I was getting LUX readings...

1 Like

What repeaters do you have? all mine are smartthings plugs so all Xiaomi 1.2 devices dropped off

I've got a could of the Aurora AONE Sockets, and some Innr plugs as well - I'm not sure which device they were struggling with, but moving to the hub to pair and then moving it away again worked perfectly.

1 Like

I can confirm this. These devices are very difficult to pair through any repeater. Once paired (close to the hub), they work fine through repeaters. FWIW, the repeaters that I have are: Tradfri outlets, Tradfri USB repeaters, and @iharyadi's zigbee environmental sensors.

2 Likes

Good to know. I've got four of these, and all have been stable. I paired all of them right next to my hub, not through the five repeaters (Iris smart plugs). I've had them about a month and none have fallen off yet.

1 Like

Anyone know the difference between these two versions of the driver? I don't see anything in the thread about it.

1.0.1.1123 - I have installed

1.0.1.1123b - currently on github

Download the Hubitat app