[RELEASE] Xiaomi Mijia Smart Light Sensor GZCGQ01LM (Zigbee 3.0)

Any tips on how to get this device to pair? The manual is in Chinese and I could not find an english version. (Hub: Firmware

I have put the Hub in Zigbee pairing mode, held the side button down for 5 (ish) seconds but nothing shows up and there are no entries in the log (except for the Start and Stop Discovery. One of the websites mentioned a "blue" light when pairing, but I am not seeing anything.

UPDATE: I managed to get it working and it's reporting battery and illuminance!! I had to hold the button down for about 7-9 seconds and then I saw the blue light flash.


I'm using this driver for my Mijia Light Sensors. I just moved one over from SmartThings and recreated the automation using a single Simple Automation Rule.

And today when it should have turned on the light, it didn't. Initially I couldn't figure out why until I checked the logs and found:
java.lang.NumberFormatException: For input string "21.0" on line 636 (luxHandler)

So to successfully used this driver in automations, you need to change this preference value from the default 1 to 0:

You might want to give this one a go as I'm using it with two of the light sensors successfully:


I looked into your driver before posting. I just wanted to post here in case anyone else ran into the same problem. The setting to remove the decimals does fix the problem.

In my case I was not able to solve the crazy battery or illuminance reporting with Marcus’ drivers (tried everything).

Chirpy’s ones did the trick.


Perhaps you meant to respond to someone else and not @chirpy? I'm pretty sure he was referring to his own drivers :smile:

I was adding to Chirpy’s comment where he was suggesting to try his version of the drivers (yep, I know), since they worked for me after multiple tries with Markus’.

Just for unlucky guys trying with Markus’.

1 Like

Thanks @chirpy for this, had one of mine drop off and would not recover using Markus' driver.
It seemed to be dead with no reporting and no device side-button response (3 quick flashes) after pairing.
Tried the device side-button 5 sec. re-pair and 10 sec. reset multiple times to no avail.
Loaded up your driver and after the 10 sec. device side-button reset/discovery/pairing it's back up and reporting normally (and also doing the device side-button = 3 quick flashes again).


hi i do someting wrong because i cant go over this


need help

From memory it took a lot of tries until the illuminance finally showed up on mine and I had to do it right next to the hub.

I did it close to the hub.
and i tried 100 times.
From point 4 many times

I had better luck with a different driver, maybe give it a try... :point_down:

1 Like

Thanks i will try

+1 for the Xiaomi Aqara Mijia driver that Ranchitat mentioned. These were the most difficult sensors to configure. Had to be right next to hub and took a few attempts

1 Like

i hope it will work
It was frustrating yesterday stay till 1:00 in the night trying and trying.... and trying

There is some special procedure to dio after the pairing?

After a series of attempts I have configured 3 devices
now it works


What did you do to actually get the lux value reported?

Please don't post the same request in multiple threads. Keep responses at your other post at

1 Like

Sorry - thought I was posting to discussions about different drivers - a bit confusing as people refer to alternatives.

Download the Hubitat app