[Release] Xiaomi / Aqara ZigBee device drivers

community_driver

#966

Oh, at most a second, but really less than a second. It results in a slight lag when used in a lighting automation. I could do a test to compare them though!

However, Iris V1 Motion Sensors don't have a light / lux sensor. It's important to understand that even with the Aqara sensor, the lux reporting capability is limited, because it's only reported just after motion detection is reported (and is restrained by the sensor's 60 second "cool down" time on motion detection). You mentioned you have "Xiaomi motion sensors" and if those are really the Xiaomi model then they don't have any light / lux sensor at all.

Well, because the Hubitat and SmartThings hubs have different ZigBee radios, the Zigbee mesh network routing topography is likely different, which means that end devices would likely "choose" a different parent (either the hub itself or a repeater) when you moved over to Hubitat. That could then reveal that some of your ZigBee repeater devices aren't "friendly" with your Xiaomi / Aqara devices.



I only have one myself, and it is the device that most frequently drops its connection, though it has remained connected for up to 6 months without interruption. Just based on everything I've read, the leak sensor has the most connection issues. I should also point out I have the "original" revision of the Aqara Leak sensor with the contacts that are screw heads. The "new" revision has button-face contacts that can't be unscrewed.

Perhaps the connection issues are due to interference from the metal parts? I'd love to try cracking mine open and add more of an antenna lead, but that would of course ruin it's use as a leak sensor because it needs to be waterproof!



My foggy crystal ball says most of us won't be able to get any of the new ZigBee 3.0 certified Aqara devices in our hands until the end of the year, or even early next year.

Yes the T1 devices are the ZigBee 3.0 certified ones. There are also some I've seen with "S2" added to the name which will be ZigBee 3.0.


#967

Thanks!
Have to say that the "old" sensors have been working flawlessly for the last couple of years on ST, and the last 2 weeks on HE. No issues at all, since i improved the mesh.


#968

Has anyone had event logs show nothing for 24 hours on the aqara motion sensors ?

Mine are still triggering events but nothing recent in events. Main status page of device shoes active state etc..

Edit. Turns out it wasn't just this device. All devices stopped logging events a restart fixed it. Also foijd my hub slowed down to a halt yesterday and had to restart to get it responsive in the web interface


#969

This might be a stupid question, but is there a way to reduce the number of decimals for temperature readings? I just updated to the latest driver, and that one has two decimals compared to one for the older driver and for my other temp sensors.

It's purely cosmetic tbh, looks rather stupid on the dashboard with two decimal values. Especially when the precision in the sensor probably is a long way from such a precise reading. :slight_smile:


#970

I can add a preference to set the number of decimals for temperature, humidity, etc. readings (0, 1, or 2), but for now the only way to change it (globally) to 0.1 precision output is to edit line 129 of the code from:

temp = temp.round(2)

to

temp = temp.round(1)

I agree, and will probably make the default 0.1 precision (tenths).


#971

@veeceeoh Have you noted any recent changes to the Aqara motion sensors? I just added a new one that is acting flakey (either slow or refusing to go active until the pairing button is pressed a few times) on HE, but performing perfectly when I pair with my Aqara hub.

Is there any info I can get you to help determine if there's yet another HW version to contend with?


#972

I haven't read any reports from users that would lead me to believe there has been any hardware revision (other than the yet-to-be-released new certified ZigBee 3.0 T1 version).

To my knowledge, every hardware revision change came with a new ZigBee model designation, so that would be the way to check. Have a look in the device details page for the motion sensor, near the bottom. The Aqara Motion Sensor's ZigBee model is lumi.sensor_motion.aq2. Note that sometimes the model text gets truncated or the correct length isn't correctly determined during the pairing process so it may show up either too short (e.g., lumi.sensor_mot) or with superfluous garbage characters at the end.

The behavior you are describing sure sounds like ZigBee mesh issues (weak signal or an "unfriendly" repeater), or possibly due to a dying battery.

Also, has the motion sensor in question been "hacked" to detect motion every 5 seconds?


#973

Yes, it's a lumi.sensor_motion.aq2. I just finally got it working (for now anyway). Seems like I might have just finally gotten a flakey one. Not something I'm used to. So far all of their devices have worked perfectly with HE. I'm sure this would pass their QC since it does pair easily and works as expected with the Aqara Hub.

It did not have the 5 second hack, but the other one in my kitchen did have the hack, and was working fine, so I decided to try it on this one too. What I found out is it will not go inactive at all when paired with the Aqara Hub if it's been hacked. It needs your driver settings to set it inactive after a time period.

Usually, after the hack is applied, I can set them anywhere between 5 seconds and whatever I want. But for some reason, this one will stay inactive if I don't enter something in the inactive time-out field, and it will flip back and forth between active and inactive if I enter 5 seconds. Once I enter 4 seconds in the inactive time-out field, it seems to now be working fine.

So for now, it looks like I can work with this one. I have a few more coming that I can replace this with if needed. I can always remove the hack and use it somewhere else paired to the Aqara Hub.


#974

I think this one is a bit wonky, when I go into button controller and set the push (it says it has 4 buttons, but its one button with 4 presses) it comes out like this, does that mean it will fire the mode off that many times ?


#975

Well, I have now had to re-pair my motion sensor 3 times.
It seems to lose connectivity, quite easily.
Should wait 1.5-2 hours after pairing to see if it is still inactive? (i.e. for it to check in?)


#976

Not wonky. :joy:

As shown in the charts that I posted when you asked about the buttons before, the different types of presses are simply assigned to buttons 1 - 4.

Think about it. Hubitat only has these events available to use for button drivers: pushed, doubleTapped, held, and released.

You have an original revision Aqara Button WXKG11LM, which sends different messages for single, double, triple, and quadruple clicks. So how can I assign them all to one button number if there's no tripleTapped and quadrupleTapped events available?

This is why I decided to assign the different number of clicks to different button numbers for the original revision Aqara Button WXKG11LM and the Xiaomi Button WXKG01LM (which even does quintiple-clicks!)

Bottom line, in your rule / app / automation, just assign the button number equal to the number of clicks you want to result in that action, and the action will only happen once.



This really sounds like a ZigBee repeater issue, meaning the Motion Sensor isn't compatible with a repeater it's connected to.

In my experience, generally when a Xiaomi / Aqara device has been paired via an "unfriendly" repeater, the Xiaomi / Aqara device will seem to work normally for 2-3 hours with whatever it's main functions are, and even possibly send its check-in/battery reports, and then the connection is dropped.

Pardon me if it's been asked before, but do you have any ZigBee repeater devices?


#977

I have a Ikea Tradfri Repeater only 20 ft away.
So, I moved it closer and it still dropped.
Hmmm... I have another motion sesnsor. I will try that out in its place and see if I get the same "dropping".


#978

Yeah, but do you have OTHER repeating devices that may be incompatible???

You never know which repeater a device picks (unless you look on an xbee, or similar). I've seen devices right next to a repeater pick a different repeater on the other side of my house MANY times.

If you have other repeating devices that are incompatible, you will have recurring issues no matter how many compatible ones you have, as sooner or later the device will likely pick the wrong one.


#979

You can try this.
http://192.168.0.24/hub/zigbee/getChildAndRouteInfo
It will show what repeater is repeating what device.
image


#980

Just be aware that it doesn't always work perfectly, because as I understand it the report is based on routing table data it receives from devices.


#981

Indeed, you make a good point.
And yes, I did check that. (http://ip address/hub/zigbee/getChildAndRouteInfo).
Guess what - it showed that the motion sensor was routing through a Iris outlet that was further away, not the closer Tradfri repeater! (@JasonJoel - you were right!)
How about that!
So, I've:

  1. Shutdown the Hub (another 15 minutes or so to go)
  2. While it's shutdown I've physically removed the Iris outlet
  3. I will restart the Hub , and hopefully it will now route through the Tradfri

I don't know why the Iris outlet is not a good Xiaomi repeater, but apparently it isn't (to be confirmed).
Does anyone know if the Samsung outlet is a good repeater?


#982

Neither the Samsung (edit: that may not be true of the newest model - see post below) nor Iris are compatible with Xiaomi devices.

I've had both, and can confirm that both of them broke my Xiaomi devices.

Although there are multiple models of the Samsung outlet, I only tested one version (not the latest model, 1 version before that).


#983

My and others' experience has been that Xiaomi/Aqara devices can be stubborn in choosing a new ZigBee parent (i.e., a repeater, or the hub itself).

If your steps result in the motion sensor dropping its connection, just remember you should first try to get it back on the network by re-joining it, without deleting it from your hub's device list.

Try, in this order:

  1. Put hub in discovery mode, and short-press the motion sensor's reset/pair button. If this doesn't get it connected, then...
  2. Put hub in discovery mode, and long-press the motion sensor's reset/pair button, just as though you are pairing it. If this doesn't work, then unfortunately, you need to...
  3. Delete the device, and pair it as a new device. Doing this would break any automation / rules though.

The reason why is somewhat technical, but basically Xiaomi / Aqara devices don't check in as often as most ZigBee devices, and most repeaters have a timeout on device checkin which is shorter than that of Xiaomi / Aqara devices, so the repeaters kick them off their device list. Then when the Xiaomi / Aqara devices come back trying to connect, they don't perform a rejoin sequence as asked to by the repeater.

The newest model, Samsung's 2018 Zigbee Outlet - model GP-U999SJVLDAA, has been reported by one user to work as a repeater for Xiaomi / Aqara devices. As far as I know, the other older models are not "friendly."

You probably should have a read through at least the first post of my other thread:

There's lists of repeater-capable devices reported / known to both work and not work with Xiaomi / Aqara devices.


#984

That was me. :slight_smile: I'd love confirmation from others, but a couple devices have worked well routing through it so far for me. It gets hard for me to tell after a while, however, since neither the hub nor XCTU show all my devices no matter how long I wait or how often I try (but as noted above, they seem hesitant to find new routers so I'm fairly confident).


#985

FOOEY!
I specifically purchased two IRIS outlets, becausethey were both Zigbee and Zwave!!
FOOEY! (again)
I have three Samsung (older model) Zigbee outlets!!

Anyone want to buy some outlets???