[Release] Xiaomi / Aqara ZigBee device drivers



I have no idea why, but they’re all working correctly today. I can’t explain it other than maybe something was corrupt in the database and when it cleaned up overnight that resolved it.


Ah, I think I figured it out. I added a TRÅDFRI LED driver, but I was just testing so I unplugged it. I’ll bet that screwed up the mesh and it had time to heal overnight.


That is a very strange thing to happen, especially because the motion reset timer is performed using code that is used in all kinds of drivers and apps. The specific method is runIn() which essentially starts a timer to execute a function in a specific number of seconds.

So if the motion reset function wasn't being run in the number of seconds you've specified, that would indicate something is not working in the execution of Groovy code above the level of the driver (or "below" depending on your view).

For a sanity-check, debug log message output could be enabled, which will allow the reset motion timer confirmation message to be displayed, along the lines of:

Reset to motion inactive after 61 seconds


Seems like this may have been the TRÅDFRI LED as I suspected. They’re all working just fine now.

I moved the LED driver module to Hue instead.


I am SOOO happy I don't have any smart bulbs left. I had so many more network/dropout issues on both ST and Hubitat when I used to have a bunch of bulbs.

Now... Not so much. :smile:


I had issues with bulbs too and got rid of most of them however I still have a bunch of sengled bulbs with no issues. They don't repeat, work great and are cheap.


That seems unlikely to me if the "active" event got sent. That's all the sensor does; the "inactive" part is handed entirely by the driver with a "timer" (a runIn, as the author stated), since unlike nearly any other sensor, the device itself doesn't send anything. Or at least this is what I say if the suspicion is that the Tradfri module has the routing problems ZLL devices are famous for. I suppose you could have meant that something else about the device was throwing things off, but unless there was a custom, hub-hogging driver, that seems odd to me too. :thinking:


No other hypothesis. If it wasn’t that, I have no explanation for the oddity. It’s gone now, that’s the most important. I’ll be more concerned if it returns :grimacing:



I am getting the odd log error from my Xiaomi devices, no line numbers unfortunately

dev:79 2019-06-28 10:49:12.384 error java.lang.NullPointerException: null (parse)
dev:525 2019-06-28 10:35:06.630 error java.lang.NullPointerException: null (parse)
dev:65 2019-06-28 04:56:18.590 error java.lang.NullPointerException: null (parse)

dev:79 and dev:545 are Aqara Door/Window Sensors (V0.7.2)
dev:65 is a Xiaomi "Original" Button V0.8.5

Any ideas where to start looking?


Without a line number, I only know where to look generally (in the parse method).

Can you help with more context?

When do these errors occur - during pairing, when there are open/close/push/etc. reports, or while the devices are idle?

I can say that I use a bunch of Aqara Door/Window sensors and a few round Xiaomi buttons myself and am not seeing those errors, so I need to figure out how to reproduce the circumstances to troubleshoot.

Are there other debug / info log messages that are seen just before or after these error messages?


New Xiaomi Aqara zigbee 3.0 devices to be announced in a few weeks.
Was about to order some more sensors now will wait a bit.
Looks like the new products eill have a T1 in their desciption.

Aqara to Announce Zigbee 3.0 Devices at CBD Trade Fair.


I’ve been holding off as well for months for these to come. Will grab some as soon as they are available. I’m hoping they will be as cheap and work better than the current devices.


I have successfully connected HE with Aqara Wireless Remote Switch (WXKG03LM). However my Aqara Wall Switch - Single (no Neutral) (QBKG04LM) has failed. I have installed this driver but i'm still no clue why its still fail to connect.


Hi Danny, Have you installed the child driver as well?


Hi guyeeba. I just did that. Restart HE and attempt several times without success. Am i still missed something here? Thanks for helping out.


Oh, you have problems with PAIRING the switch? That has nothing to do with the driver, but can be tricky, some tips:

  • try again
  • bring it closer to the hub (yeah, I know, it's a wired switch... be creative!)
  • push the button on the switch in every few seconds while joining to keep the device awake (the "no neutral" versions of Aqara switches are end devices, so they're quite sleepy),
  • and... try again. :slight_smile:

You'll find more info here:


Thanks for the tips! I have successfully paired 4 Xiaomi devices up to this moment - 12 more to go.

Luckily i had 20 metres cat6 in my keep so it helped me pair HE near to each devices.

It seems HE internal Zigbee transmitter is not as strong as my Aqara Hub. I remember last time i don't have to bring it down to all the devices in order to pair them. No wonder i read several owners have difficulties to stay connected. This could also would getting me into the same issues as well. Fortunately i have two units HE - it was unplanned to have another one but since having shipping error (bounce back to US) so i ordered extra unit upon reshipping.


These new ZigBee 3.0 devices have been "brewing" for at least 8 months, and some for more than one year.

The new "T1" models of some devices, and also new "S2" models not mentioned in that Homekit News article were listed on the ZigBee's Certified product list back in November / June last year. Here's a list with links to the ZigBee certification page for all known ZigBee devices:

There is one more new ZigBee 3.0 devices I found with FCC approval information on the FCC.io website - a completely new style of AC-mains wired wall switch presumably for U.S. consumers (listed as 120V/60Hz !!!!):


I have aqara motion sensor and paired successfully with HE. But it doesn't do anything. The logs are empty. I tried removing the device but HE gives me 500 internal error.


Log message output turns off automatically after finishing the pairing process. Then it needs to be toggled on by the user in the device details page of the Hubitat web UI:

So you clicked the "Remove" button and immediately saw the 500 error?

With the 500 error, before doing anything else, you should contact Hubitat support.

From what I've read in the forums the 500 error may be related to corruption of your hub's database. Furthermore some people suggest doing a manual backup, then a Soft Reset of your hub using the Hubitat Diagnostic Tool (found by adding :8081 to the local URL address of your hub), and finally doing a restore from that backup.