[RELEASE] Welcome Home


Is it possible to have it on action closed rather than open? I think mine is failing because it opens then I step in and close it before 10 sec. Also a close would be a true signal that you have come in the door and are ready for the message. The other day it went off before we could hear it because we were trying to get the buggy through the door. :grin: It could be a option of either?


You got it :grin:

New version:
V1.0.7 - 12/07/18 - Added an option to Contact Sensor trigger. Can now trigger based on Open or Closed.


Perfect it just worked :slight_smile:

New feature request though :smile: I had music playing at the time and it worked and restored almost perfectly, it just didn't restore the volume (it stayed high), could this be added?


Glad it's (almost) working for you. :wink: For this I have no way of testing, I don't own any devices to try and play this on. I only use the 'Speech Synth' option and do all my announcements using the Google Home Assistant Relay.

If anyone has any ideas on how to get this working, I'm all ears.



I second this request! Anybody know how to get this to work?


New version on Github...

V1.0.8 - 12/30/18 - Updated to my new color theme.


New Version on Github...

  • Can now welcome home up to 5 people at one time!

ie. Good afternoon, it's been a long time, Bryan, Amy and Emma !

V1.1.0 - 01/13/19 - Updated to announce multiple people coming home at the same time, in one message. Seems like such a simple thing but it took a huge rewrite to do it!


I found this, this morning
2019-01-22 08:00:08.669 am [error] java.lang.NullPointerException: Cannot invoke method setLevel() on null object on line 608 (contactSensorHandler)

Totally makes sense that a contact can't have a level. :face_with_raised_eyebrow:


Seeing this has nothing to do with a contact, that statement would be 100% false. The trigger was a contact sensor, the error is the setLevel for a speaker.

Go into the app and look at the 'Speech Options' section. You choose 'Music Player' but left one of the volume controls blank? :grin:

I've updated the app so each field in that section is now required.

New child app version on Github...
V1.1.2 - 01/22/19 - Made all fields within Speech Options mandatory to avoid an error.


talking about speakers i just came home and my wife had the radio on, it played my message waited then played it again. So it looks like its not collecting the previous state before it plays?


If using 'Music player' option, impossible to do. Please see any post about using the cast-api including the built in Chromecast integration. That's the number one request but Google doesn't provide any way to do it.

If you can use the 'Speech Synth' option and a 'Google Home Assistant Relay' device, then it will play the message and restore whatever was previously playing. But this requires setting up a rPI and listening to the annoying 'Broadcast from xxx' before each message. Lots of posts already out there about this too.


Seeing this has nothing to do with a contact, that statement would be 100% false.

Heh, ya I know what caused this then :no_mouth:. The speaker device previously set has a different ID now.
Thanks for exposing my stupidity :angry: j/k sort of


lol, nothing like that. Anytime I can try and make the app better, I'm all for it.


I received a very similar error to Doug. The error only shows up when I try and use the "Music Player" option. I'm using Alexa Speaks to drive my Echo.


Please update to the latest version, it was updated yesterday. Then go back into the child app and make sure each field is filled in under the 'Music Player' section.



I did the update before I tired it. And all the fields in the "Music Player" section are now required (see, new code :wink: they are filled in.


Hmmm, nothing has changed with that portion of the code since I first released this app. I actually took that portion of code from message central (documented when I released the app), can you see if message central will send a message to to Echo Speaks?

Will have to look into this. I just tried to add my one remaining echo to Hubitat to test but the Echo Skill is throwing errors. FUN.


That's kind of what I figured. I'm getting a similar error in "Check Contacts" by @Cobra :smiley: I need to run a debug for him as well.


Thanks for the confirmation. I'm having a hell of a time this morning getting things going. After fighting with my echo, I got the skill to connect. So now I've moved on to trying the echo speaks and it doesn't find my echo, lol. Need more coffee!


New version on Github...

V1.1.3 - 01/24/19 - Welcome Home now works with Echo Speaks using setvolumespeakrestore

All rules using the 'Music Player' option need to be updated.