[RELEASE] Universal Ecobee Suite, Version 1.8.01

Since updating, I keep getting this error in the logs:

*** INITIALIZATION ERROR *** PLEASE SET POSTAL CODE FOR LOCATION 'Home'

Please where should I set the postal code?

Thanks

Hubitat Main Menu, Settings, Location, Postal Code.

Also, set the Latitude and Longitude for your location on that same page.

1 Like

Anyone find a workaround for 2FA issues?

I suggest you report them to Ecobee - last person who did reported that Ecobee acknowledged their problem. Not sure if they fixed it, or if you have to turn off 2FA to get authorized...

I unfortunatelly turned 2FA on before warning.
it was working good until i just got disconnected yesterday

Is there any way to activate thermostats device manualy with use of pin?
I remember this method was used at smartthings before app existence.

Nope - no PIN authentication. Send an email to Ecobee Support explaining your problem. IIRC, they can either fix your account so that apps work with 2FA on, or they can turn off 2FA on your account...

My Ecobee application has disconnected from the API Oath fail. I was on the phone with support and they stated the authentication is an old login process. That a new Log on process is needed. I cannot authenticate to the API. I don't know if anyone else is seeing this.

Who's support told you that?

My code uses the published Ecobee Authentication interface, but I believe that Ecobee broke it with 2FA. If you have turned on 2FA, contact Ecobee Support and have them reset it for you (and then don't turn it back on again).

While you are talking with them, ask them for the link/pointer to the "new Log on process"...I'll implement it (if there is actually such a thing)...

Thanks for reporting this...

Please, don't shoot the messenger. :grin: I have "some" of the information that was provided to me in an email. Side note I thought it was BS too. I did a simple test. When I click on authenticate from the Hubitat application, it points me to a URL (API, Login, Oauth) to authenticate with the Token. When I do this from an Ecobee Plus application from Alexa it has me authenticate to a different URL that is still an Ecobee login. They admitted that they have changed how they are allowing 3rd parties to access their API's. Reason I tested with Alexa is they update the application directly, not through a third party. If this wasn't true, then I would expect being sent to the same URL, but that wasn't the case.

I can log into the Ecobee main log in page without issue. It’s only when I attempt to log in from the API page, I get a log in failure. They are starting to block log ins from that entry point. In my case, the token had expired (timeout) and required a verification of credentials which failed to update the token; thus, Ecobee Suite application fails (goes offline).

Please, let me know if this helps.

Provide the URL links that you noticed change so @storageanarchy can look into this.

Btw I have zero issues. I don’t have 2FA on as stated in the setup process of this app.

FWIW, Ecobee has multiple authentication entry points, and at least 2 different APIs - the one they share with developers like me here, and the one they share with Apple Homekit (and possibly Amazon), so your test doesn't necessarily prove anything.

Further, the authentication works fine if you don't have 2FA turned on - literally more than 1500 users can attest to that (I get a log of every authenticated endpoint using my application ID).

I just checked all of the Ecobee "public" developer API pages, and they all discuss the authentication method exactly as I use it (and as described above).

Have you tried, per chance, installing the native Hubitat Ecobee Support? If it works, and mine still doesn't, then I can work with the Hubitat Team to understand what has changed. But I suspect you will experience the same as others...2FA broke 3rd party apps. See Anyone having OAuth Ecobee issues? - if so, you might want to ask Ecobee why the native Hubitat interface doesn't work...

Finally, you might TRY making sure this:

  • Turn off 2FA
  • Exit your browser
  • Start your browser again - make sure NOTHING logs into Ecobee
  • Log into your account in the browser - DON'T CLOSE or LOGOUT of that tab/window
  • Retry authenticating from Ecobee Suite Manager - note, it MAY not ask you to log in again

If THAT doesn't work, do the above again, but this time DON'T log into Ecobee before trying authentication. You can also try a different browser (I use Chrome and Firefox).

Turn off 2FA resolved it. Odd thing this was enabled like 2 months ago and hadn't seen any issue and no other issue with any other application into Ecobee either. I did try the native application prior to calling Ecobee because that failed too. I tried to not involve you and do what I could to resolve without going back to forum. Thank you for your help.

Yeah, Ecobee really screwed up with 2FA and 3rd party apps. Some of their support folks know the issue, clearly others just blame it on the developer.

At least they fixed it so you can disable 2FA...didn't used to be able to do that without Ecobee Support assistance...

And I promise: if/when they release the new Authentication model, I'll add support for it.

2 Likes

No problem. If they send me anything. I will share you like. :slight_smile:
Thanks again.

Contacts and switches helper question. I want to turn off the AC when two windows are open. When I select the those contact sensors the only option appears to be "Any." I could create a rule with a virtual switch but I would guess there are others that also want to turn the AC on and off when they open up some specific combination of windows and doors for outside ventilation.

You're the first person to ask for that, actually. It gets real complicated trying to handle all the possible combinations of switches and contact sensors, so I decided long ago to just leave it to be handled by Rule Manager (or WebCoRE) automation.

Thanks for the reply. This is easy enough to do with a rule and virtual contact sensor.

1 Like

Ecobee Suite updates posted 18 June 2020 at 4:00pm

Fixes and Enhancements:

  • Ecobee Suite Manager, version 1.8.44
    • Fixed setHold() using Hourly Hold (holdHours)
  • Ecobee Suite Smart Room, version 1.8.18
    • Allow operation during thermostat "Hold" events or "Vacation" modes
  • Ecobee Suite Smart Vents, version 1.8.13
    • Allow vent manipulation during thermostat "Hold" events
2 Likes

Ecobee Suite update posted 28 June 2020 at 12:00pm EDT

Enhancement:

  • Ecobee Suite Routines, v1.8.18
    • Allows Action to be switch change only (Mode and/or Routine are no longer required)

This enhancement is primarily for SmartThings users who can no longer create new Routines.

Ecobee Suite Routines updated 1 July 2020 at 7:00am EDT

Fixes issues with turning on/off switches