[RELEASE] Tuya Zigbee Metering Plug (w/ healthStatus)

And you have automatic polling on with a reasonable polling interval?

Automatic polling is set to true
Polling interval is at 60 seconds, but i've tried it at 10 sec as well
Always on = false
Optimise polling and logging = True
Energy shortest reporting interval = 60
Energy longest reporting interval = 3600
Energy minimum change to be reported = 1

It has been connected for 1,5 hours now and the last*** values are still at 0

I will research this particular _TZ3000_v1pdxuqq model in more detail sometime later, it has not been tested until now.

Can you check in the State variables what are the values of powerPollingSupported , switchPollingSupported, etc... Better copy all the State variables.

State Variables

  • energyPollingSupported : true
  • lastEnergy : 0.0
  • lastPower : 0.0
  • isDigital : false
  • lastSwitchState : off
  • isRefreshRequest : false
  • notPresentCounter : 3
  • switchPollingSupported : true
  • lastPresenceState : present
  • powerPollingSupported : true
  • lastAmperage : 0.0
  • voltagePollingSupported : true
  • driverVersion : 1.4.0 2022/01/23 10:23 AM
  • lastVoltage : 0.0
  • currentPollingSupported : true
  • switchDebouncing : false
  • model : TS011F
  • destinationEP : 01

Thank you, will look at it ASAP.

1 Like

This is a very unusual device, it exposes neither the standard Zigbee Power and Energy clusters, nor the Tuya specific EF00 cluster...

I have just one theory and one idea for the moment :

  • manually update the driver to the latest development version from the GitHub link on the second post of this thread. This experimental version contains the XH-002P fingerprint in two different variants (with and without the power and energy reporting clusters)

  • Press Initialize button (I don't expect the reporting will work at this step yet).

  • REMOVE the device by pressing the ''Remove" button at the bottom of the device page.

  • UNPLUG the outlet from the mains and wait at least 3-4 minutes (this is to make sure the internal RAM is discharged)

  • Plug the outlet into the mains socket and pair it again to HE. It should pair as a new device, but this time the "Tuya Zigbee Metering Plug" driver should be automatically selected!

  • When the new device is found, there should be a 'more' link. Press it and please copy/paste the device pairing data here. It contains more information than usually shown on the device 'data' section.

  • Then go to the device page and test it again.

My theory is that this particular Tuya model does not expect to be configured for automatic reporting on the standard ZIgbee clusters and stops responding at some point. Please do not use the built-in 'Generic ZIgbee Outlet' for this test. I have seen similar weird behavior with other Tuya devices (TS0222 illuminance sensor for example)

If you turn on the Debug logging, are there any warning or error messages?

Alright. Tried what you suggested.

The "more" info:
ID: B684
Manufacturer: _TZ3000_v1pdxuqq
Product Name:
Model Number: TS011F
deviceTypeId: 1314
manufacturer : _TZ3000_v1pdxuqq
idAsInt : 1
inClusters : 0003,0004,0005,0006,E000,E001,0000
endpointId : 01
profileId : 0104
application : 43
outClusters : 0019,000A
initialized : true
model : TS011F
stage : 4
manufacturer :
idAsInt : 242
inClusters :
endpointId : F2
profileId : A1E0
application :
outClusters : 0021
initialized : true
model :
stage : 4

The log while adding the plug back: (Yes, I added 'dev' to the driver name to keep them apart)
dev:12732022-01-28 00:35:09.007 infoTuya Zigbee Metering Plug dev switch is off
dev:12732022-01-28 00:35:08.857 info configure()..
dev:12732022-01-28 00:35:08.849 infoconfiguring the switch and energy reporting..
dev:12732022-01-28 00:35:08.844 infoAuto polling is enabled, polling interval is 60 seconds
dev:12732022-01-28 00:35:08.817 infoDebug logging is false Description text logging is true
dev:12732022-01-28 00:35:08.811 infoUpdating null (Tuya Zigbee Metering Plug dev) model TS011F presence: present AlwaysOn is false
dev:12732022-01-28 00:35:08.727 infoTuya Zigbee Metering Plug dev InitializeVars()... fullInit = true
dev:12732022-01-28 00:35:08.700 infoTuya Zigbee Metering Plug dev Initialize()...
dev:12732022-01-28 00:35:04.483 infoTuya Zigbee Metering Plug dev switch is off
sys:12022-01-28 00:35:03.783 Created Zigbee Device Tuya Zigbee Metering Plug dev
dev:12732022-01-28 00:35:03.753 info configure()..
dev:12732022-01-28 00:35:03.626 infoTuya Zigbee Metering Plug dev InitializeVars()... fullInit = true
dev:12732022-01-28 00:35:03.619 infoTuya Zigbee Metering Plug dev Installed()...
sys:12022-01-28 00:35:02.171 Initializing Zigbee Device A4C1388AFE170BFD, B684

Sadly it hasn't been magically fixed. The log (with debug logging enabled) showed this:
dev:12732022-01-28 00:40:47.159 tracepolling.. refreshAll is false
dev:12732022-01-28 00:40:47.144 debugautoPoll()
dev:12732022-01-28 00:40:45.651 infoReceived bind response, data=[99, 82] (Sequence Number:99, Status: Failure)
dev:12732022-01-28 00:40:45.646 debugDesc Map: [raw:catchall: 0000 8021 00 00 0040 00 B684 00 00 0000 00 00 9982, profileId:0000, clusterId:8021, clusterInt:32801, sourceEndpoint:00, destinationEndpoint:00, options:0040, messageType:00, dni:B684, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:00, direction:00, data:[99, 82]]
dev:12732022-01-28 00:40:43.666 infoReceived Configure Reporting Response for cluster:0006 , data=[00, 00, 00, 00] (Status: Success)
dev:12732022-01-28 00:40:43.661 debugDesc Map: [raw:catchall: 0104 0006 01 01 0040 00 B684 00 00 0000 07 01 00000000, profileId:0104, clusterId:0006, clusterInt:6, sourceEndpoint:01, destinationEndpoint:01, options:0040, messageType:00, dni:B684, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:07, direction:01, data:[00, 00, 00, 00]]
dev:12732022-01-28 00:40:41.637 infoReceived bind response, data=[97, 00] (Sequence Number:97, Status: Success)
dev:12732022-01-28 00:40:41.633 debugDesc Map: [raw:catchall: 0000 8021 00 00 0040 00 B684 00 00 0000 00 00 9700, profileId:0000, clusterId:8021, clusterInt:32801, sourceEndpoint:00, destinationEndpoint:00, options:0040, messageType:00, dni:B684, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:00, direction:00, data:[97, 00]]
dev:12732022-01-28 00:40:37.434 debugEvent enter: [name:switch, value:on]
dev:12732022-01-28 00:40:37.249 debug other Tuya oddities - don't know how to handle it, skipping it for now...
dev:12732022-01-28 00:40:37.178 traceTest sendZigbeeCommands received : [he raw 0xB684 1 0x01 0x0000 {10 00 00 04 00 00 00 01 00 05 00 07 00 FE FF}, delay 200, he rattr 0xB684 0x01 6 0 {}, delay 2000, he raw 0xB684 1 0x01 0x0B04 {10 00 00 0B 05 05 05 08 05}, delay 200, he raw 0xB684 1 0x01 0x0702 {10 00 00 00 00}, delay 2000, zdo bind 0xB684 0x01 0x01 6 {A4C1388AFE170BFD} {}, delay 2000, he cr 0xB684 0x01 6 0 16 0 600 {}, delay 2000, zdo bind 0xB684 0x01 0x01 0x0702 {A4C1388AFE170BFD} {}, delay 2000, he cr 0xB684 0x01 1794 0 37 10 3600 {010000000000} {}, delay 2000]
dev:12732022-01-28 00:40:37.157 tracepolling.. refreshAll is true
dev:12732022-01-28 00:40:37.154 debugrefresh()...

After these messages it starts repeating 2 things:

  • 'trace' Polling... refresh all is false
  • 'debug' AutoPoll()

Hope all of this text helps you :sweat_smile: If there is any more info you need, let me know.

Thank you for the tests, @rvdstokker

Unfortunately, now I am 99% sure that your device does not support power or energy reporting. This is confirmed by the failed bind request in the logs, but is also confirmed in several other home automation forums - for example here and here.

I would advise to try returning the device back to the seller, if still possible.

oh cr*p... That was the main reason I replaced the existing wifi-based ones. (Well that and getting rid of the annoying "disconnect the wifi, so let's start a danceparty with the LED in the middle of the night- feature...")

I will be contacting the seller for a refund or to exchange the plugs.

Headsup for anyone looking to buy. Don't get these:
Not working plugs :frowning:

Thanks a lot for the help :smiley:

1 Like

If it's any help I got mine from Ebay Tuya ZigBee Smart UK/EU Plug Socket Power Monitor Works With Alexa Google Home | eBay

That's the UK site but it might be a clue what seller to look for.

The worst thing with AliExpress (but also the same products sold on Amazon) is that the sellers do not know what exactly product/model version they are selling. They sell whatever their supply departments provide. And with Tuya products it happens quite often that the firmware is changed, or even the electronic parts inside are changed, without the suppliers/sales being even informed about this. Often the sellers can not even understand what you are asking them... A classic example is the Tuya Scene Switch, which was changed from TS0044 to TS004F model last year breaking the usage at all HA systems.... except Tuya!

I quickly checked the customer reviews from the link provided by @rvdstokker, and as I expected - а group of customers are saying 'power/energy monitoring is working', others are saying 'nothing works except switching on/off !'.
I think both groups are right - simply because they have received different modifications of the same product at different times.

So, it is often a hit-or-miss with some Tuya products :frowning:


I just received my order, and the the outlet works well (on/off, power metering).
This was the product: Smart Plug WiFi / Zigbee Socket EU 16A Power Monitor Timing Function Tuya SmartLife APP Control Works With Alexa Google Home|Electrical Sockets| - AliExpress

On the other hand, I couldn't control (on/off) it from the Basic Rules / Rule Machine until I made the following change in the driver (1.4.1) code:

line 44:

        capability "Switch"  //Outlet has same attribute switch and functions on off

The outlet not listed as a switchable device, so I just put back the "Switch" capability

I am completely new to HE and groovy, so maybe I did something wrong... but it works.

1 Like

Thanks @tschneider, your fix is correct! I will add it tomorrow in a new version to be available for update from HPM.

Driver version was updated to 1.4.2 where the previously commented out 'Switch' capability line is now restored.

HI, Thank you for this good driver, very useful for me. But there is one question. Why does my Breaker result like this?

Is this the correct result?

My Breaker Model
Circuit Breaker2



Thank you

Yes, this is a correct view of the device driver page.
Note, that you need a load > 3..5 Watts in order the circuit breaker to start measuring the amperage and the power.

What is still missing in the driver is the option to configure the 'power outage' behavior, this is something that I can try to implement soon. What is your device default behavior when you cut off the mains power? When the power is restored, does it turn on, off, or keeps the previous switch state?

1 Like

Thank You sir. I use this Breaker as Master Breaker. I connected this Breaker with 2 conventional 16 amp breakers. I connect 1 Breaker to AC and the other to Wall switches and Outlets. I turn everything on but why are there still zeros.

If i cut off the Main Power its go to Off

1 Like

Look at the Preferences section, is the 'Automatic polling' option turned on?

If you have paired the breaker to HE first as a 'thing' (before installing this driver), you may need to repair it again. Do this as a last step, if the Polling option was not enabled.

Automatic polling turn ON. I already pair it again. same result

Download the Hubitat app