[RELEASE] Tuya Wall Mount Thermostat (Water/Electric Floor Heating) Zigbee driver

I have orderd MODEL 1 (AVATTO), will test it :slight_smile:

@kkossev , I received the MODEL 1 (AVATTO), guess the best way is to use it in Heat mode (as mention) and put the programs in Hubitat. Lucky for me you have wrote a driver, thx for that!

  • If I turn the "forced manual mode" on I should expect when the mode is changed on the device by hand it go's back to heat, it only works when I do it from HE or Google, Is this normal behavior?

  • It is not possible in heat modus to change the setpoint form google home, is this normal behavor or a bug?

  • Any idea if it is possible to turn off the beep on this device?

  • Is there a way to remove the "fan button" on the dashbord, I guess not a driver issue.

  • Do you know if it is possible to use an other tile for the thermostat on the HE dashboard?

1 Like

Hi @BrunoVoeten , thank you for your feedback!

I will be away from home until this Sunday, so I will be able to look deeper into the code then. At the moment I see that in the latest published version I have accidentally merged code for BRT-100 eTRV, will have to retest and update the GitHub repository later.

The "Force Manual Mode" option should switch the thermostat back to manual (i.e. Hubitat control) mode even when the mode was changed from the device touch-screen control. This option is done to prevent accidental switching into the scheduled mode. I will check and fix if it is not working as intended.

Checked now - the temperature control from Google Home is not working by some reason, hopefully, can find and fix it too.

The beep soind from the thermostat is really annoying, but I haven't found a way to turn it off (other than to open the device and cut the buzzer wires :sweat_smile: ). I don't remember a Zigbee command to switch the buzzer on/off.

On the Fan button removal - if I remove it, it breaks to compatibility with other HE apps, or Alexa, or GH, or any other applications that expect a thermostat device to expose Fan state and commands, even in our case when there is no fan at all.

On HE tile - it is a similar problem as with the Fan capability. The Thermostat template is designed to work this way, not very convinient for thermostats that just control a heater.

Looking forward to your actions, thx for this.
About the beep, don't know if you are joking but I want to do that if there is no other solution.
Incase if you did'it ;-), what did you just do?


The beep is no option because the plan is to install one in each bedroom and the WAF factor is low;-)

1 Like

I had no idea that the buzzer is SMD mounted. No, I haven't opened my thermostat yet, it was just an idea of how to stop the annoying sound.

From the picture, it is difficult to tell which wire to cut. If you know someone with good soldering skills (and equipment!) it may be possible to desolder the buzzer?

1 Like

It is confirmed in this Home Assistant page, that the Moes BHT-002-GCLZB thermostat (referred as 'Model 3' in the first post) has a firmware bug which results in sending multiple duplicated packets to the Zigbee coordinator (HE hub) when the temperature settings are changed:

This doesn't make it unusable in HE, but it can overload the Zigbee network for several seconds, so it is better to avoid.

Thanks for sharing this info, the plan was to order one because it looks it has no annoying beep.
Is it possible there is coming a firmware update from the manufacturer and we are doing an update via HE?
I never updated the firmware of a zigbee/zwave device....

1 Like

Tuya does not publish firmware updates as OTA files, you need to have their Zigbee hub. And firmware updates are rather rare for their products. I will check if there are any updates available when home.

You can ask the seller of the Avatto thermostat if it is possible to mute the buzzer, even if this will void the warranty.

1 Like

Already did, but not hopefull...

Hi @BrunoVoeten ,

Please update the driver to the latest dev. version 1.2.2 timeStamp 2022/09/04 9:44 AM.

Google Home compatibility was a bit tricky, I still have to compare how this driver behaves in comparison with other HE thermostat drivers, but quickly testing 'Hey Google, set thermostat to 24' seems to be working OK.

I have added also an explicit warning log when the driver switches back the thermostat into 'manual' mode. It was working for me OK with the previous driver version, please test again and let me if it works in your setup as well :

dev:32452022-09-04 10:13:45.839warnThermostat AVATTO _TZE200_ye5jkfsb 'Force Manual Mode' preference option is enabled, switching back to heat mode!

Hey @kkossev, still don't go back to manual If I change it on the device
image

using HE:

on the device:

"Hey Google" is working but the thermostat is not changing, same issue when you change it in the google app.

The ‘State variables’ do not auto refresh when they change, you must press F5 in the browser to see the updated values.

The actual states are on the upper right corner of the device page, these update instantly. Have in mind, that the automatic return to ‘manual’ mode (thernostatMode ‘heat’) happens with several seconds delay.

Can you post a screenshot of the device ‘Data’ section? Also, is the ‘model group’ set to ‘Auto detect’ ?

Can you confirm that the control is working from a HE dashboard thermostat?
image

  • 'Off' mode - should switch the thermostat off
  • 'Heat' mode- this is the 'Manual' mode that we control from HE, the thermostat shows a hand icon. Dashboard should have black background when the relay is off and red background when the relay is turned on (happens with 7-8seconds delay).
  • 'Auto' mode - this is the 'program' or 'scheduled' mode of Tuya thermostat, uses the stored inside the device schedule. Not to be used when controlled by HE.

If 'Force Manual Mode' option is switched on, then the Tuya internal schedule operation mode should be reverted back to HE 'Heat' mode (Tuya 'Manual' mode) :
image
With my thermostat, switching back to Heat mode from the HE dashboard happens in a less than 1 second, if changed from the thermostat control panel - after approx. 5 seconds.

One problem that I noticed is that sometimes when setting the heating temperature from Google Home, the temperature is one degree lower, I will have to investigate further.

Are you using the HE inbuilt 'Google Home' integration or the community integration app?

Yes, from the dashboard it is working, 'Force Manual Mode' is ON, off, heat, when auto is choosing it goes back to heat, up and down, relay is switching when the set-point is higher or lower than the actual temp, everything is working

1 Like

this is not working

Is use Google Home integration app

This is strange, sometimes It is working now (Google)

This is when I change it on the device, it comes and stay's on "auto"

image

1 Like

I made the Google Home Community integration work after several attempts.
On Google Home, I had to go to the integration and to select 'Check for new devices' every time I was changing something from Hubitat side (the ' Temperature Setting Trait' for example).
Mine looks this way:

1 Like

That's really weird because our thermostats are the same.

Can you try setting up a RM5 rule that will automatically switch the thermostat to heat mode if it was changed to auto?

Download the Hubitat app