[RELEASE] TP-Link Plug, Switch, and Bulb integration

  1. All of the errors are as expected (I should probably capture/isolate the 2nd to last error).
  2. It should not be the dual drivers - but change the driver for your HS 110 (go to the device's page and near the bottom you can select the type (driver).
  3. You are getting no indication that Hubitat is turning the devices on / off. so I do not think it is the Hubitat end. Kasa App????? Question would be, does the Kasa App show the correct state.
  4. Have you tried rebooting the HS300 (unplug, plug back in in 15 seconds). There is some quirkiness in the TP-Link Firmware.

Out of curiosity, go to the Kasa App and get the firmware version for your HS 300. TP-Link has been working on SmartThings integration and they may have had to change the firmware.

I am currently out-of-pocket, but in a couple of days I might be able to run some tests.
Dave

I'm still running some tests. Thanks for the tip/info on Number 1 and 2.

You're right. Don't think it's hubitat. I believe I checked the Kasa app when it happened and it did show correct state.

Trying this now. Just need to wait now to see if it happens. So far the bedroom one has not had the issue. Trying the original one. Will post results if this solved it.

On an off note, the funny thing about all this is the issue happened with a plug I used for a pair of Halloween skeletons that play dueling bango songs at each other whenever they hear a loud sound or clap or motion. Freaked out the house randomly but also ruined some movie watching.

If you have Amazon Alexa or Google Home, check and make sure the Kasa skill is disabled (removed in Alexa). Then use the Hubitat Alexa App to control via Alexa. Dual control may cause the problem.

If you use rules, check any that turn on/off thes HS300.

My testing showed no problems; however, I do not use rules (generally do not need rules). They are powerful tools that simplify day-to-day, I just haven't had time to start using.

Dave

I have one other thing to try if you are still having problems. It will disconnect the device from the Kasa cloud. You will still be able to control through Hubitat and through the Kasa app when on home network. No remote access via the Kasa app. Disparate move.

Yes I have both Google Home and Alexa. Checked both and not installed and skillset not enabled.

Yes, one of the first things I checked. Checked on device settings page in HE and removed from all rules and associations. Still turned on.

Thanks! That may resolve it however I think your previous solution might have worked. (reset by removing plug from TP Link HS300 for a minute then trying again). That might be the winner. Still waiting for the skeletons to start singing.

I am old. I could sing for you.

If you need the final option, it is an App I wrote for the purpose. Requires you know the IP address. Link is below:

The 15 second unplug reset HS300 didn't work. It's only one of the six plugs that decided to do this (that I know of). So I switched devices and used a device that I will keep on all the time in that specific plug (plug 5) that has the issue.
I assume it's a Kasa bug but I'll leave it alone for now until it creeps into the other plugs. Patch and root cause later.

1 Like

Hey all, I am a new Hubitat owner. I have added in the TP link Integration and followed the directions for the drivers, but for some reason the Hubitat is only seeing one light bulb to add. I have switches and other items and it does not see them. I have reserved the devices and they have static IP's on my router. I have taken one device that was not being found and reset it to factory defaults and re-added it to see if that would work- nope. Any ideas?

Porquepine,

Welcome to the quagmire. Since I do not know your expertise, I may seem to be stating the obvious. Provide answers to all of the following:

Kasa App - Are all devices installed with and controllable through the Kasa Application? If not, they will probably not work here since both rely on the same IP addressing scheme.

IP Segment - Are all the devices on the same IP segment (i.e., 192.168.1) as Hubitat? If not, correct and try again.

Separate WiFi network (i.e., guest). If on a guest WiFi network, It may not work - especially if the network is not set up to share data with other devices. Make sure no devices are on Guest WiFi networks or assure that the WiFi network is set to share data with normal WiFi network.

Device Type - I have most plug, switch, and bulb device types coded. There are two filament bulbs that are currently not available. What are the device types you can not see?

Think about these and we will find a way forward.

Dave

1 Like

Dave,

Should this work with this app? TP-Link KP303 Kasa Smart Wi-Fi Power Strip 3-Outlets 2 USB Ports | eBay

Thanks Mike. That was going to be my very next question. :grin:

I'm hoping it follows the HS300 and should be pretty compatible.

1 Like

Mike,

I just updated the Application. KP303 will install as a multi-plug.

Note: the product is not on the US TP-Link website yet, but is is in Australia.

Dave

2 Likes

Thanks Dave, I just purchased one, so I'll give it a shot next week when it arrives. Mike

Ditto

The device looks interesting. It is not available in the US, only a six-plug bar, which I really like.

Dave

I got the device today, installed it, and it's all working well, after I updated the app.

Thanks Dave. Some sweet action there.

The device is very well made too, as are most TP-link devices, from my experience.

2 Likes

hey @djgutheinz , question are you able to remove the cloud integration on these plugs at all? It would be cool being able to lock them to my local network only and restrict all external cloud connectivity. I did it from a firewall standpoint and the app then said "local only" but the HE integration was then broken so I had to open the firewall backup.

Yes. Use my Kasa Tools application. It will unbind the device (make it local only in the Kasa Application). To return to cloud control, you can use my Kasa tools or the Kasa application.

I am thinking of adding this to the "options" for the drivers. I need feedback prior to doing this.

3 Likes

Thanks for that mate. Yesterday I placed the plug on a different VLAN which worked fine however I am unable to change the IP on the device in HE without removing it all together. I have also tried to update using your Kasa device application however it cannot find it and seems to be stuck on old IP e.g. wrong VLAN. I was able to see it with your Kasa tools application because it allowed me to input it's new ip manually and remove it from the cloud which was good thanks for that.

My question to you now is there a quick way I can manually input the new IP either at the device or application level so I don't need to remove this completely and then fix my rules?

If you uninstall the device then do a manual installation, you can enter the IP manually on that installation. The application can't find devices not on the same VLAN as the Hub.

1 Like

Hi there, after much research I'm leaning toward using Hubitat for my smarthome. I will be losing internet connectivity next month (since satellite internet is my only option and I'm tired of paying 70/month for 20gb of data...) and need an offline solution for my already established smart home. I have about 10 tp-link light switches and the rest are Lutron. I know Hubitat already has support for Lutron but see that tp-link isn't really officially supported. My question is do you need a local network to use the tp-link integration? I'm planning on dumping my routers since they won't have a connection to any ISP come next month. Will I be able to use Hubitat to connect directly to my tp-link switches? TIA.