[RELEASE] Sonoff (Connect)

Hi, I received my new HE today and I am working completely in the dark. I have basically only got Sonoff devices at the moment and I am trying to connect a Sonoff SV (Garage door), Sonoff basics and I want to connect Sonoff TH's and Sonoff TX (3 and 2 Gang) light switches. I have tried for the last 4 hours and just not having any luck. I have flashed the Sonoff SV and the basic with Erocm123's firmware and I can access both devices via the web interface and they work from the web interface. I have loaded (I think) The connect app, then have installed the drivers for 3 SonoffS

I run the discovery and it finds my 2 connected Sonoffs (SV and the Basic), but I cannot do anything with either of them in the devices menu, if I go into Logs this line shows up for the Sonoff SV whenever I click ON or refresh groovyx.net.http.HttpResponseException: Not Found on line 213 (on). What could I possibly be doing wrong, what driver should I be selecting for the basics and the SV?

Sorry for the long post, a bit out of my deapth here!

Okay so I have made progress, I was using the incorrect driver for my devices, I have added the S20 and this works well. The issue I have now is that if I press the manual button on the Sonoff basic it does not update the status in Hubitat device page?

Sorry for the late response, but you need to make sure that the hubitat ip address and service port are in the device web configuration. Hitting "save preferences" on the device is supposed to auto fill those in, but you will probably want to check them if it is still not working.

HI @ericm all sorted my side, but thanks for the reply anyway.

I have installed Sonoff (Connect) and Firmware on the Sonoff SV and drivers. Device was discovered, hubitat IP address and port settings made. Everything looks good but I cannot control the switch through Hubitat. It works through the Tasmota web portal. Logs show this...
groovyx.net.http.HttpResponseException: Not Found on line 213 (off)

What ended up being your issue with not being able to control SV? I've getting similar response in the logs?

Without knowing exactly which driver you are using it would be hard to help. I do have a driver meant for the Sonoff SV for Tasmota 7.x with Hubitat support. You can find my driver in my Github repo linked from this post (linking to the post since it has additional information): [Release] Tasmota 7.x firmware with Hubitat support + Tuya and Sonoff drivers

@shawn.hoenshell

make sure you have selected the Sonoff S20-Tasmota driver the one from (@ericm) , that was my issue, I used the Tasmota wifi driver before and it would not work.

1 Like

Ok, sorry, is this the correct thread? I hope so.... You sent me two links. I am not sure what to put together to compile. One instance, I get an error because of the arduinoJson 6 and it wants me to convert from 5 to 6. I am assuming that the fix 6.6 is that fix but when I try to compile there, I get an HTTP error. So maybe I just need to know what files and subfiles and libraries I need because all these links is making it difficult to know what goes with what. 1st question.. ArduinoJson5 or ArduinoJson6? 2nd.question Sonoff.ino for shelly? or which one? Once it compiles, I am good. THANKS A TON!!!!!

check out this instead as @markus has taken over maintaining this fork.

1 Like

I have Wemo D1 Mini's that I used your Sonoff Basic bin for and they work great, however, I did not use the sonoff pinout for the mini's, I used GPIO 5 for the relay. If I flash the Tasmota bin, I can change the template etc... get what I want, but your mod software doesn't give me this option, or does it? If I want to use the Sonoff handlers in smartthings and program my wemo's with any pins at will, is there an options for this? If not, is there an easy way to get Tasmota to sync up to smartthings? Thanks a ton!!!!

PS... I put the handler in for the sonoff 4 channel but couldn't find the smart app to match. Assuming that the one for the basic should work? If not, where can I find this? When I scan in smartthings, only one device shows up and it doesn't work on any of the 3 relays I have set up.

Ok, so this is the Hubitat forums so I'm confused if you are using SmartThings or Hubitat. There are a few different solutions:

  1. My original firmware meant for use with SmartThings or Hubitat (this thread). This is firmware I developed independent of Tasmota. I stopped development on it a while ago, but it still works with several devices (mostly older devices).
  2. A modified Tasmota that I created to simply add instant status updates from the Tasmota firmware so that Hubitat or SmartThings knows what state it is in and gets instant updates regarding temperature, energy usage, etc. Tasmota had support for so many devices I figured this was a better solution than trying to keep up with my own firmware.
  3. A modified Tasmota created by @markus. He pretty much took over this project and has done a great job on making releases for the newer versions of Tasmota. His thread is over here: [Release] Tasmota 7.x/8.x firmware for Hubitat + Tuya, Sonoff and other drivers

Since this is a Hubitat forum the specific instructions and information here is geared towards that platform, but most of this stuff can be used with SmartThings with a few tweaks (not sure which platform you are using).

1 Like

I have a Smarttings hub I needed for my door lock. I am using it. I have like 5 switches hooked up now with your older code, however, I am still struggling to figure out how to get the new Hubitat/smartthings firmware to be recognized in smartthings. Do I need a different device handler and smartapp to get it to discover the switch I programmed? Will it work with any configuration? I am sorry if I am still on the wrong thread.... I thought it fit the description. If this is still the wrong thread, send me a link and I will move it. I am very new to asking for help in forums. A lot of first times here. Thanks for continuing to help me.

After looking at your wonderful link, I just ordered a Hubitat... Looks like a much better solution and more of what I want being not dependent on the cloud... Now all I need is a locally made voice assistant that will work without the internet and my goal would be 100% met!

1 Like

Welcome to HE!

There was Snips, but that has been acquired by Sonos, so who knows... Then there are things like Rhasspy and Mycroft though by default Mycroft is not fully offline.

I don't care if the voice assistant is 100% offline, I just want it to be able to turn on and off my lights when the internet is down. :slight_smile: Thanks for the leads!

1 Like

I just got my Hubitat yesterday and worked all day today trying to set it up. In Smartthings, I was able to use the Tasmota-connect (tasmota-hubitat-8.1.0.bin) on my wemos D1 mini boards. I used hongtat device drivers and app he made for smartthings and I was able to get smartthings to see both switches. In Hubitat, I can't figure out what driver and app I need for it to see two switches. For example, I have one switch that uses GPIO5 - relay 1, GPIO12-Relay2 and a couple of other pins for my buttons to manually turn on the lights. So My issue is when I find this in Habitat, it only sees the one switch (relay). What am I missing? I thought Hubitat was going to be easier than smartthings. I appreciate any help you can give me.

The latest and most up-to-date driver is being released during the day today, be on the look-out for the new thread. It is easy to install and have good docs.

Forgot to mention that the setup in the switch is Generic (18)

With the new driver you just install the parent driver and it will detect what is needed as long as the template is correct in Tasmota. If Tasmota shows two switches in the UI so will this driver.

EDIT: The driver is released:

1 Like