[Release] Rheem Econet App and Hybrid Water Heater Driver

That's ok. I prefer to use something by someone I know. I'm not experienced enough to dabble and feel comfortable messing with my heater and ac. Eventually something will come in that I can use. :slight_smile:

I just loaded this and connected it to my Sharptools dashboard. Very cool, and shows everything I wanted. Thanks for the app and driver!

It was the first 3rd party app and driver I've loaded, and it was easier than I expected.


Im having trouble logging into my econet app on habitat . I install app, update OAuth and then install driver taking out the "ONLY" I get to the part it asks for Username and password and " COULD NOT FIND DEVICES" pops up I've been going at this for a week. back and fourth between app and habitat and I can't figure it out. Thanks for any help.

Curious if anyone is using this App for Thermostat ONLY? I Had my Rheem HP replaced (after 20 years of great use) with a new Rheem with the newest Econet Thermostat. While I'm happy with the setup, I thought I'd see if there was a Hubitat use so I found this thread and installed the device drivers and app from Github but while it took my sign in, it appears to be not working properly and I wondered if anyone was still using it. Here's what I see on the Dashboard app.

Okay, got it going with a ? On one thing but it is functioning.

Hi, I have a question app Driver/App, I have Gas Water Heater.

  1. Can I have information about the temperature or just about Setpoint?
  2. What is the difference between "heatingSetpoint" and "ThermostatSetPoint"?

Below you can see the print od Hubit and Econet at the same time.


Hi, @brianspranger Did you have time to see my message here?

My waterheater has current temp and lower tank temp, this code updates the states:

def updateDeviceData(data) {
sendEvent(name: "heatingSetpoint", value: data.setPoint, unit: "F")
sendEvent(name: "thermostatOperatingState", value: data.inUse ? "heating" : "idle")
sendEvent(name: "thermostatMode", value: data.mode)
sendEvent(name: "lowerTemp", value: data.lowerTemp as Integer)
sendEvent(name: "ambientTemp", value: data.ambientTemp as Integer)
sendEvent(name: "temperature", value: data.upperTemp as Integer)

I think I tried to add some additional capabilities to the driver to see if my Google Home integration would pickup my water heater. So far I have not succeeded.

But the two setpoints should be the same, look at this function:

def setHeatingSetpoint(Number setPoint) {
sendEvent(name: "heatingSetpoint", value: setPoint, unit: "F")
sendEvent(name: "thermostatSetpoint", value: setPoint, unit: "F")

parent.setDeviceSetPoint(this.device, setPoint)

You may need to turn on the logs and see what the water heater is sending back for data.

When I was trying to track down some issues, I went to https://econetreg.myrheem.com I then did a right click > Inspect. It has all the commands in fairly plain English. I only see the ones for my particular heater, so you would have to find some of those and see if you can figure out what is missing or incorrect.

I also did like Brian said, I watched Hubitat and pressed every button on the Econet phone app and also on the water heater control panel, and recorded what it said or did in Hubitat. I think I had to view the "Devices" page in Hubitat instead of logs. The "Refresh" button in the devices page also brings up more info sometimes. Between the Rheem web page, and Hubitat, I was able to figure out the changes needed in the code.

I don't know what sensors they have for the gas heater, what does the heater's control panel have for data? In my case, the following data is available in Hubitat and on the water heater itself:

  • heatingSetpoint :
  • temperature :
  • thermostatMode :
  • thermostatOperatingState :
  • thermostatSetpoint :
  • Critical Alert :
  • Alarm Message :
  • Vacation Mode :
  • lowerTemp :
  • upperTemp :
  • ambientTemp :

Greetings all. Has anyone had issues with the driver? Today it won't accept my username and password. I tried changing the password, but that didn't work. The IOS app works fine though. I do see this in the logs:

I'm not seeing any problems with mine.

Me either.

I removed the app and the water heater from the IOS app. I then added it back to the IOS app and then to Hubitat. It seems to be working now.

I’m also having some issues. I noticed my button in our bathroom to switch to high demand mode was not working. Any ideas? I’m getting a username/password issue, but I can sign into the mobile app just fine.

mine seems to be working just fine. checked the logs tonight.

I just figured out that it did not like the capitalization I had in my username :man_shrugging:

I am able to deploy this and log in, but it statess "Could not find any devices"

I have an electric water heater with the Econet wifi module. Device shows active on Android Econet app

EDIT: Nevermind, had to call into rheem to get it fixed

Not trying to steal users from brian, but want to see if my EcoNet integration works? If it doesn't I'm sure we'd both like to fix our integrations! [RELEASE] Rheem EcoNet Integration

1 Like

I'm trying to set up this app but cannot get past the setup. It gives me an error that the username or password is incorrect. I know these are correct as I copy and paste them from my password manager and the credentials work on the Rheem app itself. its a complex password and the emaill address has a '+' sign in it, if that makes a difference.

Thanks for any advice or guidence.

I've enabled debug and get the following in the logs:

app:812021-01-30 10:42:27.599 pm debugAPI Error: groovy.lang.MissingPropertyException: No such property: access_token for class: java.lang.String

app:812021-01-30 10:42:27.588 pm debugLogin good!

app:812021-01-30 10:42:27.454 pm debugAPI Error: groovy.lang.MissingPropertyException: No such property: access_token for class: java.lang.String

app:812021-01-30 10:42:27.441 pm debugLogin good!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.