[Release] Philips Wiz Color Light Driver

Thanks! That's perfect for switching between a few effect presets. I've accomplished roughly the same thing on my system by making multiple scenes. A single virtual button interface would be more elegant. But...

What would actually solve this problem for good is to allow Dashboard tiles to have dropdown menus or comboboxes or something which would let you select from a list of items. I'm sure this is on somebody's to-do list somewhere, and I can make educated guesses about why it's challenging on this platform. Just add me to the list of people who'd use this feature if it's ever implemented.

1 Like

Awesome, will give it a try. Thanks!

So, basically, a scene for each of the light effects you want to apply.
Does that sound correct?

Not sure if something changed, due to the Hubitat update maybe. I’m running the wiz driver version 1.1.2

I have the bulbs set to refresh or query their settings every 10 seconds.

I set up a scene via the Wiz app and then went over to Hubitat to create a new scene.

When I went to “capture” the scene it still has the bulbs last settings. I waited a min or so, tried to capture again, same thing.

I had to go to Devices, then to each bulb in the scene and click refresh manually, it then reflected the correct settings, then I was able to go capture it.

I then was trying to set up another scene, same thing. Not sure if it changed with the driver version from 1.1.1 to 1.1.2 or if it’s a Hubitat thing.

Any thoughts?

I'll update my hub to the latest and test more thoroughly tomorrow. It really might be a hub thing. Since I updated to 2.2.4.139 a couple of weeks ago, my dashboard switch states don't seem as reliable, even with my regular Philips Hue lights, which have always worked very well.

Did you ever add Hubitat Package Manager support? I just installed it and the Match Up didn't find your driver. Neither did manually searching for it.

I have, but my setup is brand new, so you'll have to add the repository manually for now, using "Add Custom Repository" in the Package Manager Settings. The URL for the repository is https://raw.githubusercontent.com/zranger1/hubitat-repositories/main/repository.json

1 Like

I've been loving this driver so far, thank you for developing it!

One question I had was if it's possible to turn on/off lights with dimming.
For example, my Sengled zigbee bulb will turn on from an off state if you set the brightness to something.
It will also turn itself off if you set brightness to 0.

I don't notice that happening on these bulbs when using Hubitat controls.
Whereas if I ask Google to set the brightness of the bulbs they will turn on to the brightness I asked.

Is this type of functionality something that can be added with modification to your driver?

It'd be useful for me because I have a Pico remote and I'd like to be able to automatically turn on the lights when I press the dimmer buttons. My current workaround is to set the dimmer buttons to turn on the light and then adjust the brightness. But this workaround doesn't work for turning off the lights with the dimmer buttons (i.e. I can't keep pressing the dimmer down button to eventually just turn off the light).

This is a minor behavior change that shouldn't affect anything else -- Done! You can now turn the light on and off with the dimmer. The update should be available from the package manager.

One thing to watch out for is that because of the relatively long (10 sec) default polling interval, there may be some lag between dimmer and light. You can adjust this by shortening the polling interval if your network and hub can stand the extra traffic. (If you've got a lot of devices, I definitely don't recommend doing this.)

1 Like

Thank you! Though Hubitat Package Manager doesn't seem to see the update. I added your URL as a custom repo, is this not the correct URL?

It's in the main package manager repository list now. Just remove the custom repository and try "Update". If it isn't found, do a "Match Up" again to get the package manager to refresh its main list. Then you should be able to just Update and have it do the right thing.

It didn't automatically find it. Match up did find your repository, but didn't match it to the currently installed driver. I had to manually update the driver to the newest code then run match up again and then it found it.

Otherwise the driver itself works great! I'm not noticing too much lag (I assumed it would be up to 10 sec for each action, but I think I'm misunderstanding what the 10 sec polling interval is that you mentioned). Maybe it's because I have my dimmer controlling a group of lights instead of the individual light?

One small thing I noticed and am not sure if it's the driver's fault or the way Hubitat handles it, but let me try to explain the repro steps. In my scenario my dimmer raises/lowers the level by increments of 34 (because 3 increments of 33 leaves a 1 behind).

  1. Press dimmer up from full off (i.e. dimmer level 0)
    a. lights turn on and are set to 34
  2. Turn off the lights (with the off button, not a dimmer button)
    a. Lights turn off and Hubitat saves that the last dimmer value was 34
  3. Press the dimmer up button
    a. Lights turn on
    b. Hubitat shows the lights at 68 in the dashboard
    c. However the lights are actually only at 34 (in real life)
  4. Press dimmer up again
    a. Hubitat takes the lights to 100 in the dashboard
    b. In real life, the lights go from 34 to 100

Other than that, this works perfectly for all 14 BR30 Wiz bulbs I have in the house (4 in the office, 4 in the bedroom, and 6 in the living room). Thanks once again!

That's the 10 second lag in action -- when you do something on the hub itself, it knows about it instantly. If you use another control system, like a switch or a Google or Alexa integration, the data reaches the bulb via a totally different path, and the hub doesn't find out about it until the next polling interval.

If you use anything cloud based, the command travels from your net, to Google or Amazon (or Apple), from there to the Wiz cloud servers, from the Wiz cloud servers back to your house via encrypted MQTT.

The Hubitat doesn't know a thing about it until it asks the light bulb for its status. The shorter the polling interval, the sooner it knows. So shortening the polling interval reduces that "bounce" effect, at the expense of extra work for your hub and network. It's a balancing act, worth a bit of experimentation 'till you find a setup you like.

Your driver and nine wiz bulbs.

They are controlled by picos. The wife is happy.

That is really lovely. A great example of how color lighting adds life to a room. It looks festive and inviting!

Do you recommend adding these lights to Google Home via the Wiz integration or the Hubitat integration? I'm wondering if the Hubitat integration might be more responsive by any chance (specifically in automatically updating the light's status).

However, I'm having trouble adding all my lights to Google Home via the Hubitat integration. Some get added successfully and for others I get this error when I refresh the Google Home app on my phone:

I have no way to test this, but I would try the Hubitat integration first -- depending on your internet connection, it is likely to be faster.

When I googled this:
hubitat "the following devices are not supported by Google Home"
I got quite a lot of instances of this problem with various devices, so it's probably not the driver.

One thing you can try that fixed it for people with a different brand of bulb -- before adding it to home, set it to a color temperature, then any simple RGB color, then back to whatever you previously had set.

Apparently the Home integration is picky about all of a device's data fields, not just the ones in use. So if you've say, had an RGB/CT bulb that you've only ever used in CT mode, there might not be a value for RGB color available, and the bulb would be rejected. Just making sure the bulb has been in a valid state for all its modes makes the integration happy and allows the bulb to be added.

Also, check the easy stuff -- look in the Google Home integration app to make sure it has permission to use all your bulbs, and make sure the Hubitat can actually control them through the devices list or a dashboard.

1 Like

That seemed to work (changing the CT/color/CT)! Hopefully they stay connected if I change the bulbs to some weird setting that doesn't agree with Google.

I can now confirm that they do switch on/off a bit faster, but more importantly, their state (e.g. on or off) is updated in Hubitat right away!

By the way, you have mentioned a configurable default polling setting of 10 seconds before. Where is that exactly? I only have these settings:


The 6 seconds between light checks setting is default on all my bulbs. Is it that setting?

Once the bulb has valid data for all its modes, I'd bet it'll stay connected.

The "Time between light status checks" is the polling interval. 6 seconds is fine - I only used 10 seconds because that's where mine are set. In a future version, I'll make this dynamic -- when you change a control, the interval will shorten temporarily so you can see immediate response, if you leave the lights alone for a while, it'll lengthen to reduce network traffic.

1 Like

Good morning all!
I am new to hubitat and slowly changing items over from straight wifi to HE (once complete of most items I have previously bought ill be get zwave or zigbee), I have setup IFTTT, and added HPM along with KASA switches. I have added zranger1 to the repository and installed the driver but for the life of me can not get it to see the light. Tried to add the driver manually, HPM checked for updates and matched. I know im missing something simple Im just not there yet to know what it is. Any help would be appreciated. If I need removed this and start a new thread please let me know.

Download the Hubitat app