[Release] Magic Home Wifi Devices - 0.89

0.87 is out. Telnet and new scheduler are fully in and seem robust as can be.

Please, go into each device's settings and change them to use Telnet (see last post).

1 Like

Do I need HE version 2.1 before flipping the Telnet switch?

Nope. For any version of software under 2.1, you should use Telnet.

I see that 2.1 has dropped publicly. Let me run some tests on my end and ensure everything works as expected, and I'll make sure socket is safe to use for y'all :slight_smile:

I'll be traveling for work the next couple of weeks, but each device seems stable and functional. I'll keep working on it, even from the road, but wanted to give a fair heads up that I won't be able to really do any tests for a while.


Just got a chance to check this thread. Any bug reports? :slight_smile:

No time to work on them (long days working here) but I’ll be able to mull them over and fix once I get back next week.

Seems to be working fine on my bulbs.
Thank you so much!

1 Like

Nothing bad to report, all good news here. Thank you for this great driver.

1 Like

You guys were supposed to give me something to frantically work on between trips when I get home :joy:

I’m glad it’s working well. I haven’t been home to monitor anything or test the Socket transmission status now that 2.1 is public. I’ll find time for that in the next couple weeks though.


Not getting polling on socket . Turn on lights Dashboard does not change state. how about that.

1 Like

Also no dimming available driver needs steps for dimming ie dim by 5 10 or 20 also -5 -10 and -20


Care to elaborate? Any other drivers that do this? It'd be easy to implement.

Hey Adam

I'm running single color bulb single color controller and rgb controller no polling or dimming on any of them , didn't know until my family told me , lol


1 Like

Really? That’s interesting. RGB and single channel devices were working fine on this end when I tested.

Do they work in Telnet, but not Socket? I know you have a different single-channel device from what I have, so I may purchase one of those to fax out the differences.

Hey Adam

I will see if they still work on teienet later

neither a=socket or telenet dimmer is working.

1 Like


Just wanted to say thank you for this driver! It lets me use inexpensive outdoor RGBW LED strips in my automations.

With @bptworld's Lighting Effects, it will be simple to cycle red, while and blue on my front porch for the 4th. Or purple and gold for LSU games!

If I could make one suggestion for an improvement, it would be to suggest that hue be supported as a 0-360 degree wheel.

1 Like

I have an LEDENET RGB WW +CW controller that uses magichome firmware but I cant connect do you think it is not supported? I have tried WW+CW and just W drivers. The error is [error])java.lang.NullPointerException: Cannot get property 'state' on null object on line 543 (installed)


Problem seems to be solved. For whatever reason my hubitat was opening in Edge and seemed to work fine with the exception of this. When I tried to delete the driver I got no response so I tried it in chrome. Driver deleted and reinstalled using chrome and bingo works fine.

1 Like

New HE user here - I picked up a Ledenet RGB WW+CW controller to use with this as an indicator light. I've got some RGB strip connected to it, and it works fine from the MagicHome app.

I installed the 0.87 driver (fully updated HE as well, so The strip works, sort of. Clicking any of the preset buttons in the device settings turns the light on, but with the previous preset. I have to click the preset button twice to get the correct color. If the strip is already on, they change colors/presets correctly.

Likewise, I tried settings up rules in RM to have motion sensors or door sensors trigger certain colors. It usually doesn't come up the correct color, and it doesn't always turn off when the time is up.

I did check the logs on the device, and it LOOKS like it's sending the correct things (ie if I press a preset button, I see a currentPreset command and then a switch On command) but it's like it misses the preset command. Does the controller "go to sleep" or something?

1 Like

Sure! This feature is actually built into the driver; I just have to add a setting for it. I think I actually have a private version with thay somewhere. Is there a stock Hubitat driver that supports this that I can compare language with?

Can you send me a link to your model? This may be an issue with how I’m sending telnet events ... I’d bet that socket works (but don’t use it yet). Maybe I missed a pause somewhere. Most of my RGB+CCT models work fine with telnet, but I have one on a newer firmware that I haven’t tested that might behave differently. Which version firmware is yours?

1 Like