[Release] Magic Home Wifi Devices - 0.88

This driver works great for all my magichome controllers without resorting to flashing tasmota - however I'm getting an error in logs:

groovy.lang.MissingMethodException: No signature of method: user_driver_MagicHome_MagicHome_Wifi___Controller__RGB__353.setColor() is applicable for argument types: (java.lang.Integer, java.lang.Integer, null) values: [98, 62, null]
Possible solutions: setColor(java.lang.Object), iterator() (setColor)

Not quite sure what it means, I am using a RM rule to set a random color every time the LED strip turns on.

It looks like you haven't set the level of the bulb/strip in the rule.

This is the what I'd say, too. I had null-checking built into the driver a while back, but removed it during debugging when all of the slowdown was occurring. I will see to adding it back in.

Yes! Well, wall sockets to be precise that are connected to SmartLife. Is there a way to drive them from Hubitat?

I'll message you :slight_smile: If anyone else is reading this and is curious, feel free to reach out.

If you flash the Smart Life/Tuya device with Tasmota you can use my driver to make it work

1 Like

Thanks for sharing this—my method doesn’t work with any bulbs—not sure if it ever will, so people looking to integrate those should definitely look into flashing their SmartLife devices.

1 Like

@adamkempenich
I've finally gotten around to trying your integration out and it's been working fantastic! So well, the wife has become addicted to these wifi strips and has me putting them everywhere.
Miheal WiFi Wireless Smart Phone Controlled Led Strip Light Kit
Thank you!

I also wanted to report a discovery (hilarious at the time) I made by accident. It seems these devices share some IR codes with a cheap Vizio TV I installed last night. I was truly at a loss when during the TV setup procedure, my bed started strobing white. After turning the strips off a couple of times only to have them strobe again, was I able to make the connection. The LED controller's receiver is now covered with tape to avoid a repeat performance.

So, for anyone who would like to partially control Magic Home WiFi RGB strips from their Vizio remotes-

CH+........White Strobe
Info.........Green
Last........Seven Color Dissolve
1..............Blue
2.............Light Green
4.............Cyan
5.............White
6.............Lavender
7..............Orange
9.............Red
Yes, I may have been a little bored. :grin:

1 Like

I had to remove my IR strips in certain spots because of this :laughing: That's a good note to make for everyone else looking at these. I'm glad to hear the driver is working well for you---I really like these lights.

And since I've been dormant, lately---my wedding is quickly approaching, and I've taken a step back from all of this in the meantime.

0.90 will be out some time in the weeks following that :slight_smile: My deadline is 2 weeks before Halloween (I've got something spooky planned at my house!), so at the latest, look for it then.

6 Likes

Looking forward to it and congratulations on the upcoming nuptials!

3 Likes

Hey Adam. I'm trying to set up some WiFi lamps that work nicely with the Magic Home app (all the functions seem to work nicely). But I'm getting some issues. I've tried these 2 drivers from your set....

...but neither of them seem to give complete control over the bulbs. Some of the functions on the device page work, others don't. And here's an example error I'm getting when trying to set the brightness over 5 seconds...

Is there another driver I should be using?

Nope. That version of the driver is missing a parameter in SetLevel(). You can add it in manually, changing the method’s parameter to be:

Def setLevel(level, duration=1)

For now

Ok, not sure how to do that but will take a look when I can. Thanks. Also I noticed the color temperature doesn't change the white tone either. Maybe you can implement that too sometime if possible.

Cheers!

Which bulb is that?

This type (RGBW)...

Smart WiFi Light Bulb Led Lamp 4.5/ 7/10W RGB RGBW E27
https://s.click.aliexpress.com/e/C0k9fQbe

Do you have the flood light, 7w, or 4.5w bulb?

Hi Adam actually I'm not sure if my lamps are exactly this model. I'm away right now so can't check the bar code on the box of my lamps. But they are something like this, purchased on Aliexpress. Basically, they are designated as "RGBW" lamp bulbs that work fine on Magic Home app but don't quite work properly using the 2 drivers I tried thus far. They are interior lamps, so not floods. I recall they are around 7W. It was light level and temperature that I noted were not working. The various effects like coloured strobes and fade from colour to colour were triggering ok.

Is color temperature throwing any errors in your logs? That essentially just runs setColor, so it should work regardless.

I'm away for a few days now and my remote VNC connection via RPi has decided to go on the blink. Sigh. So can't check it right now. Will let you know when I get back.

Thank you!

1 Like

Hello, I am new here. I just have a question about Magic home LED strip. I have set an LED strip as see photo 1 and a rule see photo 2, however, the LED strip only comes on after a menuut or 4 and not at the set time !!! Can anyone explain this? And is it also possible to dim this and set a color via a rule?