[Release] Magic Home Wifi Devices - 0.88


#181

Haha these ones are on a physical switch --- too many issues of people turning them off in the app, and then having someone else hit the switch. It's a temporary solution, thankfully :laughing:

It would be a good prank, done lightheartedly. The dark side of automation is spooky!

In this case — I really pranked myself!

I also just learned that MagicHome devices send unsolicited messages to ALL devices with an active TCP connection to them. It's pretty cool, actually, and very fast!

Edit: Looks like that's just for power, though.


#182

Yes I've given myself a good laugh with some of this stuff too.
It gets me every night with my daughters room.
She used to always turn the lights on at night so I put a GE swtich in and if my virtual switch that means the kids are sleeping is on the lights go right off after being turned on.
If she goes to bed too late (it automatically turns on) I try to turn the light on to settle her into bed and the light flashes on then off.
I sigh and kind of chuckle. Then fumble in the dark. :joy:


#183

Alright. For those who are looking to get their parse() function back.. 0.83 has been released :slight_smile:

This version also introduces a setting for how often to send heartbeat or keepalive/refresh packages. I recommend keeping this under 250 seconds, as some devices will unexpectedly close sessions when they don't receive a ping.

You will need to hit initialize in the settings of each of your devices to get them talking properly in the new driver, or reboot your hub if you have a ton of these devices, like I do, and it will initialize on boot :slight_smile:

I haven't been seeing any slowdown, and I've been running my hubs with packets every 2 seconds with a lot of devices for several days. If you see any, please let me know. Fundamentally, nothing has been edited outside of the parse() method in this update.


#184

Here’s something funny :laughing:

I came home today—my phone couldn’t connect to WiFi. All of my devices were still connected on our network, so something must have happened with a soft-lock on the router. The MagicHome driver was still working perfectly—and still, no slowdown :cowboy_hat_face:

Edit: in retrospect, if this had happened with SmartThings, I’d have come home to a dead house. What a relief!


#185

Are these controllable with your driver?


#186

I just updated my 2 devices to 0.83, the odd thing is my hub was slow again when I entered to update the drivers, between 8 to 10 seconds to enter to each device when the normal is less than 3 seconds. I have those lights in the second hub with no apps or rules, just the link to hub app and 12 devices total, not sure why is getting slower, anyway it works, I let you know how it works now.

Thanks.


#187

Unfortunately, miLights use a different protocol over UDP. I think someone had a version of LimitlessLED working for SmartThings back in the day—I used to use it before I switched to MagicHome.

It may be possible to find that and port it over.

Interesting—and thank you for that note. Was this on 0.82? I wonder, if in some cases, the default refresh time is too high. If you notice this in 0.83, would you be willing to set the refreshTime in settings to 250, and see if the issue persists?


#188

Yes, with 0.82. Sure I can try 250 the refreshTime

Thanks


#189

Hi Adam,

I noticed this error on the logs after updating to 0.83, but this logs are from the master hub, the second hub where the controllers are installed has no logs.

Thanks


#190

rgbw? I’ll take a look. Sorry about the bug!


#191

Yes, RGBW controllers. Thanks


#192

My RGBW controller didn't turn off this morning. :confused:


#193

Thank you for letting me know! Did you hit initialize when you installed the new driver? I’ll take a look at the RGBW driver more heavily


#194

So I was going to post, huh it's not even responding, but then I hit initialize again and it works now.
Don't worry about my comment for now, we'll see if it goes off in the morning.

The bulb is working great.


#195

Some kind of lighting convention going on in our dining room today. Grateful that my fiancé is so patient :joy:


#196

I might be doing something wrong, but for some reason I cannot get my LED-driver to turn on with any type of automation. To give some details, I'm using a RGBW-driver from Magic Home with a LED-strip and altering on/off in manual mode it works as intended.

I've created a group containing this LED-strip with a second strip and as soon as these are on, both will follow in changing hue, saturation and level. Therefore I cannot understand what's incorrect here... anyone with any ideas?


#197

Are you using the RGBW Controller driver?


#198

I did of course double check, but unfortunately I am.


#199

Hi Carl!

What app are you using that is giving you some trouble? From my understanding, it works fine with the manual controls, but doesn’t in a certain app?

Anything in the logs that might be useful? Is debug logging turned on, as well?

Thanks!


#200

Hi Adam,

Generally I do not have any of the logs turned on to keep the database at a minimum, and unfortunately this will be the case here as well. But it's activated here and now.

The app I'm using will be RM at the moment, and if it will be to any help I can create something in SL as a trial!?