[Release] Magic Home Wifi Devices - 0.87


If it makes a difference in not looking for the preset controls.
On/Off, Color, White Temp and Dimming are all I need.


Not gonna drop it at all :slight_smile: These devices are great, and this is a good puzzle to solve.


Perhaps the very first version or second version in the history of the GIT might work... I’m not sure, though.


This is priority for me—after fixing the Telnet side of things :cowboy_hat_face:


I've been testing a new version of the drivers here for a couple days. Looks like the new connection method I'd written was causing the slow down. I've reverted the method to the original, for now, and I will continue to debug the new version while possible.

Expect connections to take longer with this new version. I'll keep chiseling away at it when possible.

Grab the files from my GitHub here



I installed it in my development hub, it works, on and off, hue and saturation, white level must be clicked twice to make it work.

Set color is not working, if I choose a color and I write the same hue and saturation in the respective buttons and click them it will change to the color but not from the Set Color Button, gave me an error too:

Thanks for your hard work!



How’s the speed of your hub? Any lockups with this version?


Speed is fine, I just tested both rgbw strips and they worked. Thank you.


Lights turned on with a rule for the first time in a week or so after updating the driver.
Hub seems faster but it could be psychosomatic.

I have the same functionality issues but nothing has been lost.
Overall net gain of a faster hub and it started responding again.

I was so busy for the holidays I didn't fight the failures and just turned the lights on with the MagicHome app.
All good now.


An update, I installed the driver on my production hub, has been a full week working, the only detail is the set color button, but everything else works, even with google HE integration can change the color correctly. Thanks.


Hello Folks. Very much noob needs a little help with this controller. I purchased the NexLux strip lights with the controller your previously mentioned. Using the Magic Home app, the lights work great. I downloaded your Beta device driver (no problems there). From the Magic Home app, I can see the IP address which I entered in the driver under Preferences: Server Device IP (I entered the full address: Device Port is 5577. Under Device Information: Device Name* - NexLux, Device Network ID* - DC4F22C2376A, Status* - INACTIVE, Type* - MagicHome WiFi - Controller (RGB). When I try to activate lights On/Off using device driver commands, nothing happens. Can someone tell me what I'm doing wrong or point me in the right direction? Firmware version on the NexLux controller is 33.v4-17.6445-A Thanks!!!


Hmm. Those lights SHOULD work—at least, with power on/off. Let’s check a few things, since I’m still working on the RGB variety (it’s in my box of devices to fully add).

  1. Just to be sure, you’re using the RGB Controller driver? It looks like those controllers are RGB, at least from a fast amazon search. (Looks like it should be, just wanting to double check)
  2. The device IP is the IP address of it on your internal network, correct? (It looks like it should be, just looking to double check)
  3. Are the logs saying anything when you try and issue commands?

This info should help a ton :slight_smile:


Thanks for the quick response, much appreciated. This is going to one of those baffling incidents!! I loaded devices drivers MagicHome - Bulb (RGBW), MH - Controller (RGB), and MH - Controller (RGBW). I'm using MH - Controller (RGB) according to the Type* parameter. The IP address came straight out of the MagicHome Pro app. When I use my iPhone Wi-Fi Signal Strength app, it indicates as connected to the Wi-Fi network. Logs show entries every time I hit the on and off buttons on the device page in HE. Strange!! I can delete the Controller (RGBW) and Bulb (RGBW) drivers if that helps; really don't need them at this point.


Under NexLux events:

|switch|on|||DEVICE||2019-01-13 11:23:46.869 AM CST|
|switch|off|||DEVICE||2019-01-13 11:23:44.919 AM CST|
|switch|on|||DEVICE||2019-01-13 11:23:34.935 AM CST|
|switch|off|||DEVICE||2019-01-13 11:23:34.225 AM CST|
|switch|on|||DEVICE||2019-01-13 11:23:30.709 AM CST|


Maybe this will help (from system logs)

dev:692019-01-13 12:34:49.049 pm errorjava.net.SocketTimeoutException: connect timed out on line 531 (on)

dev:692019-01-13 12:34:18.984 pm debugMagicHome - Switch set to off

dev:692019-01-13 12:33:35.674 pm errorjava.net.SocketTimeoutException: connect timed out on line 531 (off)

dev:692019-01-13 12:33:05.611 pm debugMagicHome - Switch set to on


A little more info. This is the NexLux I bought from Amazon. Syslogs continue to show timeouts every time I hit the on or off button. I'm running in a test environment so I can learn how these devices work HE hub is about 10' from the NexLux. Wi-Fi is LinkSys Velop and signal strength runs around 90%; enough to make u sterile :joy::joy:

Nexlux Led Light Strip, WiFi Wireless Smart Phone Controlled 16.4ft Non-Waterproof Strip Light Kit White PCB 5050 LED Lights,Working with Android and iOS System,IFTTT


That’s the one I found. It looks like the devices are talking—I’ll have to check out the protocol.


I appreciate all the info! It helps a lot.


Hello Adam Don't put a lot of effort into this until I do some more analysis of my test environment and network. I need to find out why some devices are all of a sudden un-reachable. Apparently several others are using this driver with no problems. Let me look at the time-out problem from my end.

Thanks for your effort!!


Good morning Adam...….problem solved and lights turn on/off. Problem turned out to be too many local networks that weren't talking to one another. Re-arranged HE hub and NexLux on the network and now connecting as they should.

Thanks for bearing with me as I learn more about these devices.