[Release] Magic Home Wifi Devices - 0.86


#241

Thanks! This is helpful. I’ll reach out to staff and figure out why setLevel sometimes is sending two values. I’m pretty sure this happens if a Color Temperature has been sent to the device.

In the meantime, to fix this, I think you could delete your device and re-create it.

Also, I haven’t noticed slowdown with the other drivers, so I’d say they’re safe to use. Let me know how they handle!


#242

On some devices, I'm seeing slowdown.

I'm not sure which ones, yet. This will take some time to debug.

In the meantime, if you experience slowdown, I offer an alternative:

Install this as a separate driver. I was running it reliably for a couple weeks. There's also another alternative version that I can send if this one causes slowdown for you.

Edit:
I think I've got it! I found the recursive loop. Testing and fixing.


#243

Weepeeee!

Aaahhhhhh :pensive:

Weepeeee!

Ok, I will wait. I don't want to die today by my wife :rofl:


#244

Smart man.

Still doing tests. :slight_smile:


#245

0.86 is up! It adds some checks in the parse(...) method that's fixed the slowdown for me—and hopefully you. I'm still trying to figure out why exactly this happens. A few ideas that I'll be testing in the coming week.

@vjv — I've also changed how some of the methods receive parameters, if you're willing to test how multiple hubs handle the link with this. If it's not working for you, I think I can fix it if not. Buying another hub in the next week or so for development only. :slight_smile:

If the slowdown is gone, I'll start adding features back in the next versions.


#246

Testing it now, thanks!

If I don't reply in 24 hours consider me dead. :stuck_out_tongue_winking_eye:


#247

I am looking for original firmware for magic home controller . Mine is rgb with 24 ir remote controller zj wfmn-a v1.1. Last version was 33.v6


#248

I’ll try to get it updated & test tonight. At the moment none of my bulbs allow color changes from Smart Things or Alexa integration via HE. Been beating my head trying to get this one or mqtt that allows color control before my family has my head.


#249

Which device do you have? This one should work for you without any soldering, etc... There's only two devices that I haven't coded in, yet. One of them is very old, and the other one... I'm working on :slight_smile:


#250

Hm, I don't have the RGB IR to dump firmware from. Which firmware do you have flashed on to it?


#251

I just have bulbs

and they work in HE. But any of the other integrations only on off dimming no color control


#252

I flashed with ravensystem/ravencore to test with homekit , but forgot to backup the firmware.


#253

single contoler 86 not working light froze in on.

Scott


#254

Let me take a look at this in a couple hours for you. I'll tag you once it's worked out.


#255

Ah, ok! But color is working in HE? :slight_smile: If you need a different driver for SmartThings I may be able to help you.


#256

Oh no! Do you happen to know which ESP chip yours has in it? I may be able to find one to dump---otherwise the Tasmota firmware might also restore original functionality for you.


#257

Esp8285 or esp8265


#258

Yes color works in HE just not Smartthings. So if you have a working driver by all means let me know what u need to send it. Cvccole@gmail.com is email & I’m on github as well


#259

I sent you a message. That version doesn't parse anything though.


#260

Haven't heard from vjv in 17 hours. Might need a wellness check. Tomorrow's headline's may read: Man killed for letting the WAF drop too low.