[Release] Logitech Harmony Hub Driver v0.1.20230311

Thanks Dan! Got this set up a little bit ago, everything is working great so far. Will report back if I see any issues.

Hopefully websockets will be around for awhile...although this post makes me question that :scream: I wonder what it would take to get XMPP added to Hubitat's list of capabilities.

I just ran into this as well. Refresh did not reestablish the connection. Had to hit save in the parent driver.

I will look into adding a fix to handle the hub restart issue.

The initialize method should be called on hub start assuming the driver defines the initialize capability. If that is the case and its still failing, I will take a look

1 Like

Thanks Chuck. I'll give it a shot!

1 Like

I learn something new all the time. So I just need to add 'capability "initialize"' and it will call the initialize method on reboot. Going to try that now.

1 Like

LOL - I had that in the code already, but commented it out to make the Parent UI cleaner... I am testing it now...

Update: That fixed it! Thanks @chuck.schwer for the tip! New Parent Driver code is already uploaded in GitHub.


I saw that. Lol.

Just tried it on my driver and it worked. Now I gotta go update some driver code with this new information.

Did a little forum searching and did find this from Mike in may though. Adding it to my notes for future reference.

1 Like

@ogiewon, unfortunately this integration was a real disappointment for me. I configured everything and tried to turn on my TV activity. My TV did not come on, all my lights flashed on and off and my Alexa TTS said "your hubitat hub has surpassed your quota of ogiewon apps and driver. Please remove at least 5 of them as soon as possible." I'm just tired of saying thank you, so I wrote the above instead. Great job..as usual..:roll_eyes:


DAMN! I wish you Yanks could spell properly!

I have initialise everywhere (which, of course, is the correct way to spell the word!)
Ok.. so now I have to make spelling mistakes in all my apps/drivers :slight_smile:



It took me years to switch from s to z, y to i, re to er and remove u's. You Brits made the Queen's English too complicated I guess.


Stop messing with 'proper' English! :slight_smile::slight_smile:

And don't get me started on Aluminium :crazy_face:

1 Like

I think you meant Aluminum :wink:




I was born and raised in a British colony, so I'm happy to rebel using American English. :fist:


This is working really nicely for me. Thankyou @ogiewon

1 Like

Sorry Cobra, way more people use American English than British. So by default American English is the correct English worldwide now. :slight_smile:

Like most things America touches we took it over, made it our own (in arguably worse ways), and foisted it upon the world. lol

I do a lot of business in the UK and the spelling differences make my head hurt. English is a really crappy language in terms of structure and pronunciation regardless which form you use. Although.... It makes infinitely more sense than Welsh.

I will say, though, that I rather like tyres over tires. :slight_smile:


It's been great for me as well. Only hiccups have been when either Hubitat hub reboots or Harmony hub reboots...I have had to go back into the Harmony Hub device and tap Save Configuration to get the connection to open again. But...that's what initialise() initialize() should fix I think...

Have you updated the Parent Driver to the latest version? I put the fix for capability "Initialize" in it the latest version on GitHub.