[Release] Logitech Harmony Hub Driver v0.1.20230311

Please explain the process you followed to enable the use of the Harmony Remote Home Control Buttons with Hubitat. Specifically, I am curious if you were using the SmartThings Virtual Button 'hack' that was originally used to get these working with Hubitat. Since the ST 'hack' relied on the old SmartThings/Harmony Hub Groovy integration, it would not surprise me if this Groovy integration has finally been shut down by Samsung.

Personally, I simply use the Harmony Hub remote's Home Control buttons with my Philips Hue and Lutron Caseta lighting systems, as these integrations with Harmony are still functional. Both of these work very nicely with the Home Control buttons without any need for Hubitat in the middle.

Probably not the new you wants to hear, unfortunately. Even if Samsung has not shut down the Harmony Hub legacy Groovy integration, they will soon. Logitech actually recently released an upgraded Harmony Hub mobile phone app that is supposed to support the "new" SmartThings platform. This has come as a surprise to everyone. I am not sure if this new integration might afford a new opportunity to use the SmartThings virtual device 'hack' once again, or not... :thinking:



Not the news I wanted to hear. I have checked my Smartthings Harmony controls and they still work. Not sure that it has been converted to edge yet.

I do not have Philips Hue or Lutron Caseta (trying not to create complexity of an ever growing number of hubs). All of my lights are connected to smartthings or hubitat while I am in the process of moving them all over to hubitat. Until this the only thing that I was going to have left on Smartthings was a samsung washer (which the functionality does not demand to have it connected).

I might try homebridge connection to harmony... but that would create more dependency on homekit (which except for the MYq I was looking to get rid of). Would be nice if homebridge would send its accessories to hubitat.


Just did a relogin between Smartthings and Harmony Hub. That made it work again!!!!!!

It looks like Smartthings changed something in their third party security/login process. The screens during the login were very different and it exposed all of my smartthings device to Harmony without asking what to expose.


1 Like

That's great news! Thanks for sharing.

My 'buttons' went dead about a week ago. I tried a couple of times to reauthorize and it would either error out, or not find any devices. This is what I did for success (note YMMV).

  1. Deleted the old SmartThings Harmony app from the iOS SmartThings app.
  2. Deleted the old ST integration in the iOS Harmony app.
  3. Resynced both the iOS Harmony app and the 950 remote.
  4. Built a 'new' location in the iOS SmartThings app called "Harmony".
  5. Put four new Virtual Dimmer devices in the 'Harmony" location in the iOS SmartThings app.
  6. Went back to the iOS Harmony app and BOOM, I could authorize and pull in the new Virtual Dimmers.
  7. Configured the UUID in the Hubitat driver like normal.

Logitech is using the new API: "api.smartthings.com" to authorize, so this should work going forward.

To note, you do not need a ST Hub if you use cloud virtual devices.



Just an additional piece of information.

With the new smartthings login from harmony there are a couple of new good things!

  1. You can now do all of your harmony/smartthings integrations straight from the harmony app on your phone. It used to be that to login into smartthings from harmony you had to use the pc/mac app and plug your harmony hub into the pc/mac. Now you can do that login directly from the phone app!!!!!!

  2. I have multiple harmony hubs and ran into a slight issue that I was able to resolve. Which ever hub I last re-login to smartthings from was the only hub that would work. I noticed that there was a option to remove two factor authentication option during login. Once I had selected that (and re-login with both hubs) they both were able to operate smoothly.


1 Like

push commands not working.

I have gotten my harmony hubs integrated with hubitat using your driver. I have just recently overcome the new issues with the upgraded smartthings 3rd party app security upgrade (impacts harmony working with smartthings on the home control buttons).

So I am now able to control devices on hubitat with my home control buttons on harmony remote.

What I was attempting to do is use the push command (in the hubitat device window... and in a rule) to emulate pushing a harmony home control button. When I do I get the following error...

org.codehaus.groovy.runtime.metaclass.MissingMethodExceptionNoStack: No signature of method: user_driver_ogiewon_Logitech_Harmony_Hub_Parent_622.push() is applicable for argument types: (java.math.BigDecimal) values: [2] Possible solutions: pause(), use([Ljava.lang.Object;), run(), mute(), play(), run() (method push)

Not sure how to move forward on this. What I am trying to do is sync the button level between hubitat and harmony when I use a hubitat rule to control the device vice pushing the button on the remote.


I'll take a look. It should be a pretty simple fix. Thank you for pointing it out.

@user4652 - I have just updated the Logitech Harmony Hub Parent driver in my GitHub repo. The manual push and hold commands are now properly supported on the parent device page. Please give it a test and let me know if this has resolved the issue you reported. Also - please be aware, if you're a long-time user of this code, that a few months ago I made a breaking change to the Parent Device driver. The driver now uses Hubitat's built-in Generic Component Switch child driver instead of my old custom one.

Thanks! That would help a bunch.

Got it to work from the device page.... Works great. I will be check from a rule here in a little bit and let you know how that works!

1 Like

Just ran it in a rule... That works also!!!!!!!

This is great.

With HUBIthings I think I can solve my problem (not elegantly). HUBithings allows me to share the virtual hub in Smartthings that the harmony button is tied to. So I can change the value of the dimmer through HUBIthings.... Then I THINK (not sure yet) that when I push the button Harmony will then update the value from Smartthings... so sure be able to make my two dimmers (Hubitat controlling the physical device... and Harmony button) equal each other when they are out of sync.

What would be more elegant is to be able to emulate the rocker buttons.... But not a major issue.



Dumb question, but can I use the 4 home buttons without a ST hub? I deleted my old one from my account :frowning:

Per @Bloodtick_Jones, no ST Hub is required. See this post for details of how to set up the ST side of things.

Ok, well, I don't have ST cloud virtual devices - I unlinked my hub and account. I suppose it's still letting me use my old devices from when I had an account are still in Harmony app. Guess I’ll never re-login :slight_smile:

@ogiewon Any idea why my debug logs show Status:2 when your code looks for Status:1?

No idea.

Interesting. The buttons didn't work with button controller until I changed the code to be Status:2.

Perhaps new firmware on the Harmony hub changed this? Just a guess.

I am simply use Hue and Caseta integrations directly to the Harmony hub to use these Home Control buttons.

No idea. I had a Harmony meltdown last night when I tried to replace remotes. Had to find a Win 10 laptop to clear all the pairings. It wasn't fun. I wouldn't doubt a firmware update took place, but a few factory resets for sure. I used it as a chance to upgrade the Logitech code to use components, so this is the first time on the new version.

1 Like

Harmony did push a disruptive firmware release and suffer server issues over the past week. Reports: 1, 2

I simply had to press "Off" and "Menu" for 20 secs to reset and recover the remote.