[Release] Logitech Harmony Hub Driver v0.1.20190723


#284

Sure... I mentioned it in my post... Dashboard Volume Tile... :wink:


#285

I haven't created a custom command on some time.. what kind of device is this that I test? Or is that even still the way to do it? I keep getting an error when trying to test it as an actuator (this is how I did IP control of a receiver). Love the app by the way! I use it daily!


#286

Sorry about that! I just added the "Actuator" capability to the driver. Please update your driver code. That should take care of it and allow you to select the Harmony Hub Parent device in RM to create a 'Custom Action'.

Please note that you will only be able to adjust the volume either up, or down. You will not be able to set a specific volume level as Harmony has no way to achieve this. If you want precise volume control, you must use a driver that can connect directly to your receiver over the LAN.


#287

works perfectly - thank you so much!


#288

And i already have a question / feature request :crazy_face:

When you hold down the Harmony remote volume buttons it seems to be able to "stack" the commands so the volume goes up and down pretty quickly. When I use Hubitat custom command (thanks again btw) with the button controller, the fastest repeat it can currently do is basically one click per second. In practice, it's so slow my wife gets frustrated.

Do you know of a way to speed that up? Failing that, could your code potentially "bundle" three or four clicks, or a custom amount, into one volume command perhaps?

I'm still pretty new to this, so there's probably something else I'm not considering. Thanks again

EDIT
Discovered I can stack the custom commands in Button Controller. This is perfectly sufficient. THanks again for the app!


#289

I have been thinking about that particular issue. There is no way for me to easily replicate the Harmony Hub remote control (i.e. hold and release). I might be able to provide an option to allow each button press to emulate holding the volume button for a user definable duration. It's on the back burner... Hopefully I can find some free time to experiment.


#290

OK cool we're on the same wavelength. Happy to beta test when the time comes. Not a priority!


#291

Works like a charm Dan !!


#292

I have the firmware 4.1.250 on the hub/remote and I can't get connected to the hub consistently. Do I need to do the Option+F9 trick in the MyHarmony app to downgrade the firmware to "enable XMPP and 3rd party integration"? I thought I had it working, but after the initial set up and latest drivers code I keep getting:

java.net.NoRouteToHostException: No route to host (Host unreachable) on line 247


#293

Welcome to Hubitat!

No, you do not need to downgrade your firmware on the Harmony Hub. This integration uses webSockets, not XMPP.

Aside from the error messages in the Hubitat logs, did your Activities get created? Do they properly reflect the status of your Harmony Hub? Can you start and stop activities using the Hubitat "Switches" for each activity?

From my experience. it seems quite normal for the webSocket connection to drop between the Hubitat Hub and the Harmony Hub. It is designed to automatically reconnect when this happens. Perhaps this is what you're seeing?


#294

No child devices are created. I set the IP address (checked it from the remote) and rebooted the Harmony. After the initial set up failed, I tried just clicking on initialize and it keeps giving that error.


#295

Are you sure this is the correct version number?

My Harmony hubs are all running v4.15.250.

I use the Harmony App on my phone, and then click on the menu button (three white lines in top left) and then select About. This shows the hub firmware version and IP address.


#296

Sorry, 4.15.250...

Hub software 4.15.250
Hub Extender 1.2.99
App Version: 5.6.2
Build Number: 53
(from ios app)

From physical remote same info with additional remote f/w 4.15.250.

I had a static DHCP address set, so I removed that and rebooted the hub, and tried the new IP address. Still says no route to host. Remote and iphone app work however.


#297

Are the Hubitat Hub and Harmony Hub both on the same subnet? What is the IP address of your Hubitat Hub and Harmony Hub? What type of WiFi router are you using? Can you ping both the Harmony Hub and the Hubitat hub on a PC connected to the same network?


#298

HE: 10.1.0.1
Harmony: 10.1.0.166

Harmony is on a Ubiquti AP wireless hub
Hubitat is connected to the same switch that the AP is connected to
I can't ping the Harmony hub...(edited)

I can ping the Harmony directly from the EdgeRouter switch, I just can't ping it from the desktop or any other device wirelessly connected to the same network.


#299

My Harmony Hubs PING just fine. I am using an iPhone connected via VPN to my home network, and I can ping my Harmony hubs. Sounds like you may have a Ubiquiti network setting somewhere that is blocking LAN to WiFi traffic, or WiFi to LAN traffic.


#300

Geeze...there are some devices I can't ping across to the wireless network, Amazon echo hubs don't respond from anywhere, so hard to test out. Assumed if the phone could connect things are working as they should be. I have 12 devices connected to the AP and 8 of them (my phone, ipad, a tivo) are all pingable across the network. Harmony will not respond.

Will try Ubiquiti support to see if there is some weird setting that is the default (these are out of the box except EdgeMax which I have configured for OpenVPN, DHCP, etc.).


#301

Believe it or not, if the phone app cannot direct connect to the Harmony Hub, it actually connects via the Harmony Cloud. So your phone and harmony hub may be cloud connected! :wink:


#302

Didn't think that it would do that! I never suspected the no-ping to because all of my amazon devices and my cable company's TIvo box have icmp blocked, even though there are ports open--I would set up my network Tools to connect via a specific port instead of just rely on PING. I just assume harmony did the same think but (a duh moment for me) I couldn't telnet to 8088...of course HE couldn't do anything with it.

I reset my Ubiquiti AP and that seems to have fixed my issue.

Thanks so much for your help and getting me out of the assumption rut I was in to fix it!


#303

Glad to hear you figured it out!