[RELEASE] HubiThings Replica

Ok this app is amazing. I was in the process of migrating to Hubitat from smarthings but there are a couple devices that would have been hard to integrate with hubitat. This bridged that gap for me and it was much appreciated.


Hi Didn't get much for response on this question above for the errors should I just delete the virtual devices and maybe re connect to them to resolve the errors?

What type of virtual device is throwing the error? That does not have a familiar method call of a Replica device driver. Not sure how to help.

Thanks, yes I wasn't sure what the cause was but it some mode switches I set up with HubiThings Replica. What I'm trying to do is use replica with some SmartThings virtual switches that I created in SmartThings for modes such as arm, unarm and Home so that when Hubitat changes modes it replicate in SmartThings, so when Hubitat changes modes to say armed Hubitat would turn the arm switch on in the SmartThings app. Reason is the wife still likes the SmartThings app. it seems to work fine but I get these errors in the log wonder if It should toggle the switch rather than just turn them on when mode changes. Sorry hope what I'm trying to explain makes sense.

A little confused on your configuration, but you are correct that HubiThings is throwing the error by attempting to call a method on Hubitat that the device does not handle. BUT we should be able to figure it out.

Can you select/find the Hubitat device that is dev:182

If you click on 'dev:182' it should highlight the device name and you can then go to that device and send me the 'Type' of the device to troubleshoot.

Depending on the 'Type' we can change the 'Rules' to select the correct methods in the HubiThings Replica application:

No problem. I used the HubConnect application for years doing exactly the same thing.

Just paying it back to the community with this application. :slight_smile:


delayed response by me, but thanks for your answer.

"have you tried both methods in your Replica device?"

Can you please help me understand exactly how to do this? Thanks in advance!

My apologies for not responding sooner. I've been out of pocket for a few weeks.

In the SmartThings app, go to the device page for your fan and note what controls are provided by the Fanimation service. On the device page for my fans, I have two options to control speed as shown in the image below; (a) a "dimmer" or Level control, or (b) a Fan Speed Control,

These correspond to the controls on the Replica device page in Hubitat:


If your controls don't match either of these options, or don't work for you when you try them, open the HubiThings Replica app and click on "Support for New Device" at the bottom of the page and follow the instructions.

Hope this helps.

Hello Community. I have several First Alert Smoke CO Detectors configured in ST. I am connecting them to HubiThings ST HUB Replica. Which Hubitat Device Type should I choose in the Replica list?

I don't think there is a replica driver completed for smoke/CO detectors available yet. Right now, I am in the middle of moving, and it will probably be a couple of weeks before I have time to develop on the platform.

Q: Any reason you are keeping these with ST and not moving them to HE? I had three of these on HE prior to the move, and they performed well.

Anyway, if you can wait, I can work on it when things are not in pieces.

Good point. I think I will just move them to Hubitat. Thanks

Thanks so much for this, I have everything functioning perfectly, with one challenge.

I can't control the range's oven light from Rule Machine. It works as expected from the device page, or a button on the dashboard. For my microwave hood, the light can be set from the 'actuator' function, but the range doesn't have that.
Looking in the Hubithings rule section, I don't see a command for 'setbrightnesslevel' or similar.

Is anyone controlling the light this way, and how did you do it?

What Replica driver are you using for this?

I'm using the ReplicaSamsungOven, installed and updated from HPM. The ReplicaSamsungOvenCavity child is installed as well, but that doesn't have light controls.

Contact @djgutheinz or review the updates in his support forum channel. He supports that solution.

I have reinstalled Replica, and get a fail when I try to configure API. I have deleted and regenerated the Smartthings token with no success there. What can I do to solve this problem?

Thanks for any help you may provide.

Here are some recent log entries after soft reset.

Hi @bloodtick_Jones

First of all I want to congratulate you on the HubiThings Replica, excellent, great immediate control of Samsung appliances.

I would like to make a request if possible.

I worked for a while with @djgutheinz to improve the drive that controlled air conditioning (Samsung HVAC 1.2.9), and one facility he had implemented was x_hubitat_extra_attributes.lightStatus and x_hubitat_extra_commands.setPanelLight, which allowed we to know the status and turn the air conditioning display on and off.

This is very useful for those who want to leave the room dark at night.

Please, would it be possible to restore this functionality in the Replica Samsung OCF AirCon drive?

Thank you very much.

Have you solved this problem? I installed Replica for the first time today, generated the API token and am receiving the same error message. Not sure why.

I had only selected Devices when requesting the PAT. FOr some reason this wasn not enough. I sselected more authorization options and it wored fine. Not sure which one solved it.

1 Like