[Release] Hubitat Ping

No, just these every time I click on "Send Ping"

dev:15622021-06-21 05:12:53.244 pm debugconfigure()

dev:15622021-06-21 05:12:48.059 pm debugconfigure()

dev:15622021-06-21 05:12:40.813 pm debugconfigure()

dev:15622021-06-21 05:11:57.888 pm debugconfigure()

dev:15622021-06-21 05:11:29.771 pm debugconfigure()

That would be correct functioning for this driver; may want to reboot your hub given that we don’t know how long that refresh code was running…

@thebearmay - Ok- I'll reboot and let you know...

@thebearmay - unfortunately, no change. :frowning:

Let’s try the old method, Click the Use HTTP endpoint to issue request, click save, and then try the ping.

That worked!

1 Like

@thebearmay - as soon as I add something greater than 0 in the Ping Repeat in Seconds Zero to disable field, I get the following Error message:

dev:15612021-06-21 07:05:29.031 pm errororg.codehaus.groovy.runtime.metaclass.MissingMethodExceptionNoStack: No signature of method: user_driver_thebearmay_Hubitat_Ping_1169.refresh() is applicable for argument types: () values: [] Possible solutions: every(), every(groovy.lang.Closure), grep() (refresh)

That’s strange, I can add a dummy refresh method but not sure where the call is coming from.

Edit: 2.1.1 out with the dummy refresh method

1 Like

That seems to work. Only one last strange thing... when I try to ping, I get the following error:

dev:15932021-06-21 08:28:12.779 pm errorjava.lang.NullPointerException: Cannot invoke method indexOf() on null object on line 185 (sendPingHandler)

dev:15932021-06-21 08:28:02.658 pm debug[uri:, path:/hub/networkTest/ping/, headers:[Cookie:HUBSESSION=node069fgkf2jpijd1usp3uorgpch381.node0]] Returns this:

dev:15932021-06-21 08:28:35.803 pm errorjava.lang.NullPointerException: Cannot invoke method indexOf() on null object on line 185 (sendPingHandler)

dev:15932021-06-21 08:28:25.693 pm debug[uri:, path:/hub/networkTest/ping/, headers:[Cookie:HUBSESSION=node0eze9juy0eta61qx99lfq15bnh82.node0]]

If I switch to the IP to then I get no errors and a successful ping.

Looks you’re getting a null return from the ping - I’ve added code to handle it but it should always return something… v2.1.2

I'm confused as to why I'm getting a null return. I can successfully ping and from my desktop, just like and

Not sure, I've tested it here and am successful using both methods supported by the driver. The only time I can create a null return is if the IP address contains an invalid character or format, i.e. 8.8.8,8 (comma instead of a period) will error out and cause a null return.

v2.1.3 adds a regex pattern check on the IP address

1 Like

It seems to have something to do with a C-5 hub versus a C-7 hub. I was using a C-5 hub when reporting these issues. Tonight I had an opportunity to test with my C-7 hub (which is not currently being used in production). I noticed no issues on the C-7 hub when pinging or when "Use HTTP endpoint to issue request" is turned off. On the C-7 hub, if I turn ON the "Use HTTP endpoint to issue request" then I get a 100% loss for both and, while and still return data properly (regardless of if "Use HTTP endpoint to issue request" is on or off). Not sure how much this data point will help, but hope it does.

What HE release is your C-5 on? If prior to 2.2.7.x it will use the HTTP endpoint (new method came out with 2.2.7.x), and I can duplicate the endpoint failure for consistently...

The C-5 is on; I'm glad to hear that you're able to duplicate the endpoint failure for

It should be able to use either method then. Have tracked down the or issue using the HTTP endpoint - request is timing out (Status 408) which was being suppressed by the code. Will be changing that to bring back a message.

Hmm. I wonder why the "new" method isn't working. Very strange. Also, no idea why there's a timeout on the Google DNS IPs -- this doesn't make sense to me either.

I wasn't able to get the "new" method to work on my C5 either. Honestly, I didn't mess with it much when HTTP worked. Time constraints. I'm running

1 Like

Sounds like lots of people are having problems with ping on the C5:

1 Like