[RELEASE] Hubitat Package Manager -- HubitatCommunity

Whatever you think would be best. If you create a Pull Request, I’ll gladly merge it.

Like that?

4 Likes

Looks great!

2 Likes

I installed the Bundle Manager but I am just not sure how it links with HPM. Is there a guide I could use to figure it out?

Short version, it doesn’t. HPM has its own support for Bundles, Drivers, Apps, and bundled Libraries.

1 Like

There is a whole thread. Please read at least the first two posts.

Bundle Manager

1 Like

Thank you!

It has been a good few weeks sine my package manager has detected any updates. Doesn't feel normal.

Something I've missed? Long thread.... Tq

1.8.6 is the latest.. as identified in the first post in the topic:

1 Like

Cheers, but I was referring to HPM not picking up on any app updates. I generally check in once per week and always find something.

Haven't had any app updates in a while. Not the most quantifiable of things, but it's odd, and presumed I'd missed out on something HPM related.

Never mind =p

OOOOOOoooo I get it now. Yea, perhaps I released updates to HPM too rapidly. :smiley:

4 updates in 2 weeks. Nothing in the pipeline though, so if anyone was hanging back.. the way is clear :smiley:

If you're concerned, look at the "packages" you have installed. Nearly every (possibly actually every?) developer with an app or driver in HPM has a release thread on the forums where they post about updates, and by necessity the source code is also available somewhere, usually GitHub. Be concerned if you see something there HPM doesn't see; otherwise, you might just not have anything newer available, odd as it may be to have been so long.

FWIW, I'm on HPM 1.8.6 and mine does see some updates (that I've been ignoring...), so it doesn't appear to be a universal problem if that's any consolation. :smiley: I do confess that I manually updated HPM to the newer versions once instead of letting HPM update itself due to problems some others had initially (as did I on one hub), if that matters...

2 Likes

I just updated to 1.8.6 on my C7/2.3.2.127

Even through HPM says I'm now running 1.8.6, it sees updates available for two other versions of HPM:

It shows 2 HPMs in repair, too-

any advice?

EDIT: just found [SOLVED] Two Hubitat Package Manager (HPM) in View

1 Like

After InfluxDB-Logger was added to HPM and it did an update when opeing InfluxDB-Logger I just get a blank screen on all 3 of my hubs. Is anybody else seeing this or some thoughts?

Did you do a Match Up so that HPM knew to include it? Or Install it from HPM?

Did a match up

Unable to reproduce...

This is what I just tried...

  • manually added InfluxDB-Logger.
  • Match Up -- match Yes, but didn't choose up-to-date
  • Update - got offered to update InfluxDB-Logger (as shown below)
  • Accepted the Update.

Screen Shot 2022-06-17 at 9.16.25 AM

resulting in:
Screen Shot 2022-06-17 at 9.09.54 AM

1 Like

Basically what I did and when I go into it it's basically blank. Could something have happened to the code when it was moved to HubitatCommunity

Did you try a repair, this will usually fix this kind of problem.

1 Like

"Will this affect the original code, and more importantly, the confidence in that code?" That's been my #1 test of each and every line of code I touched.

To gain confidence in the migration I very intentionally didn't alter any of the original Apps, Drivers or File pathways in the code.

The downside of keeping my fingers off the original code is... I didn't prevent/correct existing issues either. If HPM had an issue in July of last year, it probably has it still today. :smiley:

2 Likes

Download the Hubitat app