[RELEASE] HubConnect - Share Devices across Multiple Hubs (even SmartThings!)

community_app

#767

Here's a quick update on a couple new features coming for HubConnect 1.4....

SHM Integration, between hubs including Smart Home Monitor. HSM will not need to be installed on the server hub for this to work. There are some limitations to centralizing HSM, but I'll leave that for another post.

This will include the ability to map SHM states to HSM states...

The version report has been updated to now show the latest available versions.

There are also a batch of new drivers that will be included as well. More on those in a later post too. :slight_smile:


#768

HubConnect has been amazing! It is allowing for a smooth transition from SmartThings to Hubitat. So far have moved 16 devices out of 62 and all automatons are working great. Once I have all the devices over then I will port all automatons over to Hubitat. Its incredible how fast HubConnect is. Can't even tell the local devices from the remote.


#769

It happened again, but what i found to cure it was this... I am using the MakerAPI with Homebridge from @dan.t and HubConnect. I rebooted the pi hosting homebridge, then toggled the light on and off on Homekit, and the status stated updating on the Hubitat server hub. Is there a chance that something is getting stuck between homebridge and HubConnect?


#770

This is what I did with about 120 devices or so. I created them all in HE with Hubconnect. Took my time creating automations in HE. Once I had all the logic created in HE, I stopped all my ST automations and let HE run things for a few weeks. I sorted out my flaws in automations. Then moved all my devices to HE. Pretty smooth process.


#771

@csteele or @srwhite In the process of getting this app up and going last week, I just noticed apparently I added all the "HubConnect drivers" to ALL 3 hubs (coordinator and 2 remote hubs), now that I "think" I understand how this operates, having those drivers on the "remote" hubs I'm thinking is unnecessary.....is this correct? If so I'll do some house keeping on my remote hubs.


#772

If you are not transfering any devices from server/coordinator hub to remote hubs then the drivers are unnecessary.


#773

Drivers go on the “receiving end”

If you select devices on a Remote-Client then the server needs the drivers.

If you select devices on a Server Instancel then the drivers are needed on the remote.

Both Apps display a list of drivers needed on the Other End, so it’s even easier :smile:


#774

Hey @jdjmailbox,

sorry for the delay, was out of town for a few days.
Both, HubConnect and Homebridge via MakerAPI listen to the eventsocket.
So, here is a question, before you rebooted your rPI, did you try to use HomeKit to enable/disable a switch? If so, what was the result in HomeKit? Did it do the action and showed the correct result? This could give an indication on where to look for the issue.

Did you know that there is also a homebridge plugin that connects to HubConnect instead of MakerAPI? Take a look here: link to post 545


#775

FYI Regarding Keypad in ST.. I couldn't get my Iris V2 keypad to show in ST. Turns out ST does not support the capability "SecurityKeypad". I replaced the DH with the capability "Lock" and "Lock Codes", now it shows up.

Also added tiles mimicking the look of:
[RELEASE] Enhanced ZigBee Keypad Lock - Centralite Keypad, Lowes IRIS Keypad, UEI Keypad and Xfinity Keypad Device Handler - Devices & Integrations - SmartThings Community.


#776

I ran into a problem that I don't understand why it is happening.
I have been happily running along for several days migrating devices from SmartThings over to Hubitat. Each Device I create on Hubitat I mirror back to SmartThings. All good, until a few hours ago when I keep getting warnings that my SmartThings hub is offline. For the devices already created there is a seamless flow between hubs. The problem now is any new devices created on Hubtat and shared through HubConnect don't show up on the SmartThings platform.

Is there a reason this is happening? And if HubConnect thinks my remote hub is offline how is it that it is communicating with all the other devices?

Added: It may be possible the reason devices are not being create on the remote hub is I don't have a device driver for the button I am trying to move. I will test another device that I know has a proper driver. But I still don't understand why my remote hub keeps showing off-line.

So I did verify I can still connect devices from Hubitat to SmartThings using HubConnect so the only issue, which, I guess isn't a big deal anymore is why it keeps going off-line.

Thanks for putting up with my long winded issue.


#777

I noted the same thing earlier as I was trying to get a ST fan driver (tiles) working. It cleared up a few mins later but remember, HubConnect talks to ST via ST's cloud. I think ST's cloud was having the vapors... but since it cleared up.. I'm even more sure. :smiley:


#778

Yea, as I am moving things my smartthings app is throwing errors. Seems to be stable again. I'm just a little hyper because I am in the middle of a several day effort and afraid something will go wrong. Once everything is moved the stress is off. So far I have had minimal disruptions with automatons. Trying to keep it wife approved.


#779

Kind of funny that just as your getting off ST, it was flaking out.
Like it was saying “ you leaving ? How can you leave this ? You’ll be back !”
Ha ha


#780

@srwhite Is there a driver, or a way to separate GE Zwave motion switches? I have 3 in my kids rooms that will show up as motion sensor or as a light switch, depending on the driver I choose in device settings on my server hub. Could there be a single device to expose both, or would they need to be added separately?

Edit - I just combined your two drivers into 1, and it seems to work... not bad for a guy with no idea on programming, especially Groovy...lol


#781

I don't know that switch but for Hampton Bay Fan Controllers, Hubitat's driver offers to create child devices and I add then to HubConnect individually, one for the light (dimmer) and one for the fan (as a Fan Controller).


#782

It seems that the motion and switch in the GE unit is considered one device, with multiple functions. I combined the 2 driver files, adding what needed to be added, and not what didn't, and it works like a charm!

I can use the functions separately, but HE sees the motion switch as one unit.


#783

Seems the days of single function devices is about to be a historical reference we tell our kids.

The Aeon MultiSensor 6 took it a long way there and it too needs a specific Driver (Omni) to gain all the functionality/features.

Can't wait for the (imaginary) MultiSensor 9 :smiley:


#785

I tried to install, but getting -

module.js:130
throw e;
^

SyntaxError: Error parsing /usr/lib/node_modules/npm/node_modules/semver/package.json: Unexpected token g in JSON at position 0
at JSON.parse ()
at readPackage (module.js:126:52)
at tryPackage (module.js:136:13)
at Function.Module._findPath (module.js:218:20)
at Function.Module._resolveFilename (module.js:546:25)
at Function.Module._load (module.js:475:25)
at Module.require (module.js:597:17)
at require (internal/module.js:11:18)
at Object. (/usr/lib/node_modules/npm/lib/utils/unsupported.js:2:14)
at Module._compile (module.js:653:30)


#786

I think you are having a problem with your node installation. The file that is throwing this error is not used by the plugin but belongs to the npm command.
I would recommend to remove node and reinstall it once.


#787

Yeah... currently reinstalling everything on the pi. My skill set in anything Linux related is very limited (but i do know what sudo, nano, and directory commands are - woohoo!) ... I will give it a go and see what happens! Thanks!