[RELEASE] HubConnect - Share Devices across Multiple Hubs (even SmartThings!)

community_app

#586

SmartThings must have fixed a typo on their side because as of a minute ago, this is working again.

DTH= 'RGB Bulb' is one of my primary test devices for the SmartThings integration. I am able to miss a lot of nuances :slight_smile: but being able to set color in an RGB LED strip would have been an early test in the moments leading up to v1.3 release. :smiley: (my test device is a Qubino RGBW Controller attached to about 2 ft of RGBW LED strip.)


#587

I'm not using SmartThings at all. I'm 100% Hubitat.


#588

re-import the HubConnect-RGB-Bulb universal driver, please.


#589

works now! Thanks for the quick fix!


#590

Please help I have followed all the instruction to the t. (at least that's my belief) The configuration that I am trying is Hubitat-Master/ ST-Slave or controlled. I get my key and paste it to the smart app and get connected and no matter what I do the app in hubitat disappears, and st stays connected, since I have no app showing I can't add the device drivers or do anything. It behaved the same in 1.2 and since I removed the other hub events pusher that was working and the built in hub app Hub Link. What am I doing wrong?? I should at least get the habitat HubConnect app showing in order to install the device drivers. Right??


#591

I'd love to help but I'm not understanding that sentence at all. :frowning:
Apps disappearing??

There's 4 pieces of code to be pulled from Github and added to two hubs... one Hubitat, one ST.

App: HubConnect Server for Hubitat
App: HubConnect Server Instance
Driver: HubConnect Remote Hub

Those 3 get installed on Hubitat and are from/in the Hubitat folder of Github.

App: HubConnect Remote Client

Gets installed on SmartThings and is from/in the SmartThings folder of Github.

Having added the code, they have to be ready to run. From the words written:

...I'm ready to believe all of the above is correct, but I would ask for verification that it's the SmartThings version of Remote-Client that got deployed on SmartThings?

On Hubitat, you open the HubConnect App and get a Key, which can only happen if you have the App and it's child app working.

But here's where my mind can't follow.. "No app showing" Where?? ST?

Did you Publish the App?


#592

I checked "Receive mode changes from Client Hub" but the HE doesn't change mode when I change it in ST. Changes in HE do change the ST mode though.


#593

Did you also click Push Mode change to Server within ST's Remote Client?


#594

Thanks for your reply.

  1. the three pieces of code are installed.
    2.Remote client in smartthings with the latest code pasted and oauth enabled is installed.
    3.Sory for not being clear but the hubitat app once you hit done or return from setting up smartthing app is gone. That is "HubConnect app for Hubitat"
    I saw an earlier entry from Jason Joel: with the same problem but he re-installed and went away. I tried several times but no avail.
    4.When you go back to smartthins app It states that It's connected.

Hope this is clear. Thanks


#595

I don't see that option on the ST side. I only see options for the IP, connection key, and selecting devices to sync.


#596

I'm unable to duplicate... I created another remote instance. I don't have another ST hub, but I do have as many Homebridge instances....

Here are the steps I took:
25%20PM

Create a new Hub in the Server app.

34%20PM

Define the connection

09%20PM

Copy the key and click done to save the instance.

And then paste the key into the remote...

39%20PM

And it shows in the list of remotes in the server app.

39%20PM

Logs show:

dev:844 2019-04-14 02:43:35.831 pm info  Switching connection to HomebridgePi2 to http
dev:844 2019-04-14 02:43:35.621 pm trace Initialize virtual Hub device...

Note: Online is the default initial state. It takes the loss of several 'pings' to change to Warning, then to Offline. Therefore, ignore that initial apparent success.

At no time did the HubConnect App get deleted. At least for me. Please do NOT interpret that to imply I don't believe or something.. I do believe, just can't replicate.


#597

What I would try doing install the server app but do not do anything but click β€œDone” the first time around. Do not try to create a remote instance or anything. Just Done.

After that, go back to the app and create your SmartThings instance. I suspect that’s probably the issue at hand.


#598

That's what I had to do on the Hubitat side to get everything to show properly, too. Maybe worth considering adding to the install instructions if you make a future rev to them.


#599

Agreed. It appears that its a needed step. I'll get the instructions updated today.


#600

Thanks for the pull request. Unfortunately it was incomplete as each file has a full download path as part of the app definition which was missing from your PR. Please keep the feedback and suggestions coming! But I also don't want anyone being offended because as a rule I won't be accepting PR's to this repo as I already maintain a private development and testing repo. It's simply too much to manage with the limited time I have.

Instead, please continue to submit your suggestions in this (or other future) HubConnect threads.
I've noted your changes and have added them to the feature/fix list for HC 1.4! Your efforts won't go to waste!

Thanks!


#601

Now I have both hubs connected,
-First I decided to go back to an earlier backup where the OtherHub was not yet installed because I had errors in the log that there was IP conflicts with the ST Hub.
I installed the first three pieces of code. Opened the HubConnect server app in hubitat and entered the parameters and copied the key. Then hit Done as was suggested before and this time the app was there. And sure enough it stated that the ST hub was online!! Ok I forgot to delete/disable the ST Smartapp so I went to ST and the app would open and seem to work but when you hit connect to hub It would show a connection error. So I uninstalled and re-installed and entered the IP and Key and now no error. I will start installing the drivers in the ST side that I want to show in the hubitat. Well see. Thanks again.


#602

Hey VJV, In the last 2 days both of my Tradfri plugs fell off my mesh. Have you seen this? No errors I see in my logs. I did recently add a second sylvania 72922-A plug, but already had one without any issues.
Thank You


#603

I think you are using an incompatible device, I have no issues or Tradfri dropping the mesh. Please check the device compatibility list. Good luck.


#604

@srwhite It seems the 'online' status can introduce a false sense of things working correctly. Would it be useful to have an initial state of 'waiting' rather than 'online' until the client properly connected ? Also maybe an interim state of 'waiting' when the first client ping is missed until it eventually marks it 'offline' after 5 missed pings I believe.


#605

When I try to install the apps, I just get this error for each:

Metadata Error: Parent App 'shackrat:HubConnect Server for Hubitat' not found on line 25

Is there something I need to amend in the pdf install instructions?