[RELEASE] HubConnect - Share Devices across Multiple Hubs (even SmartThings!)

community_app

#566

With the frequent updates (Thank you, @srwhite) and the large number of ST drivers, I'd really like to be able to use the ST github repo update capability. I've tried the above parameters but I'm not seeing anything. Any hints?


#567

To make sure I understand, this would be the Hubitat driver, right? In that case, I can't modify it (it's a stock driver). But I looked through the ST DTH source for the Zen and, while otherwise questionably written (string comparisons for numbers?), they do indeed appear to use toBigDecimal and toDouble throughout (including when setting the heating or cooling setpoint). Not sure if maybe the rest of the Hubitat drivers also do something like this and that's why I'm the only person noticing these because I'm the only person who's tolerated having a Zen Thermostat this long. :slight_smile:


#568

26%20AM

It''s been forever since I used SmartThings and it's github integration, but that at least saves.

No idea how SmartThings translates those fields into:

https://github.com/HubitatCommunity/HubConnect/tree/master/SmartThings


#569

Owner = HubitatCommunity
Name = HubConnect
Branch = master

Nothing will show up when you click on update from repo if your code is current.


#570

Have you tried this? Is there an extra step to get the files to appear? There are many I've never added plus all/most of mine would eave been out-of-date and I still didn't see anything yesterday when I try it this way.


#571

I've got the repo added. As I've mentioned, nothing shows when I click update from repo since all of my code is current.


#572

...but how about when it's not current? :slight_smile: As I mentioned, that's my problem. Nothing shows up for me now (not unexpected). But nothing showed up for me then, either. The values saving into my IDE settings isn't a problem.


#573

In the ST IDE, click on my SmartApps. You'll see the HubConnect Remote Client app listed.

Click on the 2nd icon, which is the edit app icon.

Scroll down to Source Code Options and click on the link to expand the box. Within that box, chooseHubConnect (master).

For your device handlers, click on My Device Handlers to bring up you device handler list. For each Hubitat device handler, click on its name followed by the Device Type Settings button on the upper right. Change GitHub Repository to HubConnect (master).

This should now allow you to be able to update the apps and drivers from the repo.


#574

Thanks, @jkudave. That was a learning experience for me. Now, I'm just waiting for an update.

One question: With all the other github repos I've listed, the update also shows new apps/drivers (3rd pane in your example) that aren't actually installed yet. What's the difference that causes new apps not to show up when I do it this way?


#575

I'm not 100% sure on that. It may be because the apps and drivers were initially installed by copying and pasting the code (at least that's how I did it). It's also possible that @srwhite has to do something in the repo to allow installing and updating from it.


#576

Thanks, I am going to take a look at that


#577

This technique does not point to the repo properly. Not "deep enough" anyway.

Black
Indicates that the file is unchanged between your forked GitHub repository and the IDE.
Green
Indicates that the file is in the IDE only, and not in any repository.
Blue
Indicates that the file exists in your GitHub repository, and has been modified in the IDE but not committed to the repository.

all of mine show green, meaning there is no repo to compare to.

As I go to that ST page, everything is blue becomes green in a second or so.


#578

Yeah, I just noticed that too. That, to me, indicates something else needs to be done in the repo to allow for installs/updates. I've installed, as others have, other apps and drivers from different repos and they show updates. Perhaps with this app it's because we all initially installed by copying the code into ST, rather than installing directly from the repo. Like I said, I'm not 100% sure on this one.


#579

Homebridge just crashed on me. I had to reinstall your plugin to get it to come back up. Threw this error while trying to load the plugin:

[4/13/2019, 6:32:51 PM] Error: The requested platform 'Hubitat-HubConnect' was not registered by any plugin.
    at API.platform (/usr/local/lib/node_modules/homebridge/lib/api.js:134:13)
    at Server._loadPlatforms (/usr/local/lib/node_modules/homebridge/lib/server.js:327:45)
    at Server.run (/usr/local/lib/node_modules/homebridge/lib/server.js:90:36)
    at module.exports (/usr/local/lib/node_modules/homebridge/lib/cli.js:59:10)
    at Object.<anonymous> (/usr/local/lib/node_modules/homebridge/bin/homebridge:17:22)
    at Module._compile (internal/modules/cjs/loader.js:701:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:712:10)
    at Module.load (internal/modules/cjs/loader.js:600:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:539:12)
    at Function.Module._load (internal/modules/cjs/loader.js:531:3)
    at Function.Module.runMain (internal/modules/cjs/loader.js:754:12)
    at startup (internal/bootstrap/node.js:283:19)
    at bootstrapNodeJSCore (internal/bootstrap/node.js:622:3)

#580

Was the plugin running before? That looks like that Homebridge wasn’t able to find the plugin at all to load.


#581

Can you show me the device states for one of the Iris sensors?


#582

yeah, everything was running fine, then it all just seemed to crash. reinstalled the plugin and it all came back up. kinda weird.

for device states I assume you just mean the variables?

Current States
  battery : 100
  batteryVoltage : 2.9
  humidity : 48
  motion : inactive
  temperature : 68

State Variables
  tempOffset :  **0** 
  sensorTemp :  **65.74**

#583

@jkudave @bertabcd1234

The files in the repo need to be renamed like this to be able to install/update directly from the repo in the SmartThings console:
https://github.com/HubitatCommunity/HubConnect/pull/2

(First post so I can't post links yet...)

Hopefully the PR gets merged quickly.


#584

I'm running into an issue where I can't set a color on a group of RGB bulbs. I have a RM rule setup to turn my bedroom lights on and make them white when there is motion during the day. It's not working and I'm getting errors in the logs.


#585

And if I tell the rule to use the lights directly, instead of the group, I get this: