[RELEASE] HubConnect - Share Devices across Multiple Hubs (even SmartThings!)

I'm having trouble duplicating this one... As always, I believe you're seeing an error, what I can't do is click the right things to get it to happen here.

Your hints are: it's on a Remote hub, so the 'real device' is implied to be on the Server. That's being mirrored to the remote, which needs the custom driver.

I created a custom device per the screen cap and deployed the driver. Is that all you do to get the error?

@csteele

Sorry I didn't specify, for me the real device is on a remote hub and trying to add to the Server hub. The funny thing is I tried it again after trying it several times many different ways on Friday and it worked now.

@TechMedX, here's how I did it.

  1. Added the driver here on my post above on the Server: [RELEASE] HubConnect - Share Devices across Multiple Hubs (even SmartThings!)

  2. Add a Custom Driver on Server doing the following:
    image

  3. Attributes match the driver exactly with powerMeter being primary attribute then Save Driver.

Update: Add "energy" as attribute too, forgot to add it till afterwards.

  1. On Remote hub where real device is, on HubConnect Remote Client App add the device with the Custom Driver that was made above.

  1. Now this device is added on the Server Hub:
1 Like

@bfara83 @csteele I set it up exactly as you have there, and I still get error on 418 :frowning_face:

Well at some level they must match for the computer. An ID is basically a name. :wink:

Thanks for the response. I’ve decided to change my naming conventions and now must pay the price.

The computer, this case the Hub, uses DNI as the unique ID. Both Name and Label are able to be changed with no ill effects on the Hub.. but Change the DNI, and you're in for some amount of heartache.

1 Like

It's the real device on server or remote hub?

the real device is on the remote hub. I have all devices on the remote hub, and just HC on the server.

Yeah, I get that. I was just joking. I mean the DNI is really just a name. :yum:

I'm still unable to duplicate.

I deleted the old Custom Device and started over. I created a new one with 14 attributes, from powerMeter to energy.

I don't have a HEM, so on a Remote Hub, I created a virtual device using the built-in 'real' driver: Aeon Home Energy Meter. I then mirrored that back to the Server.

No errors. So then I did a refresh and a Config on the 'real' device on my Remote Hub. Again, no errors:

Remote Logs:

app:193 2020-05-17 10:20:18.475 am info  Received device update request from server: [308, type aeotechomeenergymonitor]
dev:308 2020-05-17 10:19:57.307 am debug [7004650400000004, delay 100, 70046F040000012C, delay 100, 7004660400000008, delay 100, 700470040000012C, delay 100, 7004670400000000, delay 100, 700471040000012C]
app:193 2020-05-17 10:18:53.273 am info  Skipping event subscriptions...  Using event socket to send events to server.
app:193 2020-05-17 10:18:52.763 am warn  The device [pseudoHEM] does not support the command refresh.
app:193 2020-05-17 10:18:52.747 am info  Received command from server: ["pseudoHEM": refresh]
app:193 2020-05-17 10:18:50.968 am info  Sending custom devices to remote: aeotechomeemergymonitor - [[id:308, label:pseudoHEM, attr:[[name:power, value:null, unit:W], [name:energy, value:null, unit:]]]]

Server Logs:

app:105 2020-05-17 10:20:17.890 am debug Requesting device sync from ZeeFourth: pseudoHEM
app:105 2020-05-17 10:18:52.231 am info  Sending refresh command to HubConnect Server.
app:105 2020-05-17 10:18:50.839 am trace Creating Device HubConnect Aeotec Home Energy Monitor - pseudoHEM... 192.168.7.65:308...

Because I don't actually have a 'real' device, there's not much in the Driver Info page to click.

What does Line 418 show for you on HubConnect Remote Client?

I did get it working when I tried this morning again with a real device, not sure if I had a space on one of the attributes or something when I tried on Friday.

hi @csteele, quick q for you. i've setup hubconnect, got it all running beautifully and it feels very robust. sweet. however, one thing: i'm trying to make an aeon wallmote quad available from one hub to the other, but it's not appearing on the second hub. i've installed the hubconnect button driver as advised, but it's not showing up. any clues? (i know the basics work as i've got a ton of zigbee bulbs and groups happily shared cross hub)

ta

Not sure what that means. The device is not mirroring? Or attributes are not mirroring?

I have two.. one on each of two hubs:

And when I tap button 1:

Screen Shot 2020-05-19 at 8.02.10 AM

Logs show:

app:748 2020-05-19 08:01:55.637 am info Received event from ZeeRadioFront/Aeon WallMote: [pushed, 1 null]

app:2 2020-05-19 08:04:14.214 am info Received event from ZeeRadioLower/Aeon WallMote 1: [pushed, 4 null]

Sorry wasn't clear - it's not mirroring at all. How do I get those logs? That'll help I guess!

Right click on the word Logs at the bottom of the Left menu. Open Link in new tab.

Screen Shot 2020-05-19 at 8.10.27 AM

Ah right - the standard Logs. I see pretty much just this relating to the Aeotec

That's the log entry for you clicking Done on an instance.

But keep watching and click a button on your WallMote.

Not seeing anything from the Wallmote, but I am seeing this which is weird:

Especially when you consider it's actually working and sending commands to the LIghtify bulbs very happily.

As you Done out of selecting devices, HubConnect sends a full list of the selection to it's connected hub. If you watch the logs on the connected hub, the receiver, you should see every device scroll by. Any that don't exist get created. Any that already exist get "skipped".

You need to carefully inspect logs showing an attempt to be created, but fail.

Download the Hubitat app