[RELEASE] HubConnect - Share Devices across Multiple Hubs (even SmartThings!)

That's what I had to do on the Hubitat side to get everything to show properly, too. Maybe worth considering adding to the install instructions if you make a future rev to them.

Agreed. It appears that its a needed step. I'll get the instructions updated today.

Thanks for the pull request. Unfortunately it was incomplete as each file has a full download path as part of the app definition which was missing from your PR. Please keep the feedback and suggestions coming! But I also don't want anyone being offended because as a rule I won't be accepting PR's to this repo as I already maintain a private development and testing repo. It's simply too much to manage with the limited time I have.

Instead, please continue to submit your suggestions in this (or other future) HubConnect threads.
I've noted your changes and have added them to the feature/fix list for HC 1.4! Your efforts won't go to waste!

Thanks!

4 Likes

Now I have both hubs connected,
-First I decided to go back to an earlier backup where the OtherHub was not yet installed because I had errors in the log that there was IP conflicts with the ST Hub.
I installed the first three pieces of code. Opened the HubConnect server app in hubitat and entered the parameters and copied the key. Then hit Done as was suggested before and this time the app was there. And sure enough it stated that the ST hub was online!! Ok I forgot to delete/disable the ST Smartapp so I went to ST and the app would open and seem to work but when you hit connect to hub It would show a connection error. So I uninstalled and re-installed and entered the IP and Key and now no error. I will start installing the drivers in the ST side that I want to show in the hubitat. Well see. Thanks again.

1 Like

Hey VJV, In the last 2 days both of my Tradfri plugs fell off my mesh. Have you seen this? No errors I see in my logs. I did recently add a second sylvania 72922-A plug, but already had one without any issues.
Thank You

I think you are using an incompatible device, I have no issues or Tradfri dropping the mesh. Please check the device compatibility list. Good luck.

@srwhite It seems the 'online' status can introduce a false sense of things working correctly. Would it be useful to have an initial state of 'waiting' rather than 'online' until the client properly connected ? Also maybe an interim state of 'waiting' when the first client ping is missed until it eventually marks it 'offline' after 5 missed pings I believe.

When I try to install the apps, I just get this error for each:

Metadata Error: Parent App 'shackrat:HubConnect Server for Hubitat' not found on line 25

Is there something I need to amend in the pdf install instructions?

1 Like

Maybe i need some more coffee, but im having a hard time setting up the HubConnect app to connect to smartthings. I started last night and was making progress, but got to the point where in HE i was adding a server and kept getting an error saying Oauth needed to be enabled, even though it was. And on the ST side it is asking for a Server Connection key and i dont see where i get that.

So i thought i should start over, i must have missed something. Deleted the apps and driver in HE. But now after i install the apps code, no new app shows up in the list of Apps. ive tried 3 times this morning. Im not sure what im missing. ive installed dozens of apps/DTH in smartthings and this process isnt all that different, but im not sure where im missing something. I cant even get the app to show up in the Apps list in HE.

any tips or tricks, or ideas? Im not sure where im going wrong and am getting frustrated. I know it should be easier than this but im getting stuck

Welcome to HE.

Did you enabled oauth in HE and ST?

You get the key when adding hubs on the server app, then you use the key on the remote hub.

Did you follow the instructions on the PDF? It's in the github.

Oauth is (was?) enabled in both but for some reason it doesnt seem to save in HE? I enabled it again in HE and it looks good now, but its still not showing up in my list of Apps. I see both apps in the Apps code and see that Oauth is still enabled on the server instance but i dont see it in the list of Apps.

that PDF is what ive been using, yes

The 20000 ft overview is...

Add the 2 App code to Your Hubitat Hub you picked to be Server. Add 1 Driver code too. Server needs oAuth enabled. Install User App (click done.)
05%20AM

On SmartThings, add 1 App code. Enable oAuth. "Publish for Me"

At this point BOTH systems should have an App displayed.

On Hubitat, Server App, create a remote Hub (Your name for it, it's IP address, type -- ST, Hubitat or Homebridge) Save the KEY, click done.

At this point, the list of Apps will show HubConnect and child apps for the hub you just created:
50%20AM
Click Server and you should see the same list: (but with your hub names, of course)
21%20AM

On your SmartThings hub, In Automation (Not Marketplace) open the HubConnect Remote Client then Connect to Server Hub, and enter your Hubitat Server Hub's IP address and paste in the KEY you captured above.

I thought i had it all worked out. Ive got the apps installed and ST is showing up in HE and was online. I left to get lunch and now its showing offline, even though my ST app tells me it is online.

As is mentioned, Online is the initial state and a fail of the 'ping' will shift it to Warning, then Offline. Therefore, Offline is the believable state.

The connectivity is LAN based. Both Hubitat 'Server' Hub and SmartThings 'remote' are on the same LAN and should have no trouble communicating.

What are your Logs saying?

app:42  2019-04-16 09:24:00.088 am trace Received ping from ZeeRadioLower.
app:644 2019-04-16 09:23:53.073 am trace Received ping from ZeeHomebridge.
app:41  2019-04-16 09:23:48.087 am trace Received ping from ZeeRadioUpper.
app:488 2019-04-16 09:23:44.260 am trace Received ping from ZeeSmart.

it looks like its trying to bring in all of the ST devices i authorized but failing, then it shows the hub is offline. I cant add an image, though, i get an error "sorry you cant put an image in a post"

If you have no connectivity, fix that first. The list of devices is unnecessary at the stage you are describing.

If the hub is Offline, you must get that fixed before any form of device exchange could be attempted.

ST is online, i can control devices and ping it from the PC im setting up HE on. SE shows its connected as the client.

i removed all but 1 device and now it shows online in HE but the device i added isnt showing up yet.

"Online/Warning/Offline" are states of the communications between the Hubs, specifically for HubConnect. Yes, I'm assuming your hubs are powered on and otherwise working. However, it's clearly telling you that the two hubs are unable to exchange http: traffic.

Imagine the simplest example of this... you tell Hubitat Server instance that your ST hub is at 192.168.1.111 and in reality it's at 192.168.1.121 You would be able to work with either in your browser because you have them bookmarked etc. But they would be unable to establish a conversation between each other.

Did you added the key to ST HubConnect app?

Download the Hubitat app