[RELEASE] Hub Watchdog - Simple way to monitor if your hub is slowing down or not

Hmm. Interesting...
(results for a virtual switch)

Obviously some witchcraft going on inside my hub in the middle of the night. Yet nothing obvious in the logs. Weird.

How is this for a result? This is my Z-wave network.

Number of Data Points: 80
Over Max Threshold: 194
Over Warning Threshold: 141
Current Max Delay: .500
Current Warning Delay: .400

Mean Delay: 21.984
Median Delay: 0.548
Minimum Delay: 0.447
Maximum Delay: 1717.222

My Virtual and Zigbee are better but there are lots of Virtual device over threshold.


Number of Data Points: 80
Over Max Threshold: 2
Over Warning Threshold: 134
Current Max Delay: .500
Current Warning Delay: .400

Mean Delay: 0.119
Median Delay: 0.109
Minimum Delay: 0.076
Maximum Delay: 0.207


Number of Data Points: 80
Over Max Threshold: 1
Over Warning Threshold: 2
Current Max Delay: .500
Current Warning Delay: .400

Mean Delay: 0.254
Median Delay: 0.248
Minimum Delay: 0.187
Maximum Delay: 0.355

Bummer, ok..

I question the validity of your results. How can you have Over Threshold events when your Maximum Delays are under those threshold settings?

1 Like

Good question, but the number of them has greatly grown since I posted my numbers 3 days ago. The raw data looks OK, so I don't know what is up?

Here is one set of Virtual device data, they all look similar.

09-29 16:23 - 0.107
09-29 16:13 - 0.098
09-29 16:03 - 0.102
09-29 15:53 - 0.108
09-29 15:43 - 0.11
09-29 15:33 - 0.087
09-29 15:23 - 0.134
09-29 15:13 - 0.111
09-29 15:03 - 0.085
09-29 14:53 - 0.162

The Zwave on the other hand is pretty bad comparatively speaking.

09-29 13:37 - 0.513
09-29 13:07 - 0.455
09-29 12:41 - 0.453
09-29 12:40 - 0.527
09-29 12:38 - 0.507
09-29 12:37 - 0.589
09-29 12:08 - 0.457
09-29 12:07 - 0.507
09-29 11:37 - 0.488
09-29 11:11 - 0.568

So I noticed when the 80 data points are filled up, it stops getting new data. Is there a way to make it roll the data First In Last Out style? Otherwise, once it's full I have to clear data manually and start over?

I don't think that looks too bad and it's consistent. Remember, a Z-wave command has a radio network to traverse, whereas a command for a virtual device doesn't have to travel.

1 Like

3am is the time for the hub to clean and backup.

1 Like

Ah, that could explain why the lights are so damned slow when I'm wondering around the house in the middle of the night in my nightgown and slippers looking for a late night tipple :smiley:

New version on Github...

Child - Examiner:
V1.0.1 - 09/30/19 - Lots of little changes

V1.0.8 - 09/30/19 - Lots of little changes

Aha - I think I have clear indication that my hub is slowing down. Here are the raw data for Virtual, Zigbee, and Zwave devices:


All three of them indicate an increase in response time beginning around 2:30-3:00AM this morning.

That's about the time when the automatic HE backup runs....

Yup. Also, my offline backup occurs at 2:30AM.

But the slowdown has continued to ~now. And didn't happen yesterday, day before, etc.

That's interesting...

I'm going to wait till tonight to reboot the hub. I'm curious to see if the slowdown will clear itself.

As the day has progressed, it is definitely gotten worse.

So, this is the first time that I have been able to document that as my rules appear less responsive, that other processes on the hub also slow down.

this is not that bad. You have to realize that for Zwave is 1. still acceptable value
it can hop in an unpredictable way between repeaters.
you practically measuring the quality of your Z-Wave network that can be dependent on many things specifically cellphone interference.

A virtual device is what determines the speed of your hub automation.

if a virtual device is slow then you have to start eliminating automation or devices causing it. You will probably find some third party app or handler and magically increase your speed.

Everything (zigbee/z-wave/virtual) is slowed down. Disabled all non-Hubitat-developed apps, and it hasn't changed (look at my earlier post for virtual & zigbee delay times).

Start disabling Hubitat app then.
But first completly shut down the hub, disconnect from power for 30 sec.
do Zwave repair.

1 Like

my virtual device was 0.3 -0.4 and I discovered that my hub connect was connected to smarttings hub on different IP than it really was.
I deleted it and now I'm on 0.1