[RELEASE] Hive Active Plug (UK Only)

Nothing special about this driver, basic on / off / configure.

  • Tried Generic Zigbee Outlet - Device state refused to update when toggling
  • Tried Generic Zigbee Switch - Nothing works
  • Tried Generic Zigbee Bulb - Works fine, but I didn’t need the set level aspect

No idea why Generic Outlet / Switch failed… without seeing the built in driver code there’s no way for me to check.

Anyway, for the handful of UK users out there… hope this helps (makes a good Zigbee repeater seeing as we cant buy the ST outlets anymore)!

3 Likes

Ordered my hub today, and getting all links in place to set it up when it arrives, cheers for this Robin as I have only one (use as a repeater). I nearly overlooked this, but trawling the [RELEASE] posts got me there. :slight_smile:

Cheers
Roy

1 Like

Is there a Hive hub or anything needed for this to work with HE? Or can you just plug it in and pair with HE? Ive tried looking for ST power outlet but they are out of stock everywhere, or silly price on amazon (over £100) so trying to look for an alternative socket.

Thanks

Worked for me by just pairing and using the driver above :+1:

1 Like

Does this driver support power usage reporting?

Plug is on deal of the day sale at £22.99 on Amazon at the moment.

Checking the Hive site, I dont believe it has this option. Its simple on/off.

To confirm from the Systronics RF platform I'm migrating from, this SLP2b smart plug has no power usage information on this system either. Bit of a shame, as it's a great repeater and its predecessor did report power.

Personally I can recommend the Salus SP600 instead. The community driver supports power reporting with it.

@andydvsn Any ideas where to get that Salus plug these days?

They crop up on eBay from time to time, but this looks like the cheapest right now at £30. Never used that supplier though.

Or, if you don't need power reporting I can genuinely recommend the £7.99 ones from Lidl if your local store has any left. Fire up my driver for that and you're good!

@andydvsn the main reason I want a Salus one is because of the green/red light on it.
I find now and then the Hubitat hub locks up, when this happens the Salus goes Red.
So i want to put one of my desk in my office so i get an alert when it goes offline so I can reboot it quicker than waiting for the wife to tell me things arent working :slight_smile: - do the Lidl ones have a similar light?
Also those £30 ones have £10 delivery, have spoke to the company and they won't budge on this

Ten quid delivery?! Pfft, are they bringing it to you in person?

The Lidl ones only have a single white on/off indicator LED on them which I've never seen do anything other than flash after a reset. I don't know what the red indicator on the SP600 means, though I assume it's a network error of some kind.

The LED on the SP600 is full RGB. A couple of times when resetting them I've managed to get the plug into a mode where it'll cycle the colours through red, green and blue. I suppose it could do colour mixing... in fact yes, I'm sure I've had one show yellow once.

I'm sure someone from Salus has a clue what that's all about, but not me. :joy:

I have only ever seen red and green, green usually means it can see the hub and red when it doesnt so i figured it will be a good indicator when the hub is playing up..

I guess though for £40 to get the WAF better it's worth it lol

1 Like

One just appeared on eBay if you're still in the market (auction, ends 17th Jan).

Nice one, cheers for the headsup!
Have ordered 4 from a supplier that charges £10 delivery for now but always find a use for more!