[Release] Google Home Assistant Relay Driver (v1 and v2)- text to speech on Google Home devices



If I issue a "[CCC]set volume to 50 on Office Speaker", my google home mini called "Office Speaker" wakes up and says OK. Unfortunately, it does not change the volume.

Try adding the "on YOUR GOOGLE DEVICE" at the end of your string to see if it wakes up and says something to you. Then you still need to make sure it actually did the action your requested.


I tried [CCC]set volume to 50 on Kitchen Speaker, but I don't get anything in the console or any spoken response. "[CC] What time is it?" responds in the current time in the console, but "[CCC] What time is it?"gives no output.


Using the following command, I get a correct voice notification from my one, and only, Google Home Mini.

[CCC]What time is it?

The mini wakes up and replies "The time is 3:40pm."

If I send "[CCC]What is the weather?"

She says "Grab your sunglasses today." or "Don't forget your sunglasses." or "Grab sunglasses." or "You might want sunscreen today." BUT, she won't give me the real weather report like she does when I ask her out loud directly.


According to developer of google-assistant-relay if the custom command requires a web-query (check the weather) it will not return the expected result with converse=true.


I'm getting nothing. Just tried "[CCC]What time is it?", but nothing shows in the console. @ogiewon, do you also have the google-assistant SDK installed or did you only install assistant relay?


I only installed assistant-relay




If you just do a straight broadcast, does it announce on all your google devices?


Broadcast command hits all devices on the same subnet by design. So yes, it does.


Maybe the version of Node I'm using is an issue? Not sure why [CCC] gives me no output. I tried to get Assistant Relay going on a PiZero W, but after hours of trying to get the authorization page to open, I gave up and reinstalled on my Homebridge Mac under Node 6.10.2 and it worked instantly.


I'm running the Ubuntu LTS version of Node. Yes I have heard newest version causes problems with assistant-relay.


And, for whatever reason it now works! I'm not sure what I've done differently. I was trying stuff in the driver code, it didn't work, so I pasted @ogiewon 's code back in and it started working. :confused::relieved:


If I issue [CC]set volume to 20, the console shows "Okay" and of course [CCC] will cause it to speak that response. When I verbally ask the mini when the volume is, it speaks the response, "the volume is set to 60%". Now if without changing a thing, I issue "[CCC]what's the volume?", I get a spoken response, "The volume is set to 20%".

So it's changing the volume, but on Assistant only.


So even though the set volume part doesn't work on my mini, this is a pretty amazing addition Dan. I can now turn devices on and off from Hubitat (albeit via cloud) that are not directly supported by Hubitat, but are supported by Google Assistant!

Love it! Thank you very much for the effort you put into this.


For some reason I cannot get this to work. I used the device handler, my relay server is up and running, but nothing happens.


Have you verified that the assistant-relay is working properly without Hubitat? Assuming you’re running on a Raspberry Pi, you can use curl to issue the proper commands to test it out.

Some User on the ST forum are having issues from the google side of things. So it is important to make sure your assistant-relay is working properly before trying to use my Hubitat Driver.


I agree. Make sure you have the assistant part working. Did you follow these directions...

Also, may not be the same, but I was having a problem getting the [CC] and [CCC] features working, so after playing around with the code, I ultimately ended up pasting Dan's original code back in and clicked "Save", and that's when it started working. Not sure if that was a coincidence, but anecdotally, that's what I did.


Works now, no idea why it took so long but hey!


Works for me! Thanks to @ogiewon for bringing this to Hubitat and for coaching me through my first-ever-rPi experience. Google just sold a couple more Home Minis.


@ogiewon I noticed the developer of the relay has released a version 2.0 "beta" will this change require a new driver for it work with hubitat?