[Release] Google Home Assistant Relay Driver (v1 and v2)- text to speech on Google Home devices

Confirming it works w/GAR 3.x - I installed your driver, created the virtual device, and my pistons are speaking like parrots. :wink:

1 Like

Very helpful discussion, I am new to Hubitat and have the Asistant relay working and commands from Hubitat working in Virtual Devices, not sure if I am missing the obvious but I cant seem to save the text commands in the virtual device. I select save preferences and save the device go back in and no device notification or speak command is saved. Is this only for testing ? do you have to use rule manager to send saved action and commands to GAR ? Any help would be appreciated
Hubitat Version 2.2.3.119

Yes, you would use Rule Machine, Hubitat Notifications, or any other App that is capable of calling the commands with the GAR Device Driver.

The commands that you’re executing directly with the device details page is simply for testing purposes.

I appreciate the quick response thanks for clearing it up

1 Like

guys, I am using this google assistant relay driver V3 and I prefer it above other solutions only because if I have music and there is a voice notification the music will resume after the notif but there are some cons such as there is an annoying voice saying "broadcast from user" followed by the notification itself and the notifications are just sent to ALL the google devices I have with out the option to select an specific device to broadcast to and it could be as well because when using the broadcasting function triggered by my voice to spread a message it works the same only able to send to all devices at the same time together. The good news are that today I found that I am able to broadcast messages to an specific device, so when I say with my voice "broadcast x message to kitchen speaker" it will actually do it to that specific speaker only. I am wondering if with the google assistant relay driver this is now as well possible, if anyone know I will appreciate

Have you tried doing exactly what you mentioned above via this driver? See below for tips...

it worked one time but with the same command it did not work the following ones, I will continue trying, thanks

1 Like

I'm running into a couple issues with GAR (v3, driver v2), and hoped someone may have already figured these out.

  1. I can get broadcasts to work (same gripe at Google about lead in announcement), I can get [P] commands to work. However, if I try [CC] or [CCC] commands, they come out as broadcasts of the commands, but no responses (I'll be honest I'm not sure which one is supposed to be the silent one because they always just broadcast). I did try testing using Greg Hesp's sandbox on the server, and even with the json that gets sent, I still get the same results. I did find that if I use the very generic "tell me a joke", then I do actually get the joke stated (or on the popup message if using the converse=false). However if I switch to something like "what's the weather" then it just broadcasts the command (this is a question I have no trouble getting a response accurately when I say it to an actual Google Home). On the popup on the sandbox it says there's no text result. I can't tell if this is a nodejs issue, a driver issue, or maybe it's a Windows issue?

  2. My only option right now for hosting nodejs is on a Windows 10 computer that stays on all the time. I think I got a service setup to run it even when not logged in, but it seems to stop working if someone else logs in that doesn't have administrator rights. Does anyone know the OS well enough about why that may be?

First, just to be clear, I have not used GAR in quite some time. So, I am replying based on my experience quite some time ago... You may want ask Greg Hesp directly by posting an ISSUE in his GitHub repository for the latest, up to date answers.

[CC] = custom command, there should be no broadcast if this is properly used as a prefix. For example, “[CC]turn on hallway lamp” - this would turn on a light named “hallway lamp” that is connected to Google Home.

[CCC] = custom command with conversation. “[CCC]tell me a joke” would hopefully result in a response from a google home device. However, this is very, very limited in functionality. Most things result in no response whatsoever. This is normal and has nothing to do with your setup.

@ogiewon
Thank you for the clarification. I don't yet have devices installed that could be voice controlled by Google as I'm just starting out, so that will be something I need to try. Also, due to my novice situation, I don't know much about GitHub, but I'll gladly ask Greg. From your answer it sounds as if the limitation is Google's. I mean really...make the joke work, but not the weather? :rofl:

I am having a problem and I just can't figure it out. It seems like I may have a Google issue but not sure. I am walking through the instructions and going step-by-step but I just cannot get past the OAuth consent screen. I created the project, enabled the API, go to create the OAuth but it insists I edit the consent screen first.

Throw my email in the user support email and the developer contact information email addresses, App name is already filled in for me, Authorized domains is already filled in for me, leaving everything else. Click SAVE AND CONTINUE and it shows “An error saving your app has occurred” and nothing more. Anybody else seen or dealt with this? I just cannot get past this at all.

Is it possible to play rain sounds with googles 'sound machine' feature ?

are there any plans to support V3 of relay? or does the V2 driver work on V3 of relay? thanks

Yes

I is working perfectly... as mentionned... super easy

Thank you very much... WAF is going way up with this.... I will pay you a couple beer ...

Thanks

For anyone who may not have a RasPi but runs an unraid/docker server there is a great docker available which runs 3.2 and interfaces perfectly.

I can assist with docker config if needed

edit:

1 Like

Hi,

I'm migrating from ST to Hubitat and I'm trying to understand what do I need to do to get AR working. I have been using it on ST side and broadcast by using webcore pistons. Now I copied my pistons from ST WC to hubitat WC and none of my broadcasts goes through.
I thought (I could be very wrong) that since nothing changes (ar server ip is same) I just continue to broadcast to same destination address with same destination port..but now I'm clearly missing something.

This could be the part where I'm really stupid but ...
Do I need to install AR drivers (?) to hubitat if I'm just broadcasting to ip address and port where AR has been and still is running?

You shouldn't need to install drivers for GAR on Hubitat if you're simply making the http calls within webCoRE.

However, as a quick test, you could install the Hubitat driver, create a virtual device using that driver, and try sending a notification to your Google device just to see if that works. If it does, you know that the problem may be within the webCoRE piston. If it does not work, then there is some work to do still...

Before I give it a try.. am I right that piston does not need to be changed to different form or something?

This has been working solid in ST side and I believe that it should work in hubitat side too.

I do not use webCoRE, and thus I really cannot assist.

Download the Hubitat app